OSDN Git Service

first commit
[slackware/slackbuild.git] / powertop / powertop.SlackBuild
1 #!/bin/sh
2
3 # Copyright 2010  Patrick J. Volkerding, Sebeka, MN, USA
4 # All rights reserved.
5 #
6 # Redistribution and use of this script, with or without modification, is
7 # permitted provided that the following conditions are met:
8 #
9 # 1. Redistributions of this script must retain the above copyright
10 #    notice, this list of conditions and the following disclaimer.
11 #
12 #  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13 #  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14 #  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15 #  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16 #  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17 #  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18 #  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19 #  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20 #  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21 #  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23
24 PKGNAM=powertop
25 VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
26 BUILD=${BUILD:-1}
27
28 # Automatically determine the architecture we're building on:
29 if [ -z "$ARCH" ]; then
30   case "$( uname -m )" in
31     i?86) export ARCH=i486 ;;
32     arm*) export ARCH=arm ;;
33     # Unless $ARCH is already set, use uname -m for all other archs:
34        *) export ARCH=$( uname -m ) ;;
35   esac
36 fi
37
38 CWD=$(pwd)
39 TMP=${TMP:-/tmp}
40 PKG=$TMP/package-${PKGNAM}
41 rm -rf $PKG
42 mkdir -p $TMP $PKG
43
44 if [ "$ARCH" = "i486" ]; then
45   SLKCFLAGS="-O2 -march=i486 -mtune=i686"
46   LIBDIRSUFFIX=""
47 elif [ "$ARCH" = "s390" ]; then
48   SLKCFLAGS="-O2"
49   LIBDIRSUFFIX=""
50 elif [ "$ARCH" = "x86_64" ]; then
51   SLKCFLAGS="-O2 -fPIC"
52   LIBDIRSUFFIX="64"
53 else
54   SLKCFLAGS="-O2"
55   LIBDIRSUFFIX=""
56 fi
57
58 cd $TMP
59 rm -rf ${PKGNAM}-${VERSION}
60 tar xvf $CWD/${PKGNAM}-$VERSION.tar.?z* || exit 1
61 cd ${PKGNAM}-$VERSION
62
63 # Make sure ownerships and permissions are sane:
64 chown -R root:root .
65 find . \
66   \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
67   -exec chmod 755 {} \; -o \
68   \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
69   -exec chmod 644 {} \;
70
71 # Build and install:
72 make || exit 1
73 make install DESTDIR=$PKG || exit 1
74
75 # Move man pages:
76 mv $PKG/usr/share/man $PKG/usr
77
78 # Strip binaries:
79 find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
80   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
81
82 # Add a documentation directory:
83 mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
84 cp -a \
85   COPYING* README* \
86   $PKG/usr/doc/${PKGNAM}-$VERSION
87
88 # If there's a ChangeLog, installing at least part of the recent history
89 # is useful, but don't let it get totally out of control:
90 if [ -r ChangeLog ]; then
91   DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
92   cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
93   touch -r ChangeLog $DOCSDIR/ChangeLog
94 fi
95
96 mkdir -p $PKG/install
97 cat $CWD/slack-desc > $PKG/install/slack-desc
98
99 cd $PKG
100 /sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
101