OSDN Git Service

first commit
[slackware/slackbuild.git] / choqok / choqok.SlackBuild~
1 #!/bin/sh
2
3 # Slackware build script for choqok
4
5 # Copyright 2010  David Woodfall <dave@dawoodfall.net>
6 # All rights reserved.
7 #
8 # Redistribution and use of this script, with or without modification, is
9 # permitted provided that the following conditions are met:
10 #
11 # 1. Redistributions of this script must retain the above copyright
12 #    notice, this list of conditions and the following disclaimer.
13 #
14 # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
15 # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
16 # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
17 # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
18 # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
19 # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
20 # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
21 # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
22 # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
23 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
24
25 PRGNAM=choqok
26 VERSION=${VERSION:-1.0}
27 BUILD=${BUILD:-1}
28 TAG=${TAG:-_SBo}
29
30 if [ -z "$ARCH" ]; then
31   case "$( uname -m )" in
32     i?86) ARCH=i486 ;;
33     arm*) ARCH=arm ;;
34        *) ARCH=$( uname -m ) ;;
35   esac
36 fi
37
38 CWD=$(pwd)
39 TMP=${TMP:-/tmp/SBo}
40 PKG=$TMP/package-$PRGNAM
41 OUTPUT=${OUTPUT:-/tmp}
42
43 if [ "$ARCH" = "i486" ]; then
44   SLKCFLAGS="-O2 -march=i486 -mtune=i686"
45   LIBDIRSUFFIX=""
46 elif [ "$ARCH" = "i686" ]; then
47   SLKCFLAGS="-O2 -march=i686 -mtune=i686"
48   LIBDIRSUFFIX=""
49 elif [ "$ARCH" = "x86_64" ]; then
50   SLKCFLAGS="-O2 -fPIC"
51   LIBDIRSUFFIX="64"
52 else
53   SLKCFLAGS="-O2"
54   LIBDIRSUFFIX=""
55 fi
56
57 set -e
58
59 rm -rf $PKG
60 mkdir -p $TMP $PKG $OUTPUT
61 cd $TMP
62 rm -rf $PRGNAM-$VERSION
63 tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
64 cd $PRGNAM-$VERSION
65 chown -R root:root .
66 find . \
67  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
68  -exec chmod 755 {} \; -o \
69  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
70  -exec chmod 644 {} \;
71
72 mkdir build
73 cd build
74   cmake \
75     -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
76     -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
77     -DCMAKE_INSTALL_PREFIX=/usr \
78     -DLIB_SUFFIX=${LIBDIRSUFFIX} \
79     -DMAN_INSTALL_DIR=/usr/man \
80     -DCMAKE_BUILD_TYPE=Release ..
81   make VERBOSE=1
82   make install DESTDIR=$PKG
83 cd ..
84
85 find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
86   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
87
88 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
89 cp -a \
90   AUTHORS COPYING README TODO *.txt \
91   $PKG/usr/doc/$PRGNAM-$VERSION
92 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
93
94 mkdir -p $PKG/install
95 cat $CWD/slack-desc > $PKG/install/slack-desc
96 cat $CWD/doinst.sh > $PKG/install/doinst.sh
97
98 cd $PKG
99 /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}