OSDN Git Service

d21790365f8f7e187442e02ae313c9be44dd660b
[handbrake-jp/handbrake-jp-git.git] / gtk / ghb.spec
1
2 Name:           %{name}
3 Version:        %{version}
4 Release:        %{release}%{?dist}
5 Summary:        A program to transcode DVDs and other sources to MPEG-4
6
7 Group:          Applications/Multimedia
8 License:        GPLv2
9 URL:            http://handbrake.fr/
10 Source0:        %{name}-%{version}.tar.bz2
11 Prefix:         %{_prefix}
12 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
13 BuildRequires: glib2-devel, gtk2-devel, webkitgtk-devel
14 BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, libgudev1-devel
15 Requires:       gtk2, coreutils
16
17 %define debug_package %{nil}
18
19 %description
20 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
21 transcoder, available for MacOS X, Linux and Windows.
22
23 %package gui
24 Summary:        A program to transcode DVDs and other sources to MPEG-4
25 Group:          Applications/Multimedia
26
27 %package cli
28 Summary:        A program to transcode DVDs and other sources to MPEG-4
29 Group:          Applications/Multimedia
30
31 %description gui
32 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
33 transcoder, available for MacOS X, Linux and Windows.
34
35 %description cli
36 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
37 transcoder, available for MacOS X, Linux and Windows.
38
39 %prep
40 %setup -q
41 cd %{_builddir}/%{name}-%{version}
42
43
44 %build
45 ./configure --debug=std --prefix=%{_prefix}
46 make %{?_smp_mflags} -C build
47
48
49 %install
50 make -C build DESTDIR=$RPM_BUILD_ROOT install-strip
51
52 ## blow away stuff we don't want
53 /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
54
55 %clean
56 rm -rf %{buildroot}
57
58 %post gui
59 touch --no-create %{_datadir}/icons/hicolor
60 if [ -x /usr/bin/gtk-update-icon-cache ]; then
61   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
62 fi
63
64 %postun gui
65 touch --no-create %{_datadir}/icons/hicolor
66 if [ -x /usr/bin/gtk-update-icon-cache ]; then
67   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
68 fi
69
70 %files gui
71 %defattr(-,root,root,-)
72 %doc NEWS AUTHORS CREDITS THANKS COPYING
73 %{_datadir}/icons/hicolor
74 %{_datadir}/applications
75 %{_bindir}/ghb
76
77 %files cli
78 %defattr(-,root,root,-)
79 %doc NEWS AUTHORS CREDITS THANKS COPYING
80 %{_bindir}/HandBrakeCLI
81
82 %changelog
83 * Sun Apr 11 2010 John Stebbins <jstebbins@jetheaddev.com> - svn
84 - Snapshot release
85
86