OSDN Git Service

* diagnostic.c (init_output_buffer): Don't initialize format_args.
[pf3gnuchains/gcc-fork.git] / libstdc++ / configure.in
index 0f556ca..e87e049 100644 (file)
@@ -2,28 +2,18 @@
 # necessary for a configure script to process the program in
 # this directory.  For more information, look at ../configure.
 
-# find a possible extension of the just-built C++ compiler. Note that this
-# is not the only choice, taking into cross and canadian cross into
-# account, and we need to search for with and without the extension.
-case "${host_alias}" in
-*cygwin* | *mingw32*)
-  EXEEXT=.exe
-  ;;
-*)
-  EXEEXT=
-  ;;
-esac
-
 # If the language specific compiler does not exist, but the "gcc" directory 
 # does, we do not build anything. Note, $r is set by the top-level Makefile.
 # Note that when we look for the compiler, we search both with and without
 # extension to handle cross and canadian cross builds. 
+# Note that if $norecursion is set we're being called from config.status,
+# so don't check for the compiler; we might be doing a make clean.
 compiler_name=cc1plus
 rm -f skip-this-dir
-if test -n "$r"; then
+if test -n "$r" && [ -z "$norecursion" ] ; then
   if test -d "$r"/gcc; then
     if test -f "$r"/gcc/$compiler_name \
-       || test -f "$r"/gcc/$compiler_name$EXEEXT; then
+       || test -f "$r"/gcc/$compiler_name.exe; then
       true
     else
       echo "rm -f multilib.out" > skip-this-dir
@@ -77,18 +67,21 @@ if [ "${shared}" = "yes" ]; then
     *-*-*)             frags=../../config/mh-${target_cpu}pic ;;
   esac
   case "${target}" in
+    *-*-aix*)          frags="${frags} aix.ml" ;;
+    *-*-beos*)         frags="${frags} beos.ml" ;;
     *-dec-osf*)                frags="${frags} dec-osf.ml";;
+    *-*-freebsd2*)     ;;
+    *-*-freebsd*)      frags="${frags} freebsd.ml" ;;
     *-*-hpux*)         frags="${frags} hpux.ml" ;;
     *-*-irix[56]*)     frags="${frags} irix5.ml" ;;
     *-*-linux*aout*)   ;;
-    *-*-freebsd2)      ;;
-    *-*-freebsd*)      frags="${frags} freebsd.ml" ;;
     *-*-linux*)                frags="${frags} linux.ml" ;;
+    # This must come after *-*-linux*
+    *-*-gnu*)          frags="${frags} gnu.ml" ;;
     *-*-openbsd*)              frags="${frags} openbsd.ml" ;;
     *-*-sysv[45]*|*-*-udk*)    frags="${frags} elf.ml" ;;
     *-*-solaris*)      frags="${frags} sol2shm.ml" ;;
     *-*-sunos4*)       frags="${frags} sunos4.ml" ;;
-    *-*-aix*)          frags="${frags} aix.ml" ;;
     i[3456]86-*-interix*)      frags="${frags} x86-interix.ml" ;;
   esac
 fi
@@ -97,7 +90,7 @@ fi
 case "${target}" in
   alpha*-*-linux-gnulibc1)     frags="${frags} linux.mt" ;;
   powerpc*-*-linux-gnulibc1)   frags="${frags} linux.mt" ;;
-  *-*-linux-gnu              frags="${frags} linux.mt" ;;
+  *-*-linux-gnu*)              frags="${frags} linux.mt" ;;
   *-*-openbsd*)                
        case "x${enable_threads}" in
                xyes|xposix)    frags="${frags} openbsd.mt" ;;