OSDN Git Service

make
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / testsuite / Makefile.am
index fe23b81..facf63a 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2005 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS =  cygnus dejagnu
+AUTOMAKE_OPTIONS = dejagnu nostdinc
 
-DEJATOOL = libstdc++-v3
-
-EXPECT = `if [ -f @glibcpp_builddir@/../../expect/expect ] ; then \
-            echo @glibcpp_builddir@/../../expect/expect ; \
-          else echo expect ; fi`
-
-RUNTEST = `if [ -f @glibcpp_srcdir@/../dejagnu/runtest ] ; then \
-              echo @glibcpp_srcdir@/../dejagnu/runtest ; \
-           else echo runtest; fi`
+include $(top_srcdir)/fragment.am
 
+AM_MAKEFLAGS = -j1
 AM_RUNTESTFLAGS =
-RUNTESTFLAGS =
-
-## CXX is actually a "C" compiler. These are real C++ programs.
-glibcpp_srcdir=@glibcpp_srcdir@
-glibcpp_builddir=@glibcpp_builddir@
-testsuite_flags_script=${glibcpp_builddir}/scripts/testsuite_flags
-CXX=`${testsuite_flags_script} --build-cxx`
-
-CXXLINK = \
-       LD_RUN_PATH=$${LD_RUN_PATH:+$$LD_RUN_PATH:}${glibcpp_builddir}/src/.libs\
-       $(LIBTOOL) --tag=CXX --mode=link $(CXX) \
-       $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@
-
-GLIBCPP_INCLUDES = @GLIBCPP_INCLUDES@
-LIBSUPCXX_INCLUDES = @LIBSUPCXX_INCLUDES@
-TOPLEVEL_INCLUDES = @TOPLEVEL_INCLUDES@
-INCLUDES = \
-       -nostdinc++ \
-       @GLIBCPP_INCLUDES@ @LIBSUPCXX_INCLUDES@ @TOPLEVEL_INCLUDES@ 
-
-## Build support library.
-noinst_LIBRARIES = libv3test.a
-libv3test_a_SOURCES = testsuite_hooks.cc testsuite_allocator.cc
-
-## Build support utilities.
-if GLIBCPP_TEST_ABI
-noinst_PROGRAMS = abi_check
-else
-noinst_PROGRAMS = 
-endif
-abi_check_SOURCES = abi_check.cc
-
-all-local: stamp_wchar
-
-# Enable wchar_t tests if capable.
-if GLIBCPP_TEST_WCHAR_T
-stamp_wchar:
-       touch testsuite_wchar_t
-else
-stamp_wchar:
-endif
-
-# Override this so local rules are possible.
-check-am: 
-       $(MAKE) $(AM_MAKEFLAGS) check-DEJAGNU; \
-       $(MAKE) $(AM_MAKEFLAGS) check-local 
-
-check-local: check-abi
-
-baseline_file = @baseline_file@
-extract_symvers = @glibcpp_srcdir@/scripts/extract_symvers
-
-current_symbols.txt: ${extract_symvers} ../src/.libs/libstdc++.so
-         -@(${extract_symvers} ../src/.libs/libstdc++.so current_symbols.txt)
+
+# Generated lists of files to run.  All of these names are valid make
+# targets, if you wish to generate a list manually.
+lists_of_files = \
+   testsuite_files \
+   testsuite_files_interactive \
+   testsuite_files_performance
+
+# This rule generates all of the testsuite_files* lists at once.
+${lists_of_files}:
+       ${glibcxx_srcdir}/scripts/create_testsuite_files \
+         ${glibcxx_srcdir}/testsuite `${PWD_COMMAND}`
+
+# We need more things in site.exp, but automake completely controls the
+# creation of that file; there's no way to append to it without messing up
+# the dependancy chains.  So we overrule automake.  This rule is exactly
+# what it would have generated, plus our own additions.
+site.exp: Makefile
+       @echo 'Making a new site.exp file...'
+       @echo '## these variables are automatically generated by make ##' >site.tmp
+       @echo '# Do not edit here.  If you wish to override these values' >>site.tmp
+       @echo '# edit the last section' >>site.tmp
+       @echo 'set srcdir $(srcdir)' >>site.tmp
+       @echo "set objdir `pwd`" >>site.tmp
+       @echo 'set build_alias "$(build_alias)"' >>site.tmp
+       @echo 'set build_triplet $(build_triplet)' >>site.tmp
+       @echo 'set host_alias "$(host_alias)"' >>site.tmp
+       @echo 'set host_triplet $(host_triplet)' >>site.tmp
+       @echo 'set target_alias "$(target_alias)"' >>site.tmp
+       @echo 'set target_triplet $(target_triplet)' >>site.tmp
+       @echo 'set target_triplet $(target_triplet)' >>site.tmp
+       @echo 'set libiconv "$(LIBICONV)"' >>site.tmp
+       @echo 'set baseline_file "$(baseline_file)"' >> site.tmp
+       @echo '## All variables above are generated by configure. Do Not Edit ##' >>site.tmp
+       @test ! -f site.exp || \
+         sed '1,/^## All variables above are.*##/ d' site.exp >> site.tmp
+       @-rm -f site.bak
+       @test ! -f site.exp || mv site.exp site.bak
+       @mv site.tmp site.exp
+
+
+baseline_file = ${baseline_dir}/baseline_symbols.txt
+extract_symvers = $(glibcxx_srcdir)/scripts/extract_symvers
 
 baseline_symbols:
        -@(output=${baseline_file}; \
@@ -95,10 +77,10 @@ baseline_symbols:
            echo "Baseline file doesn't exist."; \
            echo "Try 'make new-abi-baseline' to create it."; \
            exit 1; \
-         fi; \
-       touch baseline_symbols)
+         fi; true)
 
-new-abi-baseline: 
+new-abi-baseline:
+       -@$(mkinstalldirs) ${baseline_dir}
        -@(output=${baseline_file}; \
          if test -f $${output}; then \
            output=$${output}.new; \
@@ -107,45 +89,34 @@ new-abi-baseline:
          fi; \
          ${extract_symvers} ../src/.libs/libstdc++.so $${output})
 
-if GLIBCPP_TEST_ABI
 # Use 'new-abi-baseline' to create an initial symbol file.  Then run
 # 'check-abi' to test for changes against that file.
-check-abi: abi_check baseline_symbols current_symbols.txt
-       -@(./abi_check --check ./current_symbols.txt ${baseline_file})
+check-abi: baseline_symbols site.exp
+       -@runtest --tool libstdc++ abi.exp
 
-check-abi-verbose: abi_check baseline_symbols current_symbols.txt 
-       -@(./abi_check --check-verbose ./current_symbols.txt ${baseline_file})
-else
-check-abi:
-check-abi-verbose:
-endif
+# Runs the testsuite, but in compile only mode.
+# Can be used to test sources with non-GNU FE's at various warning
+# levels and for checking compile time across releases.
+# See script.
+compile_script=${glibcxx_srcdir}/scripts/check_compile
+check-compile: testsuite_files ${compile_script}
+       -@(chmod + ${compile_script}; \
+         ${compile_script} ${glibcxx_srcdir} ${glibcxx_builddir})
 
 
-# These two special 'check-script' rules use the bash script 'check'
-# to do testing. This script is not as portable as the dejagnu test
-# harness, and is thus off by default. It does produce interesting
-# output however, including various performance analysis items like
-# compile time, execution time, and binary size.
-check_survey = ${glibcpp_builddir}/scripts/check_survey
-check-script: ${check_survey}
-       -@(chmod + ${check_survey}; \
-         ${check_survey} 0)
-
-check-script-install: ${check_survey}
-       -@(chmod + ${check_survey}; \
-         ${check_survey} 0)
-
-
-# Runs the testsuite/performance tests.  
+# Runs the testsuite/performance tests.
 # Some of these tests create large (~75MB) files, allocate huge
 # ammounts of memory, or otherwise tie up machine resources. Thus,
 # running this is off by default.
-check_performance=${glibcpp_srcdir}/scripts/check_performance
-check-performance: ${check_performance}
-       -@(chmod + ${check_performance}; \
-         ${check_performance} ${glibcpp_srcdir} ${glibcpp_builddir})
+performance_script=${glibcxx_srcdir}/scripts/check_performance
+check-performance: testsuite_files_performance ${performance_script}
+       -@(chmod + ${performance_script}; \
+         ${performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
+
 
+.PHONY: baseline_symbols new-abi-baseline \
+       check-abi check-compile check-performance
 
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
-            testsuite_* site.exp abi_check baseline_symbols
+            testsuite_* site.exp abi_check baseline_symbols *TEST*