OSDN Git Service

make
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / testsuite / Makefile.am
index 371ab72..facf63a 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+## Copyright (C) 2001, 2002, 2003, 2005 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -28,54 +28,6 @@ include $(top_srcdir)/fragment.am
 AM_MAKEFLAGS = -j1
 AM_RUNTESTFLAGS =
 
-## CXX is actually a "C" compiler. These are real C++ programs.
-testsuite_flags_script=${glibcxx_builddir}/scripts/testsuite_flags
-CXX         = $(shell ${testsuite_flags_script} --build-cxx)
-GLIBCXX_INCLUDES = $(shell ${testsuite_flags_script} --build-includes)
-AM_CXXFLAGS = $(shell ${testsuite_flags_script} --cxxflags)
-
-GLIBGCC_DIR=`$(CC) -print-libgcc-file-name | sed 's,/[^/]*$$,,'`
-GLIBCXX_DIR=${glibcxx_builddir}/src/.libs
-
-CXXLINK = \
-       $(LIBTOOL) --tag=CXX --mode=link $(CXX) \
-       -R $(GLIBGCC_DIR) -R $(GLIBCXX_DIR) \
-       $(AM_CXXFLAGS) $(CXXFLAGS) $(LDFLAGS) -lv3test -L. -o $@
-
-## Build support library.
-noinst_LIBRARIES = libv3test.a
-libv3test_a_SOURCES = \
-       testsuite_abi.cc \
-       testsuite_allocator.cc \
-       testsuite_hooks.cc 
-
-## Build support utilities.
-if GLIBCXX_TEST_ABI
-noinst_PROGRAMS = abi_check
-else
-noinst_PROGRAMS =
-endif
-abi_check_SOURCES = abi_check.cc
-abi_check_DEPENDENCIES = libv3test.a
-
-all-local: stamp_wchar stamp_thread testsuite_files
-
-# Enable wchar_t tests if capable.
-if GLIBCXX_TEST_WCHAR_T
-stamp_wchar:
-       touch testsuite_wchar_t
-else
-stamp_wchar:
-endif
-
-# Enable thread tests if capable.
-if GLIBCXX_TEST_THREAD
-stamp_thread:
-       touch testsuite_thread
-else
-stamp_thread:
-endif
-
 # Generated lists of files to run.  All of these names are valid make
 # targets, if you wish to generate a list manually.
 lists_of_files = \
@@ -83,6 +35,10 @@ lists_of_files = \
    testsuite_files_interactive \
    testsuite_files_performance
 
+# This rule generates all of the testsuite_files* lists at once.
+${lists_of_files}:
+       ${glibcxx_srcdir}/scripts/create_testsuite_files \
+         ${glibcxx_srcdir}/testsuite `${PWD_COMMAND}`
 
 # We need more things in site.exp, but automake completely controls the
 # creation of that file; there's no way to append to it without messing up
@@ -103,6 +59,7 @@ site.exp: Makefile
        @echo 'set target_triplet $(target_triplet)' >>site.tmp
        @echo 'set target_triplet $(target_triplet)' >>site.tmp
        @echo 'set libiconv "$(LIBICONV)"' >>site.tmp
+       @echo 'set baseline_file "$(baseline_file)"' >> site.tmp
        @echo '## All variables above are generated by configure. Do Not Edit ##' >>site.tmp
        @test ! -f site.exp || \
          sed '1,/^## All variables above are.*##/ d' site.exp >> site.tmp
@@ -110,15 +67,10 @@ site.exp: Makefile
        @test ! -f site.exp || mv site.exp site.bak
        @mv site.tmp site.exp
 
-# This is automatically run after the generated check-DEJAGNU rule.
-check-local: check-abi
 
 baseline_file = ${baseline_dir}/baseline_symbols.txt
 extract_symvers = $(glibcxx_srcdir)/scripts/extract_symvers
 
-current_symbols.txt: ${extract_symvers} ../src/.libs/libstdc++.so
-         -@(${extract_symvers} ../src/.libs/libstdc++.so current_symbols.txt)
-
 baseline_symbols:
        -@(output=${baseline_file}; \
          if test ! -f $${output}; then \
@@ -137,38 +89,19 @@ new-abi-baseline:
          fi; \
          ${extract_symvers} ../src/.libs/libstdc++.so $${output})
 
-if GLIBCXX_TEST_ABI
 # Use 'new-abi-baseline' to create an initial symbol file.  Then run
 # 'check-abi' to test for changes against that file.
-check-abi: abi_check baseline_symbols current_symbols.txt
-       -@./abi_check --check ./current_symbols.txt ${baseline_file} \
-         2>&1 | tee libstdc++-abi.sum
-       -@cp libstdc++-abi.sum libstdc++-abi.log
-
-check-abi-verbose: abi_check baseline_symbols current_symbols.txt
-       -@./abi_check --check-verbose ./current_symbols.txt ${baseline_file} \
-         2>&1 | tee libstdc++-abi.sum
-       -@cp libstdc++-abi.sum libstdc++-abi.log
-
-else
-check-abi:
-check-abi-verbose:
-endif
+check-abi: baseline_symbols site.exp
+       -@runtest --tool libstdc++ abi.exp
 
-
-# These two special 'check-script' rules use the bash script
-# 'check_survey' to do testing. This script is not as portable as the
-# dejagnu test harness, and is thus off by default. It does produce
-# interesting output however, including various performance analysis
-# items like compile time, execution time, and binary size.
-survey_script = ${glibcxx_builddir}/scripts/check_survey
-check-script: ${survey_script}
-       -@(chmod + ${survey_script}; \
-         ${survey_script} 0)
-
-check-script-install: ${survey_script}
-       -@(chmod + ${survey_script}; \
-         ${survey_script} 0)
+# Runs the testsuite, but in compile only mode.
+# Can be used to test sources with non-GNU FE's at various warning
+# levels and for checking compile time across releases.
+# See script.
+compile_script=${glibcxx_srcdir}/scripts/check_compile
+check-compile: testsuite_files ${compile_script}
+       -@(chmod + ${compile_script}; \
+         ${compile_script} ${glibcxx_srcdir} ${glibcxx_builddir})
 
 
 # Runs the testsuite/performance tests.
@@ -181,14 +114,8 @@ check-performance: testsuite_files_performance ${performance_script}
          ${performance_script} ${glibcxx_srcdir} ${glibcxx_builddir})
 
 
-# This rule generates all of the testsuite_files* lists at once.
-${lists_of_files}:
-       ${glibcxx_srcdir}/scripts/create_testsuite_files \
-         ${glibcxx_srcdir}/testsuite `${PWD_COMMAND}`
-
-
-.PHONY: baseline_symbols new-abi-baseline check-abi check-abi-verbose \
-check-script check-script-install check-performance
+.PHONY: baseline_symbols new-abi-baseline \
+       check-abi check-compile check-performance
 
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \