OSDN Git Service

2010-03-02 Paolo Carlini <paolo.carlini@oracle.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / include / Makefile.am
index 47253e6..23aad14 100644 (file)
@@ -1,6 +1,6 @@
 #o# Makefile for the include subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
+## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010
 ## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
@@ -29,8 +29,8 @@ std_builddir = .
 std_headers = \
        ${std_srcdir}/algorithm \
        ${std_srcdir}/array \
+       ${std_srcdir}/atomic \
        ${std_srcdir}/bitset \
-       ${std_srcdir}/c++0x_warning.h \
        ${std_srcdir}/chrono \
        ${std_srcdir}/complex \
        ${std_srcdir}/condition_variable \
@@ -78,6 +78,7 @@ bits_builddir = ./bits
 bits_headers = \
         ${bits_srcdir}/algorithmfwd.h \
        ${bits_srcdir}/allocator.h \
+       ${bits_srcdir}/atomic_base.h \
        ${bits_srcdir}/atomicfwd_c.h \
        ${bits_srcdir}/atomicfwd_cxx.h \
        ${bits_srcdir}/atomic_0.h \
@@ -87,6 +88,7 @@ bits_headers = \
        ${bits_srcdir}/basic_string.h \
        ${bits_srcdir}/basic_string.tcc \
        ${bits_srcdir}/boost_concept_check.h \
+       ${bits_srcdir}/c++0x_warning.h \
        ${bits_srcdir}/char_traits.h \
        ${bits_srcdir}/codecvt.h \
        ${bits_srcdir}/concept_check.h \
@@ -100,6 +102,7 @@ bits_headers = \
        ${bits_srcdir}/gslice.h \
        ${bits_srcdir}/gslice_array.h \
        ${bits_srcdir}/hashtable.h \
+       ${bits_srcdir}/hashtable_policy.h \
        ${bits_srcdir}/indirect_array.h \
        ${bits_srcdir}/ios_base.h \
        ${bits_srcdir}/istream.tcc \
@@ -152,6 +155,8 @@ bits_headers = \
        ${bits_srcdir}/streambuf.tcc \
        ${bits_srcdir}/stringfwd.h \
        ${bits_srcdir}/unique_ptr.h \
+       ${bits_srcdir}/unordered_map.h \
+       ${bits_srcdir}/unordered_set.h \
        ${bits_srcdir}/valarray_array.h \
        ${bits_srcdir}/valarray_array.tcc \
        ${bits_srcdir}/valarray_before.h \
@@ -564,6 +569,7 @@ tr1_headers = \
        ${tr1_srcdir}/gamma.tcc \
        ${tr1_srcdir}/hypergeometric.tcc \
        ${tr1_srcdir}/hashtable.h \
+       ${tr1_srcdir}/hashtable_policy.h \
        ${tr1_srcdir}/inttypes.h \
        ${tr1_srcdir}/limits.h \
        ${tr1_srcdir}/math.h \
@@ -587,8 +593,10 @@ tr1_headers = \
        ${tr1_srcdir}/tgmath.h \
        ${tr1_srcdir}/tuple \
        ${tr1_srcdir}/type_traits \
-       ${tr1_srcdir}/unordered_set \
        ${tr1_srcdir}/unordered_map \
+       ${tr1_srcdir}/unordered_map.h \
+       ${tr1_srcdir}/unordered_set \
+       ${tr1_srcdir}/unordered_set.h \
        ${tr1_srcdir}/utility \
        ${tr1_srcdir}/wchar.h \
        ${tr1_srcdir}/wctype.h
@@ -609,13 +617,8 @@ tr1_impl_headers = \
        ${tr1_impl_srcdir}/cstdlib \
        ${tr1_impl_srcdir}/cwchar \
        ${tr1_impl_srcdir}/cwctype \
-       ${tr1_impl_srcdir}/functional \
-       ${tr1_impl_srcdir}/hashtable \
-       ${tr1_impl_srcdir}/hashtable_policy.h \
        ${tr1_impl_srcdir}/regex \
        ${tr1_impl_srcdir}/type_traits \
-       ${tr1_impl_srcdir}/unordered_map \
-       ${tr1_impl_srcdir}/unordered_set \
        ${tr1_impl_srcdir}/utility
 
 decimal_srcdir = ${glibcxx_srcdir}/include/decimal
@@ -642,7 +645,6 @@ c_base_headers = \
        ${c_base_srcdir}/csetjmp \
        ${c_base_srcdir}/csignal \
        ${c_base_srcdir}/cstdarg \
-       ${c_base_srcdir}/cstdatomic \
        ${c_base_srcdir}/cstdbool \
        ${c_base_srcdir}/cstddef \
        ${c_base_srcdir}/cstdint \
@@ -793,7 +795,7 @@ profile_headers = \
        ${profile_srcdir}/multiset.h \
        ${profile_srcdir}/set \
        ${profile_srcdir}/set.h \
-       ${profile_srcdir}/hashtable.h
+       ${profile_srcdir}/iterator_tracker.h
 profile_impl_srcdir = ${glibcxx_srcdir}/include/profile/impl
 profile_impl_builddir = ./profile/impl
 profile_impl_headers = \
@@ -806,7 +808,9 @@ profile_impl_headers = \
        ${profile_impl_srcdir}/profiler_state.h \
        ${profile_impl_srcdir}/profiler_trace.h \
        ${profile_impl_srcdir}/profiler_vector_size.h \
-       ${profile_impl_srcdir}/profiler_vector_to_list.h
+       ${profile_impl_srcdir}/profiler_vector_to_list.h \
+       ${profile_impl_srcdir}/profiler_list_to_vector.h \
+       ${profile_impl_srcdir}/profiler_list_to_slist.h
 
 # Some of the different "C" header models need extra files.
 # Some "C" header schemes require the "C" compatibility headers.