OSDN Git Service

2003-03-28 Paolo Carlini <pcarlini@unitus.it>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / configure.in
index 0de1794..b9da74a 100644 (file)
@@ -13,7 +13,7 @@ ORIGINAL_LD_FOR_MULTILIBS=$LD
 PACKAGE=libstdc++
 AC_SUBST(PACKAGE)
 # For libtool versioning info, format is CURRENT:REVISION:AGE
-libtool_VERSION=5:2:0
+libtool_VERSION=6:0:0
 AC_SUBST(libtool_VERSION)
 
 GLIBCPP_TOPREL_CONFIGURE
@@ -411,7 +411,12 @@ else
   GLIBCPP_CHECK_COMPLEX_MATH_SUPPORT
   GLIBCPP_CHECK_WCHAR_T_SUPPORT
   GLIBCPP_CHECK_STDLIB_SUPPORT
-  GLIBCPP_CHECK_UNISTD_SUPPORT
+
+  # For showmanyc_helper().
+  AC_CHECK_HEADERS(sys/ioctl.h sys/filio.h)
+  GLIBCPP_CHECK_POLL
+  GLIBCPP_CHECK_S_ISREG_OR_S_IFREG
+
   AC_LC_MESSAGES
 
   AC_TRY_COMPILE([
@@ -471,23 +476,33 @@ AC_SUBST(LIBSUPCXX_PICFLAGS)
 # down from config-ml.in -> top_srcdir/Makefile.am ->
 # top_srcdir/{src,libsupc++}/Makefile.am, manually append it here.
 AC_OUTPUT(Makefile \
-    include/Makefile src/Makefile \
-    libmath/Makefile libio/Makefile libsupc++/Makefile \
-    po/Makefile testsuite/Makefile mkcheck testsuite_flags,
-[ if ! test -f stamp-h; then
-   test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
-    if test -n "$CONFIG_FILES"; then
-     if test -n "${with_build_subdir}" || test -n "${with_target_subdir}"; then
-      LD="${ORIGINAL_LD_FOR_MULTILIBS}"
-      ac_file=Makefile . ${glibcpp_basedir}/../config-ml.in
-      grep '^MULTISUBDIR =' Makefile >> src/Makefile
-      grep '^MULTISUBDIR =' Makefile >> libsupc++/Makefile
-     fi
-    fi
+include/Makefile src/Makefile \
+libmath/Makefile libio/Makefile libsupc++/Makefile \
+po/Makefile testsuite/Makefile mkcheck testsuite_flags,
+[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
+ if test -n "$CONFIG_FILES"; then
+   if test -n "${with_build_subdir}" || test -n "${with_target_subdir}"; then
+     LD="${ORIGINAL_LD_FOR_MULTILIBS}"
+     # Ony modify Makefiles that are just being created.
+     case " $CONFIG_FILES" in
+       *" Makefile"*)
+        ac_file=Makefile . ${glibcpp_basedir}/../config-ml.in
+        ;;
+     esac
+     case $CONFIG_FILES in
+       *src/Makefile*)
+        grep '^MULTISUBDIR =' Makefile >> src/Makefile
+        ;;
+     esac
+     case $CONFIG_FILES in
+       *libsupc++/Makefile*)
+        grep '^MULTISUBDIR =' Makefile >> libsupc++/Makefile
+        ;;
+     esac
    fi
-chmod +x mkcheck
-chmod +x testsuite_flags
-],
+ fi
+ chmod +x mkcheck
+ chmod +x testsuite_flags],
 srcdir=${srcdir}
 host=${host}
 target=${target}
@@ -499,6 +514,7 @@ CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
 glibcpp_basedir=${glibcpp_basedir}
 CC="${CC}"
 CXX="${CXX}"
+ORIGINAL_LD_FOR_MULTILIBS="${ORIGINAL_LD_FOR_MULTILIBS}"
 )
 dnl  In autoconf 2.5x, AC_OUTPUT is replaced by three AC_ macros:
 dnl  AC_CONFIG_FILES(Makefile \
@@ -507,9 +523,22 @@ dnl      libmath/Makefile libio/Makefile libsupc++/Makefile \
 dnl      po/Makefile testsuite/Makefile mkcheck testsuite_flags)
 dnl  AC_CONFIG_COMMANDS([default],
 dnl  [if test -n "$CONFIG_FILES"; then
-dnl    ac_file=Makefile . ${glibcpp_basedir}/../config-ml.in
-dnl    grep '^MULTISUBDIR =' Makefile >> src/Makefile
-dnl    grep '^MULTISUBDIR =' Makefile >> libsupc++/Makefile
+dnl    # Ony modify Makefiles that are just being created.
+dnl    case " $CONFIG_FILES" in
+dnl      *" Makefile"*)
+dnl        ac_file=Makefile . ${glibcpp_basedir}/../config-ml.in
+dnl        ;;
+dnl    esac
+dnl    case $CONFIG_FILES in
+dnl      *src/Makefile*)
+dnl        grep '^MULTISUBDIR =' Makefile >> src/Makefile
+dnl        ;;
+dnl    esac
+dnl    case $CONFIG_FILES in
+dnl      *libsupc++/Makefile*)
+dnl        grep '^MULTISUBDIR =' Makefile >> libsupc++/Makefile
+dnl        ;;
+dnl    esac
 dnl  fi
 dnl  chmod +x mkcheck
 dnl  chmod +x testsuite_flags