OSDN Git Service

Add bug ID.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / configure.in
index 9a0b3b7..b526c40 100644 (file)
@@ -3,10 +3,41 @@
 
 AC_PREREQ(2.13)
 AC_INIT(src/ios.cc)
-AC_CONFIG_AUX_DIR(..)
+
+# When building with srcdir == objdir, links to the source files will
+# be created in directories within the target_subdir.  We have to
+# adjust toplevel_srcdir accordingly, so that configure finds
+# install-sh and other auxiliary files that live in the top-level
+# source directory.
+if test "${srcdir}" = "."; then
+  if test -z "${with_target_subdir}"; then
+    toplevel_srcdir="\${top_srcdir}/.."
+    auxdir="${srcdir}/.."
+  else
+    if test "${with_target_subdir}" != "."; then
+      toplevel_srcdir="\${top_srcdir}/${with_multisrctop}../.."
+      auxdir="${srcdir}/${with_multisrctop}../.."
+    else
+      toplevel_srcdir="\${top_srcdir}/${with_multisrctop}.."
+      auxdir="${srcdir}/${with_multisrctop}.."
+    fi
+  fi
+else
+  toplevel_srcdir="\${top_srcdir}/.."
+  auxdir="${srcdir}/.."
+fi
+AC_CONFIG_AUX_DIR($auxdir)
+AC_SUBST(toplevel_srcdir)
+
+dnl This is here just to satisfy automake.
+ifelse(not,equal,[AC_CONFIG_AUX_DIR(..)])
 
 # Gets and sets build, host, target, *_vendor, *_cpu, *_os, etc.
+# AC 2.50 sets target_alias iff the user specified --target, but we use it
+# everywhere, so we set it here just to be sure.
 AC_CANONICAL_SYSTEM
+target_alias=${target_alias-$target}
+AC_SUBST(target_alias)
 
 # We use these options to decide which functions to include.
 AC_ARG_WITH(target-subdir,
@@ -24,9 +55,9 @@ AM_PROG_LIBTOOL
 AC_SUBST(enable_shared)
 AC_SUBST(enable_static)
 GLIBCPP_CHECK_GNU_MAKE
-  if test "x$_cv_gnu_make_command" = "x"; then
-    AC_MSG_ERROR([GNU make not found. Please install it or correct your path.])
-  fi
+
+
+
 AM_CONFIG_HEADER(config.h)
 
 # Check for c++ or library specific bits that don't require linking.
@@ -35,11 +66,14 @@ GLIBCPP_CHECK_COMPILER_VERSION
 # Enable all the crazy c++ stuff.  C_MBCHAR must come early.
 GLIBCPP_ENABLE_DEBUG($USE_MAINTAINER_MODE)
 GLIBCPP_ENABLE_CSTDIO
+GLIBCPP_ENABLE_CLOCALE
 GLIBCPP_ENABLE_C_MBCHAR([yes])
-GLIBCPP_ENABLE_LONG_LONG([no])
+GLIBCPP_ENABLE_C99([yes])
+GLIBCPP_ENABLE_LONG_LONG([yes])
 GLIBCPP_ENABLE_CHEADERS([c_std])
 GLIBCPP_ENABLE_THREADS
 GLIBCPP_ENABLE_CXX_FLAGS([none])
+GLIBCPP_ENABLE_SJLJ_EXCEPTIONS
 
 if test -n "$with_cross_host"; then
 
@@ -68,9 +102,7 @@ if test -n "$with_cross_host"; then
        float.h inttypes.h])
 
        # GLIBCPP_CHECK_COMPILER_FEATURES
-       WFMT_FLAGS='-fdiagnostics-show-location=once'
        SECTION_FLAGS='-ffunction-sections -fdata-sections'
-       AC_SUBST(WFMT_FLAGS)
        AC_SUBST(SECTION_FLAGS)
        GLIBCPP_CHECK_LINKER_FEATURES
        # GLIBCPP_CHECK_BUILTIN_MATH_SUPPORT
@@ -141,7 +173,6 @@ if test -n "$with_cross_host"; then
          AC_DEFINE(HAVE_TANHL)
        fi
        GLIBCPP_CHECK_COMPLEX_MATH_SUPPORT
-       GLIBCPP_CHECK_COMPLEX_MATH_COMPILER_SUPPORT
        GLIBCPP_CHECK_WCHAR_T_SUPPORT
        os_include_dir="config/os/gnu-linux"
        # GLIBCPP_CHECK_STDLIB_SUPPORT
@@ -161,8 +192,6 @@ if test -n "$with_cross_host"; then
 
        os_include_dir="config/os/newlib"
 
-       AC_DEFINE(_GLIBCPP_BUGGY_FLOAT_COMPLEX)
-       AC_DEFINE(_GLIBCPP_BUGGY_COMPLEX)
        # need to check for faster f versions of math functions, ie sinf?
        ;;
   esac
@@ -185,10 +214,14 @@ else
   GLIBCPP_CHECK_BUILTIN_MATH_SUPPORT
   GLIBCPP_CHECK_MATH_SUPPORT
   GLIBCPP_CHECK_COMPLEX_MATH_SUPPORT
-  GLIBCPP_CHECK_COMPLEX_MATH_COMPILER_SUPPORT
   GLIBCPP_CHECK_WCHAR_T_SUPPORT
   GLIBCPP_CHECK_STDLIB_SUPPORT
 
+  AC_TRY_COMPILE([
+#include <setjmp.h>
+], [sigjmp_buf env; while (! sigsetjmp (env, 1)) siglongjmp (env, 1);],
+[AC_DEFINE(HAVE_SIGSETJMP, 1, [Define if sigsetjmp is available.  ])])
+
   AC_FUNC_MMAP
 fi
 
@@ -203,7 +236,6 @@ AC_LINK_FILES($ATOMICITYH/bits/atomicity.h, include/bits/atomicity.h)
 
 AM_CONDITIONAL(NULL_TARGET, test "$NULL_TARGET" = yes)
 AM_CONDITIONAL(NATIVE, test "$NATIVE" = yes || test "$NULL_TARGET" = yes)
-AM_CONDITIONAL(USE_LIBDIR, test -z "$with_cross_host")
 AM_CONDITIONAL(CANADIAN, test "$CANADIAN" = yes)
  
 AC_CACHE_SAVE
@@ -218,73 +250,24 @@ fi
 
 # Generate the various Makefiles, include files, and scripts.
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
 # Needed so that g++ can find the correct include subdir automatically.
 INTERFACE=v3
 
-# Check for the interface version number for specifying where header
-# files are installed, if a version number is provided.
-AC_MSG_CHECKING([for interface version number])
-libstdcxx_interface=$INTERFACE
-AC_MSG_RESULT($libstdcxx_interface)
-AC_SUBST(libstdcxx_interface)
-
-# Process the option --with-gxx-include-dir=<path to include-files directory>
-AC_MSG_CHECKING([for --with-gxx-include-dir])
-AC_ARG_WITH(gxx-include-dir,
-[ --with-gxx-include-dir  the installation directory for include files],
-[case "${withval}" in
-  yes)
-    AC_MSG_ERROR(Missing directory for --with-gxx-include-dir)
-    gxx_include_dir=no
-    ;;
-  no)
-    gxx_include_dir=no
-    ;;
-  *)
-    gxx_include_dir=${withval}
-    ;;
-esac], [gxx_include_dir=no])
-AC_MSG_RESULT($gxx_include_dir)
-AC_SUBST(gxx_include_dir)
-AM_CONDITIONAL(GXX_INCLUDE_DIR, test x${gxx_include_dir} != xno)
-
-# Process the option "--enable-version-specific-runtime-libs"
-AC_MSG_CHECKING([for --enable-version-specific-runtime-libs])
-AC_ARG_ENABLE(version-specific-runtime-libs,
-[  --enable-version-specific-runtime-libs    Specify that runtime libraries should be installed in a compiler-specific directory ],
-[  version_specific_libs=yes
-# Need the gcc compiler version to know where to install libraries
-# and header files if --enable-version-specific-runtime-libs option
-# is selected.
-changequote(,)dnl
-gcc_tmp=`grep version_string ${srcdir}/../gcc/version.c | awk '{print $6}'`
-gcc_num=`echo ${gcc_tmp} | sed 's/\"//g'`
-#gcc_date=`grep version_string ${srcdir}/../gcc/version.c | awk '{print $7}'`
-#gcc_version=$gcc_num-$gcc_date
-gcc_version=$gcc_num
-changequote([,])dnl
-AC_SUBST(gcc_version)
-],version_specific_libs=no)
-AC_MSG_RESULT($version_specific_libs)
-if test x${version_specific_libs} = xyes; then
-  AM_CONDITIONAL(VERSION_SPECIFIC_LIBS, test x${version_specific_libs} = xyes)
-  AC_MSG_WARN(version specific directory is: $gcc_version)
-fi
-
-# We have to install all the generated or linked includes files
-# specified as build_headers in src/Makefile.am in a target-dependent
-# place, or else multiple installs for different compilers will
-# overwrite these files.
-# NB: Keep this and gcc/Makefile.in's -DGPLUSPLUS_TOOL_INCLUDE_DIR in sync.
-gxx_target_include_dir='$(exec_prefix)/$(target_alias)/include/g++-$(libstdcxx_interface)'
-AC_SUBST(gxx_target_include_dir)
-
+# Export all the install information
+GLIBCPP_EXPORT_INSTALL_INFO
 
 # Export all the include and flag information to makefiles.
 GLIBCPP_EXPORT_INCLUDES
 GLIBCPP_EXPORT_FLAGS
 
+if ${CONFIG_SHELL-/bin/sh} ./libtool --tag CXX --features |
+   grep "enable shared" > /dev/null; then
+  LIBSUPCXX_PICFLAGS=-prefer-pic
+else
+  LIBSUPCXX_PICFLAGS=
+fi
+AC_SUBST(LIBSUPCXX_PICFLAGS)
+
 # This should be done by mkincludedir, but hack around it now.
 blddir=`pwd`
 echo "checking for $blddir/include"
@@ -298,14 +281,14 @@ fi
 # installed in the correct place. To work around this not being passed
 # down from config-ml.in -> top_srcdir/Makefile.am ->
 # top_srcdir/{src,libsupc++}/Makefile.am, manually append it here.
-AC_OUTPUT(tests_flags mkcheck Makefile src/Makefile libmath/Makefile libio/Makefile libsupc++/Makefile,
+AC_OUTPUT(Makefile src/Makefile libmath/Makefile libio/Makefile libsupc++/Makefile testsuite/Makefile mkcheck testsuite_flags,
 [if test -n "$CONFIG_FILES"; then
   ac_file=Makefile . ${glibcpp_basedir}/../config-ml.in
   grep '^MULTISUBDIR =' Makefile >> src/Makefile
   grep '^MULTISUBDIR =' Makefile >> libsupc++/Makefile
 fi
-chmod +x tests_flags
 chmod +x mkcheck
+chmod +x testsuite_flags
 ],
 srcdir=${srcdir}
 host=${host}