OSDN Git Service

* Makefile.in (html): Add html generation support.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 530ccc3..d17fcca 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE = v3
-gxx_include_dir=$(includedir)/g++
-
-SUBDIRS = libio libmath libsupc++ src
-
-
-# Compile flags that should be constant throughout the build, both for
-# SUBDIRS and for libstdc++-v3 in general.
-# Optimization flags that are probably a good idea for thrill-seekers. Just
-# uncomment the lines below and make, everything else is ready to go... 
-# OPTIMIZE_CXXFLAGS = -O3 -fstrict-aliasing -fvtable-gc 
-OPTIMIZE_CXXFLAGS = 
-
-# Warning flags to use.
-WARN_CXXFLAGS = \
-       -Wall -Wno-format -W -Wwrite-strings -Winline \
-       $(WERROR) @WFMT_FLAGS@
-
-# These bits are all figured out from configure. Look in acinclude.m4
-# or configure.in to see how they are set.
-# NB: DEBUGFLAGS have to be at the end so that -O2 can be overridden.
-CONFIG_CXXFLAGS = \
-       @EXTRA_CXX_FLAGS@ \
-       @SECTION_FLAGS@ @CSHADOWFLAGS@ @DEBUG_FLAGS@ 
-
-
-# Root level of the include sources.
-GLIBCPP_INCLUDE_DIR = $(top_srcdir)/include
-
-# Can either use include/c or include/c_std to grab "C" headers. This
-# variable is set to the include directory currently in use.
-C_INCLUDE_DIR = $(GLIBCPP_INCLUDE_DIR)/@c_include_dir@
-
-
-# Passed down for cross compilers, canadian crosses.
-TOPLEVEL_INCLUDES = -I$(includedir)
-
-LIBMATH_INCLUDES = -I$(top_srcdir)/libmath
-
-if GLIBCPP_NEED_LIBIO
-LIBIO_INCLUDES = \
-       -I$(top_builddir)/libio -I$(top_srcdir)/libio 
-else
-LIBIO_INCLUDES = -I$(top_srcdir)/libio
+if GLIBCXX_HOSTED
+  hosted_source = libmath src po testsuite
 endif
-
-LIBSUPCXX_INCLUDES = -I$(top_srcdir)/libsupc++
-
-# XXX May need to add this in later to enabled shadow header includes
-#      -I$(top_builddir)/cshadow
-CSHADOW_INCLUDES = \
-       -I$(GLIBCPP_INCLUDE_DIR)/std -I$(C_INCLUDE_DIR)
-
-
-# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check:  $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 0 `pwd` $(top_srcdir)
-
-check-install: $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 1 `pwd` $(top_srcdir) $(prefix)
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+SUBDIRS = include libsupc++ $(hosted_source)
+
+# These rules are messy, but are hella worth it.
+doxygen:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=user $${srcdir} $${builddir})
+
+doxygen-maint:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${builddir})
+
+doxygen-man:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=man $${srcdir} $${builddir})
+
+.PHONY: doxygen doxygen-maint doxygen-man
+
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
-
 # All the machinations with string instantiations messes up the
 # automake-generated TAGS rule. Make a simple one here.
 TAGS: tags-recursive $(LISP)
@@ -153,8 +85,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -162,10 +92,9 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
        "LIBCFLAGS=$(LIBCFLAGS)" \
        "PICFLAG=$(PICFLAG)" \
@@ -174,14 +103,7 @@ AM_MAKEFLAGS = \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)" \
-       "OPTIMIZE_CXXFLAGS=$(OPTIMIZE_CXXFLAGS)" \
-       "WARN_CXXFLAGS=$(WARN_CXXFLAGS)" \
-       "CONFIG_CXXFLAGS=$(CONFIG_CXXFLAGS)" \
-       "GLIBCPP_INCLUDE_DIR=$(GLIBCPP_INCLUDE_DIR)" \
-       "C_INCLUDE_DIR=$(C_INCLUDE_DIR)" \
-       "TOPLEVEL_INCLUDES=$(TOPLEVEL_INCLUDES)" \
-       "LIBMATH_INCLUDES=$(LIBMATH_INCLUDES)" \
-       "LIBIO_INCLUDES=$(LIBIO_INCLUDES)" \
-       "CSHADOW_INCLUDES=$(CSHADOW_INCLUDES)" \
-       "LIBSUPCXX_INCLUDES=$(LIBSUPCXX_INCLUDES)"
+       "WERROR=$(WERROR)"
+
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)