OSDN Git Service

* Makefile.in (html): Add html generation support.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 5032ed1..d17fcca 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 ## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
+include $(top_srcdir)/fragment.am
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE = v3
-gxx_include_dir=$(includedir)/g++
+if GLIBCXX_HOSTED
+  hosted_source = libmath src po testsuite
+endif
+## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
+SUBDIRS = include libsupc++ $(hosted_source)
 
-SUBDIRS = math libio src
+# These rules are messy, but are hella worth it.
+doxygen:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=user $${srcdir} $${builddir})
 
-# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check:  $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 0 `pwd` $(top_srcdir)
+doxygen-maint:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${builddir})
 
-check-install: $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 1 `pwd` $(top_srcdir) $(prefix)
+doxygen-man:
+       -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
+         builddir=`${PWD_COMMAND}`; \
+         ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=man $${srcdir} $${builddir})
 
-#all-local:  stamp-rebuild
+.PHONY: doxygen doxygen-maint doxygen-man
 
-# This has already been sanity-checked by configure to a certain extent
-#stamp-rebuild:  $(top_builddir)/config.status
-#      if test "$(GCC_OBJDIR)" != "no"; then \
-#      (cd "$(GCC_OBJDIR)/gcc" && \
-#       if test -f libgcc2.ready ; then \
-#         rm -f libgcc2.ready libgcc.a libgcc2.a ; \
-#         $(MAKE) libgcc2.a TARGET_LIBGCC2_CFLAGS='@NAMESPACES@' ; \
-#         $(MAKE) libgcc.a ; \
-#       else \
-#         echo '** There does not appear to be a previously-built' ; \
-#         echo '** library here.  Please see' ; \
-#         echo '** <http://sourceware.cygnus.com/libstdc++/install.html>' ; \
-#         echo '** In particular, the "Building and Installing' ; \
-#         echo '** the library (without GCC sources)" section.' ; \
-#         exit 1 ; \
-#       fi \
-#      ) \
-#      fi
-#      touch stamp-rebuild
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
-MULTISRCTOP =
-MULTIBUILDTOP =
-MULTIDIRS =
-MULTISUBDIR =
-MULTIDO = true
-MULTICLEAN = true
-
-# Multilib Makefile bits.
-.PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
-       maintainer-clean-multi
-
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
-
-all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
-install-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
-mostlyclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=mostlyclean multi-clean
-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=clean multi-clean
-distclean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=distclean multi-clean
-maintainer-clean-multi:
-       $(MULTICLEAN) $(AM_MAKEFLAGS) DO=maintainer-clean multi-clean
-
 # All the machinations with string instantiations messes up the
 # automake-generated TAGS rule. Make a simple one here.
 TAGS: tags-recursive $(LISP)
@@ -126,8 +85,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -135,10 +92,9 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
        "LIBCFLAGS=$(LIBCFLAGS)" \
        "PICFLAG=$(PICFLAG)" \
@@ -149,12 +105,5 @@ AM_MAKEFLAGS = \
        "DESTDIR=$(DESTDIR)" \
        "WERROR=$(WERROR)"
 
-
-
-
-
-
-
-
-
-
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)