OSDN Git Service

* libtool-version: Bump current to 9.
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 8700fff..c1f17b6 100644 (file)
@@ -19,7 +19,7 @@
 
 ## You should have received a copy of the GNU General Public License along
 ## with this library; see the file COPYING.  If not, write to the Free
-## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+## Software Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
 ## USA.
 
 include $(top_srcdir)/fragment.am
@@ -30,26 +30,28 @@ endif
 ## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
 SUBDIRS = include libsupc++ $(hosted_source)
 
+ACLOCAL_AMFLAGS = -I . -I .. -I ../config
+
 # These rules are messy, but are hella worth it.
 doxygen:
        -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
          builddir=`${PWD_COMMAND}`; \
          ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
-                   --build_alias=$(build_alias) \
+                   --host_alias=${host_alias} \
                    --mode=user $${srcdir} $${builddir})
 
 doxygen-maint:
        -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
          builddir=`${PWD_COMMAND}`; \
          ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
-                   --build_alias=$(build_alias) \
+                   --host_alias=${host_alias} \
                    --mode=maint $${srcdir} $${builddir})
 
 doxygen-man:
        -(srcdir=`cd ${top_srcdir}; ${PWD_COMMAND}`; \
          builddir=`${PWD_COMMAND}`; \
          ${SHELL} ${srcdir}/docs/doxygen/run_doxygen \
-                   --build_alias=$(build_alias) \
+                   --host_alias=${host_alias} \
                    --mode=man $${srcdir} $${builddir})
 
 .PHONY: doxygen doxygen-maint doxygen-man
@@ -99,8 +101,6 @@ AM_MAKEFLAGS = \
        "AR=$(AR)" \
        "AS=$(AS)" \
        "LD=$(LD)" \
-       "LIBCFLAGS=$(LIBCFLAGS)" \
-       "PICFLAG=$(PICFLAG)" \
        "RANLIB=$(RANLIB)" \
        "NM=$(NM)" \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
@@ -110,3 +110,9 @@ AM_MAKEFLAGS = \
 
 # Subdir rules rely on $(FLAGS_TO_PASS)
 FLAGS_TO_PASS = $(AM_MAKEFLAGS)
+
+# Installation of distribution html documentation not yet supported
+# TODO: Write custom install-html rule.
+.PHONY: install-html
+install-html:
+