OSDN Git Service

* libmath/stubs.c (hypot, hypotf, hypotl): Don't divide by
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 95994db..97fcfa8 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000, 2001 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 AUTOMAKE_OPTIONS = 1.3 cygnus
 MAINT_CHARSET = latin1
 
-SUBDIRS = libio libmath libsupc++ src
+SUBDIRS = include libio libmath libsupc++ src po testsuite 
 
 mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
 
-# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check: $(top_builddir)/mkcheck
+PWD = $${PWDCMD-pwd}
+
+# These two special 'check-script' rules use the bash script 'mkcheck'
+# to do testing. This script is not as portable as the dejagnu test
+# harness, and is thus off by default. It does produce interesting
+# output however, including various performance analysis items like
+# compile time, execution time, and binary size.
+check-script: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
+         cd testsuite; \
+         @glibcpp_builddir@/mkcheck 0)
 
-check-install: $(top_builddir)/mkcheck
+check-script-install: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
          cd testsuite; \
-         $${builddir}/mkcheck 1 $${builddir} $${srcdir} $(prefix))
+         @glibcpp_builddir@/mkcheck 1)
+
+# Use 'new-abi-baseline' to create an initial symbol file.  Then run
+# 'check-abi' to test for changes against that file.
+baseline_file = @baseline_file@
+check-abi: $(top_builddir)/testsuite/abi_check
+       -@(cd testsuite; \
+         @glibcpp_srcdir@/config/abi/extract_symvers \
+            ../src/.libs/libstdc++.so \
+            ./current_symbols.txt && \
+         ./abi_check --check ./current_symbols.txt ${baseline_file})
+
+new-abi-baseline:
+       -@(output=${baseline_file}; \
+         if test -f $${output}; then \
+           output=$${output}.new; \
+           t=`echo $${output} | sed 's=.*config/abi/=='`; \
+           echo "Baseline file already exists, writing to $${t} instead."; \
+         fi; \
+         @glibcpp_srcdir@/config/abi/extract_symvers \
+            src/.libs/libstdc++.so $${output})
+
+# These rules are messy, but are hella worth it.
+doxygen:
+       -(srcdir=`cd ${top_srcdir}; ${PWD}`; \
+         builddir=`${PWD}`; \
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=user $${srcdir} $${builddir})
+
+doxygen-maint:
+       -(srcdir=`cd ${top_srcdir}; ${PWD}`; \
+         builddir=`${PWD}`; \
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${builddir})
+
+doxygen-man:
+       -(srcdir=`cd ${top_srcdir}; ${PWD}`; \
+         builddir=`${PWD}`; \
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=man $${srcdir} $${builddir})
+
+.PHONY: doxygen doxygen-maint doxygen-man
 
 # Multilib support.
 MAKEOVERRIDES=
 
-# Multilib variables.
+# Multilib support variables.
 MULTISRCTOP =
 MULTIBUILDTOP =
 MULTIDIRS =
@@ -55,19 +98,19 @@ MULTISUBDIR =
 MULTIDO = true
 MULTICLEAN = true
 
-# Multilib Makefile bits.
+# Multilib support.
 .PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
        maintainer-clean-multi
 
-all-am: all-multi
-install-am: install-multi
-mostlyclean-am: mostlyclean-multi
-clean-am: clean-multi
-distclean-am: distclean-multi
-maintainer-clean-am: maintainer-clean-multi
+all-recursive: all-multi
+install-recursive: install-multi
+mostlyclean-recursive: mostlyclean-multi
+clean-recursive: clean-multi
+distclean-recursive: distclean-multi
+maintainer-clean-recursive: maintainer-clean-multi
 
 all-multi:
-       $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
+       : $(MAKE) ; exec $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do
 install-multi:
        $(MULTIDO) $(AM_MAKEFLAGS) DO=install multi-do
 mostlyclean-multi:
@@ -106,8 +149,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -115,10 +156,9 @@ AM_MAKEFLAGS = \
        "includedir=$(includedir)" \
        "prefix=$(prefix)" \
        "tooldir=$(tooldir)" \
+       "gxx_include_dir=$(gxx_include_dir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
        "LIBCFLAGS=$(LIBCFLAGS)" \
        "PICFLAG=$(PICFLAG)" \
@@ -128,3 +168,6 @@ AM_MAKEFLAGS = \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
        "WERROR=$(WERROR)" 
+
+# Subdir rules rely on $(FLAGS_TO_PASS)
+FLAGS_TO_PASS = $(AM_MAKEFLAGS)