OSDN Git Service

* gengtype-yacc.y (option, stringseq): Add missing
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 59ab45c..75c799d 100644 (file)
 
 include $(top_srcdir)/fragment.am
 
+if GLIBCXX_HOSTED
+  # Possibly libmath as well...
+  hosted_source = src po
+endif
 ## Keep this list sync'd with acinclude.m4:GLIBCXX_CONFIGURE.
-SUBDIRS = include libmath libsupc++ src po testsuite 
+SUBDIRS = include libmath libsupc++ $(hosted_source) testsuite
 
 # These rules are messy, but are hella worth it.
 doxygen:
@@ -48,6 +52,10 @@ doxygen-man:
 
 .PHONY: doxygen doxygen-maint doxygen-man
 
+# Handy forwarding targets.
+check-%:
+       cd testsuite && $(MAKE) $@
+
 # Multilib support.
 MAKEOVERRIDES=
 
@@ -128,7 +136,7 @@ AM_MAKEFLAGS = \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)" 
+       "WERROR=$(WERROR)"
 
 # Subdir rules rely on $(FLAGS_TO_PASS)
 FLAGS_TO_PASS = $(AM_MAKEFLAGS)