OSDN Git Service

* testsuite/thread/pthread1.cc: Use one condition variable
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index f585052..3f058ee 100644 (file)
@@ -24,7 +24,7 @@
 AUTOMAKE_OPTIONS = 1.3 cygnus
 MAINT_CHARSET = latin1
 
-SUBDIRS = include libio libmath libsupc++ src po intl testsuite 
+SUBDIRS = include libio libmath libsupc++ src po testsuite 
 
 mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
 
@@ -35,13 +35,11 @@ mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
 # compile time, execution time, and binary size.
 check-script: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
          cd testsuite; \
          @glibcpp_builddir@/mkcheck 0)
 
 check-script-install: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
          cd testsuite; \
          @glibcpp_builddir@/mkcheck 1)
 
@@ -55,7 +53,8 @@ doxygen:
 doxygen-maint:
        -(srcdir=`cd ${top_srcdir}; pwd`; \
          outdir=`pwd`; \
-         ${srcdir}/docs/doxygen/run_doxygen --mode=maint $${srcdir} $${outdir})
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${outdir})
 
 .PHONY: doxygen doxygen-maint