OSDN Git Service

* ChangeLog.2, ChangeLog.3, ChangeLog.5, ChangeLog, alias.c,
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index bad1b08..3f058ee 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 AUTOMAKE_OPTIONS = 1.3 cygnus
 MAINT_CHARSET = latin1
 
-# This helps subvert libstdcxx_interface, as calculated by devo/config.if
-# Needed so that g++ can find the correct include subdir automatically.
-INTERFACE = v3
-gxx_include_dir=$(includedir)/g++
-
-SUBDIRS = math libio libsupc++ src
-
-# Use $(blddir) instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
-check:  $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 0 `pwd` $(top_srcdir)
-
-check-install: $(top_builddir)/mkcheck
-       chmod +x  $(top_builddir)/mkcheck
-       $(top_builddir)/mkcheck 1 `pwd` $(top_srcdir) $(prefix)
-
-#all-local:  stamp-rebuild
-
-# This has already been sanity-checked by configure to a certain extent
-#stamp-rebuild:  $(top_builddir)/config.status
-#      if test "$(GCC_OBJDIR)" != "no"; then \
-#      (cd "$(GCC_OBJDIR)/gcc" && \
-#       if test -f libgcc2.ready ; then \
-#         rm -f libgcc2.ready libgcc.a libgcc2.a ; \
-#         $(MAKE) libgcc2.a TARGET_LIBGCC2_CFLAGS='@NAMESPACES@' ; \
-#         $(MAKE) libgcc.a ; \
-#       else \
-#         echo '** There does not appear to be a previously-built' ; \
-#         echo '** library here.  Please see' ; \
-#         echo '** <http://sourceware.cygnus.com/libstdc++/install.html>' ; \
-#         echo '** In particular, the "Building and Installing' ; \
-#         echo '** the library (without GCC sources)" section.' ; \
-#         exit 1 ; \
-#       fi \
-#      ) \
-#      fi
-#      touch stamp-rebuild
+SUBDIRS = include libio libmath libsupc++ src po testsuite 
+
+mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
+
+# These two special 'check-script' rules use the bash script 'mkcheck'
+# to do testing. This script is not as portable as the dejagnu test
+# harness, and is thus off by default. It does produce interesting
+# output however, including various performance analysis items like
+# compile time, execution time, and binary size.
+check-script: $(top_builddir)/mkcheck
+       -(chmod + $(top_builddir)/mkcheck; \
+         cd testsuite; \
+         @glibcpp_builddir@/mkcheck 0)
+
+check-script-install: $(top_builddir)/mkcheck
+       -(chmod + $(top_builddir)/mkcheck; \
+         cd testsuite; \
+         @glibcpp_builddir@/mkcheck 1)
+
+# These two rules might seem messy, but are hella worth it.
+doxygen:
+       -(srcdir=`cd ${top_srcdir}; pwd`; \
+         outdir=`pwd`; \
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=user $${srcdir} $${outdir})
+
+doxygen-maint:
+       -(srcdir=`cd ${top_srcdir}; pwd`; \
+         outdir=`pwd`; \
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${outdir})
+
+.PHONY: doxygen doxygen-maint
 
 # Multilib support.
 MAKEOVERRIDES=
@@ -126,8 +120,6 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
-       "EXPECT=$(EXPECT)" \
-       "RUNTEST=$(RUNTEST)" \
        "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
@@ -137,8 +129,6 @@ AM_MAKEFLAGS = \
        "tooldir=$(tooldir)" \
        "AR=$(AR)" \
        "AS=$(AS)" \
-       "CC=$(CC)" \
-       "CXX=$(CXX)" \
        "LD=$(LD)" \
        "LIBCFLAGS=$(LIBCFLAGS)" \
        "PICFLAG=$(PICFLAG)" \
@@ -147,14 +137,4 @@ AM_MAKEFLAGS = \
        "NM_FOR_BUILD=$(NM_FOR_BUILD)" \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
-       "WERROR=$(WERROR)"
-
-
-
-
-
-
-
-
-
-
+       "WERROR=$(WERROR)"