OSDN Git Service

* 5ataprop.adb, 5atpopsp.adb, 5ftaprop.adb, 5gmastop.adb,
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / Makefile.am
index 0f32f38..3f058ee 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the toplevel directory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997,1998, 1999, 2000, 2001 Free Software Foundation, Inc.
+## Copyright (C) 1997, 1998, 1999, 2000, 2001 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
 AUTOMAKE_OPTIONS = 1.3 cygnus
 MAINT_CHARSET = latin1
 
-SUBDIRS = libio libmath libsupc++ src testsuite
+SUBDIRS = include libio libmath libsupc++ src po testsuite 
 
 mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
 
-# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
-# because then the paths will be full pathnames, not relative
-# pathnames. (-Wl,--rpath seems to like this better.)
+# These two special 'check-script' rules use the bash script 'mkcheck'
+# to do testing. This script is not as portable as the dejagnu test
+# harness, and is thus off by default. It does produce interesting
+# output however, including various performance analysis items like
+# compile time, execution time, and binary size.
 check-script: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
-         cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
+         cd testsuite; \
+         @glibcpp_builddir@/mkcheck 0)
 
 check-script-install: $(top_builddir)/mkcheck
        -(chmod + $(top_builddir)/mkcheck; \
-         srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
-         test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
          cd testsuite; \
-         $${builddir}/mkcheck 1 $${builddir} $${srcdir} $(prefix))
+         @glibcpp_builddir@/mkcheck 1)
 
-# These two rules seem messy.
+# These two rules might seem messy, but are hella worth it.
 doxygen:
        -(srcdir=`cd ${top_srcdir}; pwd`; \
          outdir=`pwd`; \
@@ -54,11 +53,11 @@ doxygen:
 doxygen-maint:
        -(srcdir=`cd ${top_srcdir}; pwd`; \
          outdir=`pwd`; \
-         ${srcdir}/docs/doxygen/run_doxygen --mode=maint $${srcdir} $${outdir})
+         /bin/sh ${srcdir}/docs/doxygen/run_doxygen \
+                   --mode=maint $${srcdir} $${outdir})
 
 .PHONY: doxygen doxygen-maint
 
-
 # Multilib support.
 MAKEOVERRIDES=
 
@@ -121,6 +120,7 @@ AM_MAKEFLAGS = \
        "PICFLAG=$(PICFLAG)" \
        "PICFLAG_FOR_TARGET=$(PICFLAG_FOR_TARGET)" \
        "SHELL=$(SHELL)" \
+       "RUNTESTFLAGS=$(RUNTESTFLAGS)" \
        "exec_prefix=$(exec_prefix)" \
        "infodir=$(infodir)" \
        "libdir=$(libdir)" \
@@ -138,5 +138,3 @@ AM_MAKEFLAGS = \
        "NM_FOR_TARGET=$(NM_FOR_TARGET)" \
        "DESTDIR=$(DESTDIR)" \
        "WERROR=$(WERROR)" 
-
-