OSDN Git Service

./ChangeLog:
[pf3gnuchains/gcc-fork.git] / libf2c / configure.in
index 0ae338e..1e4a2ad 100644 (file)
@@ -19,6 +19,7 @@
 #the Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 #02111-1307, USA.
 
+AC_PREREQ(2.12.1)
 AC_INIT(libF77/Version.c)
 
 if test "${srcdir}" = "."  ; then
@@ -30,6 +31,34 @@ if test "${srcdir}" = "."  ; then
 else
   topsrcdir=${srcdir}/..
 fi
+dnl This is needed for a multilibbed build in the source tree so
+dnl that install-sh and config.sub get found.
+AC_CONFIG_AUX_DIR($topsrcdir)
+
+# If the language specific compiler does not exist, but the "gcc" directory does,
+# we do not build anything. Note, $r is set by the top-level Makefile.
+compiler_name=f771
+rm -f skip-this-dir
+AC_MSG_CHECKING(if compiler $compiler_name has been built)
+AC_CACHE_VAL(f77_cv_compiler_exists,
+       [f77_cv_compiler_exists=yes
+       if test -n "$r"; then
+               if test -d "$r"/gcc; then
+                       if test -f "$r"/gcc/$compiler_name; then
+                               true
+                       else
+                               f77_cv_compiler_exists=no
+                               echo "rm -f config.cache config.log multilib.out" > skip-this-dir
+                       fi
+               fi
+       fi
+       ])
+AC_MSG_RESULT($f77_cv_compiler_exists)
+if test x$f77_cv_compiler_exists = xno
+then
+       rm -f Makefile conftest* confdefs* core
+       exit 0
+fi
 
 dnl Checks for programs.
 # For g77 we'll set CC to point at the built gcc, but this will get it into
@@ -174,13 +203,17 @@ AC_SUBST(gcc_version_trigger)
 AC_CANONICAL_SYSTEM
 AC_SUBST(target_alias)
 AC_CONFIG_SUBDIRS(libU77 libI77 libF77)
-AC_OUTPUT(g2c.h:g2c.hin Makefile,
+# Do Makefile first since g2c.h depends on it and shouldn't get an
+# earlier timestamp.  Of course, it does when the multilib gunk below
+# edits Makefile, sigh; see additional touch below.
+AC_OUTPUT(Makefile g2c.h:g2c.hin,
  [test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h
 if test -n "$CONFIG_FILES"; then
   if test -n "${with_target_subdir}"; then
     # FIXME: We shouldn't need to set ac_file
     ac_file=Makefile
     . ${topsrcdir}/config-ml.in
+    touch g2c.h   # to keep it more recent than Makefile
   fi
 fi],
 srcdir=${srcdir}