OSDN Git Service

Daily bump.
[pf3gnuchains/gcc-fork.git] / libcpp / configure.ac
index 71b6ff6..fd09865 100644 (file)
@@ -46,6 +46,7 @@ AC_C_INLINE
 AC_FUNC_OBSTACK
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
+AC_CHECK_TYPE(ssize_t, int)
 AC_STRUCT_TM
 AC_CHECK_SIZEOF(int)
 AC_CHECK_SIZEOF(long)
@@ -117,19 +118,25 @@ case $target in
        arm*-*-symbianelf* | \
        x86_64-*-* | \
        ia64-*-* | \
-       hppa*64*-*-* | parisc*64*-*-* | \
-       i[34567]86-*-darwin[0-9]* | \
+       hppa*64*-*-* | \
+       i[34567]86-*-darwin* | \
        i[34567]86-*-solaris2.1[0-9]* | \
        mips*-*-* | \
        mmix-*-* | \
        powerpc*-*-* | \
        rs6000*-*-* | \
        s390*-*-* | \
-       sparc64*-*-* | ultrasparc-*-freebsd* | \
-       sparcv9-*-solaris2* | \
-       sparc-*-solaris2.[789] | sparc-*-solaris2.1[0-9]* | \
-       sh[123456789l]*-*-*)
+       sparc*-*-* | \
+       spu-*-* | \
+       sh[123456789lbe]*-*-* | sh-*-*)
                need_64bit_hwint=yes ;;
+       i[34567]86-*-linux*)
+               if test "x$enable_targets" = xall; then
+                       need_64bit_hwint=yes
+               else
+                       need_64bit_hwint=no
+               fi
+               ;;
        *)
                need_64bit_hwint=no ;;
 esac