OSDN Git Service

Daily bump.
[pf3gnuchains/gcc-fork.git] / libcpp / configure.ac
index 5c27835..fd09865 100644 (file)
@@ -22,7 +22,8 @@ AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
 # See config/warnings.m4 for details.
 
 ACX_PROG_CC_WARNING_OPTS([-W -Wall -Wwrite-strings -Wstrict-prototypes \
-                         -Wmissing-prototypes -Wold-style-definition])
+                         -Wmissing-prototypes -Wold-style-definition \
+                         -Wmissing-format-attribute])
 ACX_PROG_CC_WARNING_ALMOST_PEDANTIC([-Wno-long-long])
 
 # Only enable with --enable-werror-always until existing warnings are
@@ -45,6 +46,7 @@ AC_C_INLINE
 AC_FUNC_OBSTACK
 AC_TYPE_OFF_T
 AC_TYPE_SIZE_T
+AC_CHECK_TYPE(ssize_t, int)
 AC_STRUCT_TM
 AC_CHECK_SIZEOF(int)
 AC_CHECK_SIZEOF(long)
@@ -112,22 +114,29 @@ fi
 m4_changequote(,)
 case $target in
        alpha*-*-* | \
-       arm*-*-eabi* | \
+       arm*-*-*eabi* | \
        arm*-*-symbianelf* | \
        x86_64-*-* | \
        ia64-*-* | \
-       hppa*64*-*-* | parisc*64*-*-* | \
+       hppa*64*-*-* | \
+       i[34567]86-*-darwin* | \
        i[34567]86-*-solaris2.1[0-9]* | \
        mips*-*-* | \
        mmix-*-* | \
        powerpc*-*-* | \
        rs6000*-*-* | \
        s390*-*-* | \
-       sparc64*-*-* | ultrasparc-*-freebsd* | \
-       sparcv9-*-solaris2* | \
-       sparc-*-solaris2.[789] | sparc-*-solaris2.1[0-9]* | \
-       sh[123456789l]*-*-*)
+       sparc*-*-* | \
+       spu-*-* | \
+       sh[123456789lbe]*-*-* | sh-*-*)
                need_64bit_hwint=yes ;;
+       i[34567]86-*-linux*)
+               if test "x$enable_targets" = xall; then
+                       need_64bit_hwint=yes
+               else
+                       need_64bit_hwint=no
+               fi
+               ;;
        *)
                need_64bit_hwint=no ;;
 esac