OSDN Git Service

./
[pf3gnuchains/gcc-fork.git] / libcpp / configure.ac
index 71b6ff6..8a23633 100644 (file)
@@ -118,7 +118,7 @@ case $target in
        x86_64-*-* | \
        ia64-*-* | \
        hppa*64*-*-* | parisc*64*-*-* | \
-       i[34567]86-*-darwin[0-9]* | \
+       i[34567]86-*-darwin* | \
        i[34567]86-*-solaris2.1[0-9]* | \
        mips*-*-* | \
        mmix-*-* | \
@@ -128,8 +128,16 @@ case $target in
        sparc64*-*-* | ultrasparc-*-freebsd* | \
        sparcv9-*-solaris2* | \
        sparc-*-solaris2.[789] | sparc-*-solaris2.1[0-9]* | \
+       spu-*-* | \
        sh[123456789l]*-*-*)
                need_64bit_hwint=yes ;;
+       i[34567]86-*-linux*)
+               if test "x$enable_targets" = xall; then
+                       need_64bit_hwint=yes
+               else
+                       need_64bit_hwint=no
+               fi
+               ;;
        *)
                need_64bit_hwint=no ;;
 esac