OSDN Git Service

2001-11-07 David O'Brien <obrien@FreeBSD.org>
[pf3gnuchains/gcc-fork.git] / libchill / configure.in
index afb9f67..cd08ba1 100644 (file)
@@ -1,5 +1,5 @@
 # Process this file with autoconf to produce a configure script.
-#   Copyright (C) 1995, 1997, 1998 Free Software Foundation, Inc.
+#   Copyright (C) 1995, 1997, 1998, 1999 Free Software Foundation, Inc.
 #   Contributed by Dave Love (d.love@dl.ac.uk).
 #
 #This file is part of GNU CC.
@@ -19,7 +19,7 @@
 #the Free Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 #02111-1307, USA.
 
-AC_PREREQ(2.12.1)
+AC_PREREQ(2.13)
 AC_INIT(chillrt0.c)
 
 if test "${srcdir}" = "." ; then
@@ -35,29 +35,32 @@ dnl This is needed for a multilibbed build in the source tree so
 dnl that install-sh and config.sub get found.
 AC_CONFIG_AUX_DIR($topsrcdir)
 
-# If the language specific compiler does not exist, but the "gcc" directory does,
-# we do not build anything. Note, $r is set by the top-level Makefile.
+# If the language specific compiler does not exist, but the "gcc" directory 
+# does, we do not build anything. Note, $r is set by the top-level Makefile.
+# Note that when we look for the compiler, we search both with and without
+# extension to handle cross and canadian cross builds. 
 compiler_name=cc1chill
 rm -f skip-this-dir
 AC_MSG_CHECKING(if compiler $compiler_name has been built)
 AC_CACHE_VAL(chill_cv_compiler_exists,
-       [chill_cv_compiler_exists=yes
-       if test -n "$r"; then
-               if test -d "$r"/gcc; then
-                       if test -f "$r"/gcc/$compiler_name; then
-                               true
-                       else
-                               chill_cv_compiler_exists=no
-                               echo "rm -f config.cache config.log multilib.out" > skip-this-dir
-                       fi
-               fi
-       fi
-       ])
+[chill_cv_compiler_exists=yes
+if test -n "$r"; then
+  if test -d "$r"/gcc; then
+    if test -f "$r"/gcc/$compiler_name \
+       || test -f "$r"/gcc/$compiler_name.exe; then
+      true
+    else
+      chill_cv_compiler_exists=no
+      echo "rm -f config.cache config.log multilib.out" > skip-this-dir
+    fi
+  fi
+fi
+])
 AC_MSG_RESULT($chill_cv_compiler_exists)
 if test x$chill_cv_compiler_exists = xno
 then
-       rm -f Makefile conftest* confdefs* core
-       exit 0
+  rm -f Makefile conftest* confdefs* core
+  exit 0
 fi
 
 dnl Checks for programs.
@@ -67,6 +70,11 @@ AC_PROG_CC
 
 test "$AR" || AR=ar
 AC_SUBST(AR)
+if test "$RANLIB"; then :
+  AC_SUBST(RANLIB)
+else
+  AC_PROG_RANLIB
+fi
 AC_PROG_MAKE_SET
 
 dnl Checks for libraries.
@@ -120,6 +128,10 @@ AC_CHECK_FUNC(atexit,
      AC_DEFINE(onexit,on_exit),)])])
 else true
 fi
+AC_CHECK_FUNC(memmove,
+  MEMMOVE_O='',
+  MEMMOVE_O=memmove.o)
+AC_SUBST(MEMMOVE_O)
 
 # We need multilib support, but only if configuring for the target.
 AC_OUTPUT(Makefile,