OSDN Git Service

2010-09-21 Jason Blevins <jrblevin@sdf.org>
[pf3gnuchains/gcc-fork.git] / intl / configure.ac
index 516057b..698c330 100644 (file)
@@ -1,7 +1,8 @@
-AC_PREREQ(2.59)
+AC_PREREQ(2.64)
 AC_INIT
 AC_CONFIG_SRCDIR(gettext.c)
 AC_CONFIG_HEADER(config.h)
+AC_CONFIG_MACRO_DIR(../config)
 AM_GNU_GETTEXT_VERSION(0.12.1)
 AM_GNU_GETTEXT
 
@@ -16,6 +17,21 @@ AC_DEFINE(set_relocation_prefix, libintl_set_relocation_prefix,
 AC_DEFINE(relocate, libintl_relocate,
 [Define this entry point correctly.])
 
+MISSING=`cd $ac_aux_dir && ${PWDCMD-pwd}`/missing
+AC_CHECK_PROGS([ACLOCAL], [aclocal], [$MISSING aclocal])
+AC_CHECK_PROGS([AUTOCONF], [autoconf], [$MISSING autoconf])
+AC_CHECK_PROGS([AUTOHEADER], [autoheader], [$MISSING autoheader])
+
+AC_ARG_ENABLE(maintainer-mode,
+[  --enable-maintainer-mode enable rules only needed by maintainers],,
+enable_maintainer_mode=no)
+if test "x$enable_maintainer_mode" = xno; then
+  MAINT='#'
+else
+  MAINT=
+fi
+AC_SUBST(MAINT)
+
 # Additional info for config.intl.
 AC_SUBST(LIBINTL_DEP)
 AC_SUBST(INCINTL)
@@ -24,8 +40,10 @@ LIBINTL_DEP=
 INCINTL=
 case $USE_INCLUDED_LIBINTL in
   yes)
-    LIBINTL_DEP='${top_builddir}/intl/libintl.a'
-    INCINTL='-I${top_builddir}/intl'
+    LIBINTL=`echo $LIBINTL | sed 's,${top_builddir},&/..,' `
+    LTLIBINTL=`echo $LTLIBINTL | sed 's,${top_builddir},&/..,' `
+    LIBINTL_DEP='${top_builddir}/../intl/libintl.a'
+    INCINTL='-I${top_builddir}/../intl'
     ;;
 esac