OSDN Git Service

Drop test for libunwind 0.95 and earlier.
[pf3gnuchains/gcc-fork.git] / gcc / configure.in
index fb8d022..2db5442 100644 (file)
@@ -25,7 +25,7 @@
 # Initialization and sanity checks
 # --------------------------------
 
-AC_PREREQ(2.57)
+AC_PREREQ(2.13)
 AC_INIT(tree.c)
 AC_CONFIG_HEADER(auto-host.h:config.in)
 
@@ -798,7 +798,7 @@ int main()
   fi
 fi
 
-AC_CHECK_TYPE(ssize_t, int)
+gcc_AC_CHECK_TYPE(ssize_t, int)
 
 # Try to determine the array type of the second argument of getgroups
 # for the target system (int or gid_t).
@@ -1882,8 +1882,14 @@ changequote(,)dnl
 changequote([,])dnl
     fi
   else
-    # non-GNU linkers don't seem to support .hidden yet
-    gcc_cv_ld_hidden=no
+    case "${target}" in
+      hppa64*-*-hpux*)
+       gcc_cv_ld_hidden=yes
+       ;;
+      *)
+       gcc_cv_ld_hidden=no
+       ;;
+    esac
   fi
 fi])
 libgcc_visibility=no
@@ -1959,16 +1965,15 @@ __FRAME_BEGIN__:
        .byte   0x4
        .4byte  .L1-.LFB1
 .LEFDE1:],
-[  dnl # For autoconf 2.5x, must protect trailing spaces with @&t@.
-cat > conftest.lit <<EOF
+[  cat > conftest.lit <<EOF
  0000 10000000 00000000 017a0001 781a0004  .........z..x...
  0010 01000000 12000000 18000000 00000000  ................
- 0020 08000000 04080000 0044               .........D      @&t@
+ 0020 08000000 04080000 0044               .........D      
 EOF
-cat > conftest.big <<EOF
+  cat > conftest.big <<EOF
  0000 00000010 00000000 017a0001 781a0004  .........z..x...
  0010 00000001 00000012 00000018 00000000  ................
- 0020 00000008 04000000 0844               .........D      @&t@
+ 0020 00000008 04000000 0844               .........D      
 EOF
   # If the assembler didn't choke, and we can objdump,
   # and we got the correct data, then succeed.
@@ -2534,36 +2539,6 @@ if test x"$gcc_cv_ld_pie" = xyes; then
 fi
 AC_MSG_RESULT($gcc_cv_ld_pie)
 
-# Miscellaneous target-specific checks.
-case "$target" in
-  mips*-*-*)
-    AC_MSG_CHECKING(whether libgloss uses STARTUP directives consistently)
-    gcc_cv_mips_libgloss_startup=no
-    gcc_cv_libgloss_srcdir=`echo $srcdir | sed -e 's,/gcc$,,'`/libgloss
-    if test "x$exec_prefix" = xNONE; then
-      if test "x$prefix" = xNONE; then
-        test_prefix=/usr/local
-      else
-        test_prefix=$prefix
-      fi
-    else
-      test_prefix=$exec_prefix
-    fi
-    for f in $gcc_cv_libgloss_srcdir/mips/idt.ld $test_prefix/$target_noncanonical/lib/idt.ld
-    do
-      if grep '^STARTUP' $f > /dev/null 2>&1; then
-        gcc_cv_mips_libgloss_startup=yes
-        break
-      fi
-    done
-    if test x"$gcc_cv_mips_libgloss_startup" = xyes; then
-      AC_DEFINE(HAVE_MIPS_LIBGLOSS_STARTUP_DIRECTIVES, 1,
-        [Define if your MIPS libgloss linker scripts consistently include STARTUP directives.])
-    fi
-    AC_MSG_RESULT($gcc_cv_mips_libgloss_startup)
-    ;;
-esac
-
 if test x$with_sysroot = x && test x$host = x$target \
    && test "$prefix" != "/usr" && test "x$prefix" != "x$local_prefix" ; then
   AC_DEFINE_UNQUOTED(PREFIX_INCLUDE_DIR, "$prefix/include",