OSDN Git Service

* approved by rth
[pf3gnuchains/gcc-fork.git] / fastjar / configure.in
index c73f0e2..b27a866 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_INIT(jartool.h)
-AM_INIT_AUTOMAKE(fastar, 0.92-gcc)
+AM_INIT_AUTOMAKE(fastjar, 0.92-gcc)
 AM_CONFIG_HEADER(config.h)
 
 dnl Checks for programs.
@@ -12,6 +12,8 @@ AC_PATH_PROG(STRIP, strip, /usr/bin/strip, $PATH:/bin:/usr/bin:/usr/local/bin)
 AC_PATH_PROG(CHMOD, chmod, /bin/chmod, $PATH:/bin:/usr/bin:/usr/local/bin)
 AC_EXEEXT
 
+AM_MAINTAINER_MODE
+
 dnl Add warning flags if we are using gcc.
 if test "$GCC" = yes; then
   fastjar_warn_cflags='-W -Wall -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings'
@@ -22,21 +24,21 @@ dnl Checks for header files.
 AC_HEADER_DIRENT
 AC_HEADER_STDC
 AC_STRUCT_TM
-AC_CHECK_HEADERS(fcntl.h unistd.h sys/param.h getopt.h)
+AC_CHECK_HEADERS(fcntl.h unistd.h sys/param.h stdlib.h)
 
 dnl Checks for typedefs, structures, and compiler characteristics.
 AC_TYPE_OFF_T
 AC_STRUCT_TM
 
 dnl Check for type-widths
-AC_CHECK_SIZEOF(char)
-AC_CHECK_SIZEOF(short)
-AC_CHECK_SIZEOF(int)
-AC_CHECK_SIZEOF(long)
-AC_CHECK_SIZEOF(long long)
+gcc_AC_COMPILE_CHECK_SIZEOF(char)
+gcc_AC_COMPILE_CHECK_SIZEOF(short)
+gcc_AC_COMPILE_CHECK_SIZEOF(int)
+gcc_AC_COMPILE_CHECK_SIZEOF(long)
+gcc_AC_COMPILE_CHECK_SIZEOF(long long)
 
 dnl Check byte order
-AC_C_BIGENDIAN
+fastjar_AC_COMPILE_C_BIGENDIAN
 
 AC_ARG_WITH(system-zlib,
 [  --with-system-zlib      use installed libz])