OSDN Git Service

2002-09-10 Matthias Klose <doko@debian.org>
[pf3gnuchains/gcc-fork.git] / fastjar / Makefile.am
index fa22049..b7c43c9 100644 (file)
@@ -1,5 +1,8 @@
 # Process this with automake to create Makefile.in
 
+## We definitely don't want dependency tracking when using automake 1.4.
+AUTOMAKE_OPTIONS = no-dependencies
+
 # Work around what appears to be a GNU make bug handling MAKEFLAGS
 # values defined in terms of make variables, as is the case for CC and
 # friends when we are called from the top level Makefile.
@@ -38,14 +41,46 @@ AM_MAKEFLAGS = \
        "RANLIB=$(RANLIB)" \
        "DESTDIR=$(DESTDIR)"
 
-INCLUDES = -I. -I$(top_srcdir) $(ZINCS)
+INCLUDES = -I. -I$(top_srcdir) $(ZINCS) -I$(top_srcdir)/../include
+
+LIBIBERTY = ../libiberty/libiberty.a
 
-bin_PROGRAMS = fastjar grepjar
-fastjar_SOURCES = jartool.c dostime.c compress.c pushback.c jartool.h zipfile.h dostime.h compress.h pushback.h
-fastjar_LDADD = $(ZLIBS)
-fastjar_DEPENDENCIES = $(ZDEPS)
-grepjar_SOURCES = jargrep.c dostime.c compress.c pushback.c jartool.h zipfile.h dostime.h compress.h pushback.h
-grepjar_LDADD = $(ZLIBS)
-grepjar_DEPENDENCIES = $(ZDEPS)
+bin_PROGRAMS = jar grepjar
+jar_SOURCES = jartool.c dostime.c compress.c pushback.c jartool.h \
+zipfile.h dostime.h compress.h pushback.h
+jar_LDADD = $(ZLIBS) $(LIBIBERTY)
+jar_DEPENDENCIES = $(ZDEPS) $(LIBIBERTY)
+
+grepjar_SOURCES = jargrep.c dostime.c compress.c pushback.c jartool.h \
+zipfile.h dostime.h compress.h pushback.h
+grepjar_LDADD = $(ZLIBS) $(LIBIBERTY)
+grepjar_DEPENDENCIES = $(ZDEPS) $(LIBIBERTY)
 
 AM_CFLAGS = @fastjar_warn_cflags@
+
+MAKEINFO += -I $(srcdir)/../gcc/doc/include
+TEXINFO_TEX = $(srcdir)/../gcc/doc/include/texinfo.tex
+info_TEXINFOS = fastjar.texi
+fastjar_TEXINFOS = \
+       $(srcdir)/../gcc/doc/include/gcc-common.texi \
+       $(srcdir)/../gcc/doc/include/fdl.texi \
+       $(srcdir)/../gcc/doc/include/gpl.texi
+man_MANS = jar.1 grepjar.1
+EXTRA_DIST = $(man_MANS)
+
+TEXI2POD = perl $(srcdir)/../contrib/texi2pod.pl
+POD2MAN = pod2man --center="GNU" --release="gcc-@gcc_version@"
+
+$(srcdir)/jar.1: $(srcdir)/fastjar.texi
+       -$(TEXI2POD) -D jar < $(srcdir)/fastjar.texi > fastjar.pod
+       ($(POD2MAN) --section=1 fastjar.pod > jar.1.T$$$$ && \
+               mv -f jar.1.T$$$$ $(srcdir)/jar.1) || \
+               (rm -f jar.1.T$$$$ && exit 1)
+       rm -f fastjar.pod
+
+$(srcdir)/grepjar.1: $(srcdir)/fastjar.texi
+       -$(TEXI2POD) -D grepjar < $(srcdir)/fastjar.texi > grepjar.pod
+       ($(POD2MAN) --section=1 grepjar.pod > grepjar.1.T$$$$ && \
+               mv -f grepjar.1.T$$$$ $(srcdir)/grepjar.1) || \
+               (rm -f grepjar.1.T$$$$ && exit 1)
+       rm -f grepjar.pod