OSDN Git Service

Remove floatformat_arm_ext.
[pf3gnuchains/gcc-fork.git] / boehm-gc / configure.in
index 70764c4..155653d 100644 (file)
@@ -1,13 +1,24 @@
-dnl Process this file with autoconf to produce configure.
+# Copyright (c) 1999-2001 by Red Hat, Inc. All rights reserved.
+# 
+# THIS MATERIAL IS PROVIDED AS IS, WITH ABSOLUTELY NO WARRANTY EXPRESSED
+# OR IMPLIED.  ANY USE IS AT YOUR OWN RISK.
+# 
+# Permission is hereby granted to use or copy this program
+# for any purpose,  provided the above notices are retained on all copies.
+# Permission to modify the code and to distribute modified code is granted,
+# provided the above notices are retained, and a notice that the code was
+# modified is included with the above copyright notice.
+#
+# Original author: Tom Tromey
 
-AC_INIT(gc_mark.h)
+dnl Process this file with autoconf to produce configure.
 
-dnl Can't be done in BOEHM_CONFIGURE because that confuses automake. 
-AC_CONFIG_AUX_DIR(..)
+AC_INIT(gcj_mlc.c)
 
-AC_CANONICAL_SYSTEM
+dnl Can't be done in GC_CONFIGURE because that confuses automake. 
+AC_CONFIG_AUX_DIR(.)
 
-BOEHM_CONFIGURE(.)
+GC_CONFIGURE(.)
 
 AM_PROG_LIBTOOL
 
@@ -22,93 +33,98 @@ AM_MAINTAINER_MODE
 # automake wants to see AC_EXEEXT.  But we don't need it.  And having
 # it is actually a problem, because the compiler we're passed can't
 # necessarily do a full link.  So we fool automake here.
-if test "x" = "y"; then
-   AC_EXEEXT
+if false; then
+  # autoconf 2.50 runs AC_EXEEXT by default, and the macro expands
+  # to nothing, so nothing would remain between `then' and `fi' if it
+  # were not for the `:' below.
+  :
+  AC_EXEEXT
 fi
 
-AC_MSG_CHECKING([for threads package to use])
-AC_ARG_ENABLE(threads, [  --enable-threads=TYPE   choose threading package],
-  THREADS=$enableval,
-  dnl FIXME: figure out native threads to use here.
-  THREADS=no)
-
-if test "$THREADS" = yes; then
-   case "$host" in
-    *-*-vxworks*)
-       THREADS=vxworks
-       ;;
-    *-*-linux*)
-       # FIXME: this isn't correct in all cases.
-       THREADS=posix
-       ;;
-    *-*-win*)
-       THREADS=win32
-       ;;
-    *-*-irix[[1-5]].*)
-       # No built-in threads library on IRIX 5.* and older.
-       THREADS=none
-       ;;
-    *-*-irix*)
-       # FIXME: for now, choose POSIX, because we implement that.
-       # Later, choose irix threads.
-       THREADS=posix
-       ;;
-    *-*-solaris*)
-       # FIXME: for now, choose POSIX, because we implement that.
-       # Later, choose solaris threads.
-       THREADS=posix
-       ;;
-    *)
-       # For now.
-       THREADS=none
-       ;;
-   esac
+AC_MSG_CHECKING([for thread model used by GCC])
+THREADS=`$CC -v 2>&1 | sed -n 's/^Thread model: //p'`
+if test -z "$THREADS"; then
+   THREADS=no
 fi
+AC_MSG_RESULT([$THREADS])
+
+AC_ARG_ENABLE(parallel-mark,
+[  --enable-parallel-mark      parallelize marking and free list construction],
+   [case "$THREADS" in
+      no | none | single)
+       AC_MSG_ERROR([Parallel mark requires --enable-threads=x spec])
+       ;;
+    esac]
+)
 
-INCLUDES=
-THREADLIB=
+INCLUDES=-I${srcdir}/include
+THREADLIBS=
 case "$THREADS" in
  no | none | single)
     THREADS=none
     ;;
  posix | pthreads)
     THREADS=posix
+    THREADLIBS=-lpthread
     case "$host" in
+     x86-*-linux* | ia64-*-linux* | i586-*-linux* | i686-*-linux*)
+       AC_DEFINE(GC_LINUX_THREADS)
+       AC_DEFINE(_REENTRANT)
+        if test "${enable_parallel_mark}"; then
+         AC_DEFINE(PARALLEL_MARK)
+       fi
+       AC_DEFINE(THREAD_LOCAL_ALLOC)
+       ;;
      *-*-linux*)
-       AC_DEFINE(LINUX_THREADS)
+       AC_DEFINE(GC_LINUX_THREADS)
        AC_DEFINE(_REENTRANT)
        ;;
+     *-*-hpux*)
+       AC_MSG_WARN("Only HP/UX 11 threads are supported.")
+       AC_DEFINE(GC_HPUX_THREADS)
+       AC_DEFINE(_POSIX_C_SOURCE,199506L)
+       if test "${enable_parallel_mark}" = yes; then
+         AC_DEFINE(PARALLEL_MARK)
+       fi
+       AC_DEFINE(THREAD_LOCAL_ALLOC)
+       THREADLIBS="-lpthread -lrt"
+       ;;
+     *-*-freebsd*)
+       AC_MSG_WARN("FreeBSD does not yet fully support threads with Boehm GC.")
+       AC_DEFINE(GC_FREEBSD_THREADS)
+       INCLUDES="$INCLUDES -pthread"
+       THREADLIBS=-pthread
+       ;;
      *-*-solaris*)
-       AC_DEFINE(SOLARIS_THREADS)
-       AC_DEFINE(_SOLARIS_PTHREADS)
+       AC_DEFINE(GC_SOLARIS_THREADS)
+       AC_DEFINE(GC_SOLARIS_PTHREADS)
        ;;
      *-*-irix*)
-       AC_DEFINE(IRIX_THREADS)
+       AC_DEFINE(GC_IRIX_THREADS)
+       ;;
+     *-*-cygwin*)
+       THREADLIBS=
        ;;
     esac
-    THREADLIB=-lpthread
     ;;
- decosf1 | irix | mach | os2 | solaris | win32 | dce | vxworks)
+ win32)
+    AC_DEFINE(GC_WIN32_THREADS)
+    ;;
+ decosf1 | irix | mach | os2 | solaris | dce | vxworks)
     AC_MSG_ERROR(thread package $THREADS not yet supported)
     ;;
  *)
     AC_MSG_ERROR($THREADS is an unknown thread package)
     ;;
 esac
-AC_MSG_RESULT($THREADS)
-AC_SUBST(THREADLIB)
-
-AC_ARG_ENABLE(java-gc,
-changequote(<<,>>)dnl
-<<  --enable-java-gc=TYPE   choose garbage collector [boehm]>>,
-changequote([,])
-  GC=$enableval,
-  GC=boehm)
-target_all=
-if test "$GC" = "boehm"; then
-   target_all=libgcjgc.la
-fi
+AC_SUBST(THREADLIBS)
+
+AC_CHECK_LIB(dl, dlopen, EXTRA_TEST_LIBS="$EXTRA_TEST_LIBS -ldl")
+AC_SUBST(EXTRA_TEST_LIBS)
+
+target_all=libgcjgc.la
 AC_SUBST(target_all)
+AC_SUBST(target_alias)
 
 dnl If the target is an eCos system, use the appropriate eCos
 dnl I/O routines.
@@ -138,11 +154,19 @@ AC_SUBST(CXXINCLUDES)
 
 machdep=
 case "$host" in
-# alpha_mach_dep.s assumes that pointers are not saved in fp registers.
-# Gcc on a 21264 can spill pointers to fp registers.  Oops.
-# alpha*-*-*)
-#    machdep="alpha_mach_dep.lo"
-#    ;;
+ alpha*-*-openbsd*)
+    machdep="alpha_mach_dep.lo"
+    if test x"${ac_cv_lib_dl_dlopen}" != xyes ; then
+       AC_MSG_WARN(OpenBSD/Alpha without dlopen(). Shared library support is disabled)
+       AM_DISABLE_SHARED
+    fi
+    ;;
+ alpha*-*-*)
+    machdep="alpha_mach_dep.lo"
+    ;;
+ i?86-*-solaris2.[[89]]*)
+    AC_DEFINE(SOLARIS25_PROC_VDB_BUG_FIXED)
+    ;;
  mipstx39-*-elf*)
     machdep="mips_ultrix_mach_dep.lo"
     AC_DEFINE(STACKBASE, __stackbase)
@@ -156,8 +180,15 @@ case "$host" in
     AC_DEFINE(NO_EXECUTE_PERMISSION)
     ;;
  sparc-sun-solaris2.3*)
+    machdep="sparc_mach_dep.lo"
     AC_DEFINE(SUNOS53_SHARED_LIB)
     ;;
+ sparc-sun-solaris2.*)
+    machdep="sparc_mach_dep.lo"
+    ;;
+ ia64-*-*)
+    machdep="mach_dep.lo ia64_save_regs_in_stack.lo"
+    ;;
 esac
 if test x"$machdep" = x; then
    machdep="mach_dep.lo"
@@ -189,23 +220,44 @@ dnl We need to override the top-level CFLAGS.  This is how we do it.
 MY_CFLAGS="$CFLAGS"
 AC_SUBST(MY_CFLAGS)
 
-dnl Define a few things to retarget the library towards
-dnl embedded Java.
+dnl Include defines that have become de facto standard.
+dnl ALL_INTERIOR_POINTERS can be overridden in startup code.
 AC_DEFINE(SILENT)
 AC_DEFINE(NO_SIGNALS)
+AC_DEFINE(NO_EXECUTE_PERMISSION)
+AC_DEFINE(ALL_INTERIOR_POINTERS)
+
+dnl By default, make the library as general as possible.
 AC_DEFINE(JAVA_FINALIZATION)
 AC_DEFINE(GC_GCJ_SUPPORT)
+AC_DEFINE(ATOMIC_UNCOLLECTABLE)
 
 dnl This is something of a hack.  When cross-compiling we turn off
-dnl some functionality.  We also enable the "small" configuration.
-dnl These is only correct when targetting an embedded system.  FIXME.
+dnl some functionality. These is only correct when targetting an
+dnl embedded system.  FIXME.
 if test -n "${with_cross_host}"; then
    AC_DEFINE(NO_SIGSET)
-   AC_DEFINE(NO_CLOCK)
-   AC_DEFINE(SMALL_CONFIG)
    AC_DEFINE(NO_DEBUGGING)
 fi
 
+AC_ARG_ENABLE(full-debug,
+[  --enable-full-debug include full support for pointer backtracing etc.],
+[ if test "$enable_full_debug" = "yes"; then
+    AC_MSG_WARN("Must define GC_DEBUG and use debug alloc. in clients.")
+    AC_DEFINE(KEEP_BACK_PTRS)
+    AC_DEFINE(DBG_HDRS_ALL)
+    case $host in
+      ia64-*-linux* )
+       AC_DEFINE(MAKE_BACK_GRAPH)
+      ;;
+      x86-*-linux* | i586-*-linux* | i686-*-linux* )
+       AC_DEFINE(MAKE_BACK_GRAPH)
+       AC_MSG_WARN("Client must not use -fomit-frame-pointer.")
+       AC_DEFINE(SAVE_CALL_COUNT, 8)
+      ;;
+    esac ]
+  fi)
+
 AM_CONDITIONAL(USE_LIBDIR, test -z "$with_cross_host")
 
 if test "${multilib}" = "yes"; then
@@ -214,15 +266,12 @@ else
   multilib_arg=
 fi
 
-AC_OUTPUT(Makefile,
-[
-dnl Put all the -D options in a file.  These are required before
-dnl boehm-config.h can be included.  This is a huge hack brought
-dnl about by overall poor structuring of this entire library.
+AC_OUTPUT(Makefile include/Makefile, [
+dnl Put all the -D options in a file.
 echo "$DEFS" > boehm-cflags
 
 if test -n "$CONFIG_FILES"; then
-  ac_file=Makefile . ${boehm_gc_basedir}/../config-ml.in
+  ac_file=Makefile . ${gc_basedir}/../config-ml.in
 fi],
 srcdir=${srcdir}
 host=${host}
@@ -230,7 +279,7 @@ target=${target}
 with_multisubdir=${with_multisubdir}
 ac_configure_args="${multilib_arg} ${ac_configure_args}"
 CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
-boehm_gc_basedir=${boehm_gc_basedir}
+gc_basedir=${gc_basedir}
 CC="${CC}"
 DEFS="$DEFS"
 )