OSDN Git Service

Remove floatformat_arm_ext.
[pf3gnuchains/gcc-fork.git] / boehm-gc / configure.in
index 219af7f..155653d 100644 (file)
@@ -90,8 +90,7 @@ case "$THREADS" in
        THREADLIBS="-lpthread -lrt"
        ;;
      *-*-freebsd*)
-       AC_MSG_WARN("Threaded GC is prone to deadlock before FreeBSD 4.5.")
-       AC_MSG_WARN("Related symptom is pthread_join returns spurious EINTR.")
+       AC_MSG_WARN("FreeBSD does not yet fully support threads with Boehm GC.")
        AC_DEFINE(GC_FREEBSD_THREADS)
        INCLUDES="$INCLUDES -pthread"
        THREADLIBS=-pthread
@@ -108,7 +107,10 @@ case "$THREADS" in
        ;;
     esac
     ;;
- decosf1 | irix | mach | os2 | solaris | win32 | dce | vxworks)
+ win32)
+    AC_DEFINE(GC_WIN32_THREADS)
+    ;;
+ decosf1 | irix | mach | os2 | solaris | dce | vxworks)
     AC_MSG_ERROR(thread package $THREADS not yet supported)
     ;;
  *)
@@ -122,6 +124,7 @@ AC_SUBST(EXTRA_TEST_LIBS)
 
 target_all=libgcjgc.la
 AC_SUBST(target_all)
+AC_SUBST(target_alias)
 
 dnl If the target is an eCos system, use the appropriate eCos
 dnl I/O routines.
@@ -151,15 +154,16 @@ AC_SUBST(CXXINCLUDES)
 
 machdep=
 case "$host" in
- alpha*-*-*)
+ alpha*-*-openbsd*)
     machdep="alpha_mach_dep.lo"
-    ;;
- alpha-*-openbsd*)
     if test x"${ac_cv_lib_dl_dlopen}" != xyes ; then
        AC_MSG_WARN(OpenBSD/Alpha without dlopen(). Shared library support is disabled)
        AM_DISABLE_SHARED
     fi
     ;;
+ alpha*-*-*)
+    machdep="alpha_mach_dep.lo"
+    ;;
  i?86-*-solaris2.[[89]]*)
     AC_DEFINE(SOLARIS25_PROC_VDB_BUG_FIXED)
     ;;
@@ -176,9 +180,13 @@ case "$host" in
     AC_DEFINE(NO_EXECUTE_PERMISSION)
     ;;
  sparc-sun-solaris2.3*)
+    machdep="sparc_mach_dep.lo"
     AC_DEFINE(SUNOS53_SHARED_LIB)
     ;;
- ia64-*-hpux*)
+ sparc-sun-solaris2.*)
+    machdep="sparc_mach_dep.lo"
+    ;;
+ ia64-*-*)
     machdep="mach_dep.lo ia64_save_regs_in_stack.lo"
     ;;
 esac
@@ -225,12 +233,10 @@ AC_DEFINE(GC_GCJ_SUPPORT)
 AC_DEFINE(ATOMIC_UNCOLLECTABLE)
 
 dnl This is something of a hack.  When cross-compiling we turn off
-dnl some functionality.  We also enable the "small" configuration.
-dnl These is only correct when targetting an embedded system.  FIXME.
+dnl some functionality. These is only correct when targetting an
+dnl embedded system.  FIXME.
 if test -n "${with_cross_host}"; then
    AC_DEFINE(NO_SIGSET)
-   AC_DEFINE(NO_CLOCK)
-   AC_DEFINE(SMALL_CONFIG)
    AC_DEFINE(NO_DEBUGGING)
 fi
 
@@ -241,7 +247,11 @@ AC_ARG_ENABLE(full-debug,
     AC_DEFINE(KEEP_BACK_PTRS)
     AC_DEFINE(DBG_HDRS_ALL)
     case $host in
+      ia64-*-linux* )
+       AC_DEFINE(MAKE_BACK_GRAPH)
+      ;;
       x86-*-linux* | i586-*-linux* | i686-*-linux* )
+       AC_DEFINE(MAKE_BACK_GRAPH)
        AC_MSG_WARN("Client must not use -fomit-frame-pointer.")
        AC_DEFINE(SAVE_CALL_COUNT, 8)
       ;;