OSDN Git Service

2000-09-30 Bryce McKinlay <bryce@albatross.co.nz>
[pf3gnuchains/gcc-fork.git] / boehm-gc / Makefile.am
index fba2c1f..263cdb6 100644 (file)
@@ -14,23 +14,29 @@ MULTISUBDIR =
 MULTIDO = true
 MULTICLEAN = true
 
-tooldir = $(exec_prefix)/$(target_alias)
-toollibdir = $(tooldir)/lib$(MULTISUBDIR)
-
-## FIXME: when native, use libtool to provide shared libraries.
-toollib_LIBRARIES = $(target_all)
-EXTRA_LIBRARIES = libgcjgc.a
-libgcjgc_a_SOURCES = allchblk.c alloc.c blacklst.c checksums.c \
-config.h dbg_mlc.c dyn_load.c finalize.c gc.h gc_alloc.h gc_cpp.h \
-gc_hdrs.h gc_mark.h gc_priv.h gc_private.h gc_typed.h headers.c        \
-irix_threads.c linux_threads.c malloc.c mallocx.c mark.c mark_rts.c \
+## Install a library built with a cross compiler in tooldir, not
+## libdir.
+if USE_LIBDIR
+toolexeclibdir = $(libdir)$(MULTISUBDIR)
+else
+toolexecdir = $(exec_prefix)/$(target_alias)
+toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+endif
+
+toolexeclib_LTLIBRARIES = $(target_all)
+EXTRA_LTLIBRARIES = libgcjgc.la
+libgcjgc_la_SOURCES = allchblk.c alloc.c blacklst.c checksums.c        \
+gcconfig.h dbg_mlc.c dyn_load.c finalize.c gc.h gc_alloc.h gc_cpp.h \
+gc_hdrs.h gc_mark.h gc_priv.h gc_private.h gc_typed.h gcj_mlc.c headers.c \
+hpux_irix_threads.c linux_threads.c malloc.c mallocx.c mark.c mark_rts.c \
 misc.c new_hblk.c obj_map.c os_dep.c pcr_interface.c ptr_chck.c        \
-quick_threads.c real_malloc.c reclaim.c solaris_pthreads.c stubborn.c \
-typd_mlc.c version.h weakpointer.h
-libgcjgc_a_LIBADD = @addobjs@
-libgcjgc_a_DEPENDENCIES = @addobjs@
+real_malloc.c reclaim.c solaris_pthreads.c solaris_threads.c \
+solaris_threads.h stubborn.c typd_mlc.c version.h weakpointer.h
+libgcjgc_la_LIBADD = @addobjs@
+libgcjgc_la_DEPENDENCIES = @addobjs@
+libgcjgc_la_LDFLAGS = -version-info 1:1:0 -rpath $(toolexeclibdir)
 
-EXTRA_libgcjgc_a_SOURCES = alpha_mach_dep.s mips_sgi_mach_dep.s        \
+EXTRA_libgcjgc_la_SOURCES = alpha_mach_dep.s mips_sgi_mach_dep.s \
 mips_ultrix_mach_dep.s rs6000_mach_dep.s sparc_mach_dep.s \
 sparc_sunos4_mach_dep.s mach_dep.c ecos.cc
 
@@ -39,22 +45,26 @@ AM_CFLAGS = @BOEHM_GC_CFLAGS@
 
 check_PROGRAMS = gctest
 gctest_SOURCES = test.c
-gctest_LDADD = ./libgcjgc.a
+gctest_LDADD = ./libgcjgc.la $(THREADLIB)
 
+TESTS = gctest
 
 ## FIXME: relies on internal code generated by automake.
-all_objs = @addobjs@ $(libgcjgc_a_OBJECTS)
-$(all_objs) : config.h gc_priv.h gc_hdrs.h gc.h gc_mark.h
+all_objs = @addobjs@ $(libgcjgc_la_OBJECTS)
+$(all_objs) : gcconfig.h gc_priv.h gc_hdrs.h gc.h gc_mark.h
 
 ## FIXME: we shouldn't have to do this, but automake forces us to.
-.s.o:
-       $(CC) -x assembler-with-cpp $(DEFS) $(INCLUDES) $(CPPFLAGS) $(BOEHM_GC_CFLAGS) \
-       $(MY_CFLAGS) -c $<
+.s.lo:
+## We use -Wp,-P to strip #line directives.  Irix `as' chokes on
+## these.
+       $(LTCOMPILE) -Wp,-P -x assembler-with-cpp -c $<
 
-## We have our own definition of COMPILE because we want to use our
+## We have our own definition of LTCOMPILE because we want to use our
 ## CFLAGS, not those passed in from the top level make.
-COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(MY_CFLAGS) $(BOEHM_GC_CFLAGS) 
-LINK = $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) \
+       $(AM_CPPFLAGS) $(CPPFLAGS) \
+       $(AM_CFLAGS) $(MY_CFLAGS) $(BOEHM_GC_CFLAGS) 
+LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
 
 AM_CFLAGS = @BOEHM_GC_CFLAGS@
 
@@ -105,12 +115,12 @@ CONFIG_STATUS_DEPENDENCIES = $(boehm_gc_basedir)/configure.host
 .PHONY: all-multi mostlyclean-multi clean-multi distclean-multi \
        maintainer-clean-multi
 
-all-recursive: all-multi
-install-recursive: install-multi
-mostlyclean-recursive: mostlyclean-multi
-clean-recursive: clean-multi
-distclean-recursive: distclean-multi
-maintainer-clean-recursive: maintainer-clean-multi
+all-am: all-multi
+install-am: install-multi
+mostlyclean-am: mostlyclean-multi
+clean-am: clean-multi
+distclean-am: distclean-multi
+maintainer-clean-am: maintainer-clean-multi
 
 all-multi:
        $(MULTIDO) $(AM_MAKEFLAGS) DO=all multi-do