OSDN Git Service

v2rayA: Update to 1.5.7
authorTianling Shen <cnsztl@immortalwrt.org>
Thu, 21 Apr 2022 03:58:12 +0000 (11:58 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Thu, 21 Apr 2022 03:58:12 +0000 (11:58 +0800)
Removed all upstreamed patches.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
v2raya/Makefile
v2raya/patches/001-fix-failed-to-clean-iptables-rules-in-some-cases.patch [deleted file]
v2raya/patches/002-fix-resolving-subscription-for-line-breaked-base64-s.patch [deleted file]
v2raya/patches/003-chore-upgrade-routingA-to-fix-the-quote-and-colon-co.patch [deleted file]
v2raya/patches/040-fix-panic-in-go-1.18.patch [deleted file]

index 1fad19e..7da8b8c 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=v2rayA
-PKG_VERSION:=1.5.6.2
+PKG_VERSION:=1.5.7
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=d949246aa9fe80aa9cb8fb4d80cb470f508bb44d4ac23e84e28e3b9abd30b67c
+PKG_HASH:=6d203ef95ac2a48f6f1808b93fc1cd1a4f32a0419710d0c7a74169f27c38ed9c
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
 
 PKG_LICENSE:=AGPL-3.0-only
diff --git a/v2raya/patches/001-fix-failed-to-clean-iptables-rules-in-some-cases.patch b/v2raya/patches/001-fix-failed-to-clean-iptables-rules-in-some-cases.patch
deleted file mode 100644 (file)
index 4ba35d5..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From e7839b5e9de01f8dca66449eb2e720963a56f403 Mon Sep 17 00:00:00 2001
-From: mzz2017 <mzz@tuta.io>
-Date: Sat, 5 Feb 2022 20:23:32 +0800
-Subject: [PATCH] fix: failed to clean iptables rules in some cases
-
----
- service/core/v2ray/transparent.go | 13 ++++++-------
- 1 file changed, 6 insertions(+), 7 deletions(-)
-
-diff --git a/core/v2ray/transparent.go b/core/v2ray/transparent.go
-index 5480660..07b01a0 100644
---- a/core/v2ray/transparent.go
-+++ b/core/v2ray/transparent.go
-@@ -12,12 +12,14 @@ import (
- )
- func DeleteTransparentProxyRules() {
--      removeResolvHijacker()
-       iptables.CloseWatcher()
--      iptables.Tproxy.GetCleanCommands().Run(false)
--      iptables.Redirect.GetCleanCommands().Run(false)
-+      if !conf.GetEnvironmentConfig().Lite {
-+              removeResolvHijacker()
-+              iptables.Tproxy.GetCleanCommands().Run(false)
-+              iptables.Redirect.GetCleanCommands().Run(false)
-+              iptables.DropSpoofing.GetCleanCommands().Run(false)
-+      }
-       iptables.SystemProxy.GetCleanCommands().Run(false)
--      iptables.DropSpoofing.GetCleanCommands().Run(false)
-       time.Sleep(100 * time.Millisecond)
- }
-@@ -89,9 +91,6 @@ func CheckAndSetupTransparentProxy(checkRunning bool, setting *configure.Setting
- }
- func CheckAndStopTransparentProxy() {
--      if !IsTransparentOn() {
--              return
--      }
-       DeleteTransparentProxyRules()
- }
--- 
-2.20.1
-
diff --git a/v2raya/patches/002-fix-resolving-subscription-for-line-breaked-base64-s.patch b/v2raya/patches/002-fix-resolving-subscription-for-line-breaked-base64-s.patch
deleted file mode 100644 (file)
index a730a0c..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 4a9347e0cc5effe67399931c804bcef1114d535f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=E9=AB=98=E6=B8=90=E7=A6=BB?=
- <zhangyibo.114514@bytedance.com>
-Date: Tue, 8 Feb 2022 17:52:56 +0800
-Subject: [PATCH] fix: resolving subscription for line-breaked base64 string
- (#406)
-
----
- service/common/crypto.go | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/common/crypto.go b/common/crypto.go
-index b9e5173..4a067e8 100644
---- a/common/crypto.go
-+++ b/common/crypto.go
-@@ -44,10 +44,11 @@ func Base64StdDecode(s string) (string, error) {
-       return string(raw), err
- }
--// 封装base64.URLEncoding进行解码,加入了长度补全。当error时,返回输入和err
-+// 封装base64.URLEncoding进行解码,加入了长度补全,换行删除。当error时,返回输入和err
- func Base64URLDecode(s string) (string, error) {
-       s = strings.TrimSpace(s)
-       saver := s
-+      s = strings.ReplaceAll(strings.ReplaceAll(s, "\n", ""), "\r", "")
-       if len(s)%4 > 0 {
-               s += strings.Repeat("=", 4-len(s)%4)
-       }
--- 
-2.20.1
-
diff --git a/v2raya/patches/003-chore-upgrade-routingA-to-fix-the-quote-and-colon-co.patch b/v2raya/patches/003-chore-upgrade-routingA-to-fix-the-quote-and-colon-co.patch
deleted file mode 100644 (file)
index 6916166..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-From f0e76da0ad8efcfcafe600817635824ae0bc6220 Mon Sep 17 00:00:00 2001
-From: mzz2017 <mzz@tuta.io>
-Date: Sat, 19 Feb 2022 18:43:13 +0800
-Subject: [PATCH] chore: upgrade routingA to fix the quote and colon conflict
-
----
- service/go.mod | 2 +-
- service/go.sum | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/go.mod b/go.mod
-index 128845c..8627a09 100644
---- a/go.mod
-+++ b/go.mod
-@@ -25,7 +25,7 @@ require (
-       github.com/tidwall/gjson v1.10.2
-       github.com/tidwall/sjson v1.2.3
-       github.com/v2fly/v2ray-core/v4 v4.42.2-0.20210928173456-a9979057dcaa
--      github.com/v2rayA/RoutingA v1.0.1
-+      github.com/v2rayA/RoutingA v1.0.2
-       github.com/v2rayA/beego/v2 v2.0.4
-       github.com/v2rayA/shadowsocksR v1.0.4
-       github.com/v2rayA/v2ray-lib v0.0.0-20211227083129-d4f59fbf62b8
-diff --git a/go.sum b/go.sum
-index e6088a2..8aa379d 100644
---- a/go.sum
-+++ b/go.sum
-@@ -213,8 +213,8 @@ github.com/v2fly/VSign v0.0.0-20201108000810-e2adc24bf848 h1:p1UzXK6VAutXFFQMnre
- github.com/v2fly/ss-bloomring v0.0.0-20210312155135-28617310f63e h1:5QefA066A1tF8gHIiADmOVOV5LS43gt3ONnlEl3xkwI=
- github.com/v2fly/v2ray-core/v4 v4.42.2-0.20210928173456-a9979057dcaa h1:MyrHPDN4JhKoOvBOK8UUVoXd4Pd9AoIfbLClTPEbKt4=
- github.com/v2fly/v2ray-core/v4 v4.42.2-0.20210928173456-a9979057dcaa/go.mod h1:6wk/2dqqbvcRFSLcSRR5GNfjMrcJcephXmA1HjZs0Pg=
--github.com/v2rayA/RoutingA v1.0.1 h1:vAU6Xz3aK8R2NvpKxnD/c54UouLlpGxMDhriCh6hBGU=
--github.com/v2rayA/RoutingA v1.0.1/go.mod h1:f5pkOS7f5YsjdSNWLTOTzv0/DaldMP0OeVY8Fi/G12g=
-+github.com/v2rayA/RoutingA v1.0.2 h1:UHBIdrflQ0zj+PXnEDLj9D2aTk2gYreIsvtfPKNdpu4=
-+github.com/v2rayA/RoutingA v1.0.2/go.mod h1:M9kQE+WtKChg48TABm9jdVBPjvm1bNDjm1zFPNfyU/c=
- github.com/v2rayA/beego/v2 v2.0.4 h1:rnlnGhip6akWhl7gUw0lYiW0x+9Q9q4eba+bBQgSCnY=
- github.com/v2rayA/beego/v2 v2.0.4/go.mod h1:PlQvo/G/eyvrJ1OaZ8rdgp/m0kh9CPIV3X1gSHS9UlE=
- github.com/v2rayA/shadowsocksR v1.0.4 h1:65Ltdy+I/DnlkQTJj+R+X85zhZ63ORE1Roy+agAcF/s=
--- 
-2.20.1
-
diff --git a/v2raya/patches/040-fix-panic-in-go-1.18.patch b/v2raya/patches/040-fix-panic-in-go-1.18.patch
deleted file mode 100644 (file)
index a13e1ab..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From eb210b5e634b65838b50387891ad837590fb2b4e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=E9=AB=98=E6=B8=90=E7=A6=BB?= <admin@gaojianli.me>
-Date: Tue, 22 Mar 2022 15:28:50 +0800
-Subject: [PATCH] fix: panic in go 1.18 (#462)
-
----
- go.mod | 2 +-
- go.sum | 2 ++
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/go.mod b/go.mod
-index 8627a09d..9a239804 100644
---- a/go.mod
-+++ b/go.mod
-@@ -50,7 +50,7 @@ require (
-       github.com/lufia/plan9stats v0.0.0-20211012122336-39d0f177ccd0 // indirect
-       github.com/mattn/go-isatty v0.0.12 // indirect
-       github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421 // indirect
--      github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742 // indirect
-+      github.com/modern-go/reflect2 v1.0.2 // indirect
-       github.com/pelletier/go-toml v1.2.0 // indirect
-       github.com/pires/go-proxyproto v0.6.1 // indirect
-       github.com/power-devops/perfstat v0.0.0-20210106213030-5aafc221ea8c // indirect
-diff --git a/go.sum b/go.sum
-index 8aa379de..e07329bf 100644
---- a/go.sum
-+++ b/go.sum
-@@ -145,6 +145,8 @@ github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421 h1:ZqeYNhU3OH
- github.com/modern-go/concurrent v0.0.0-20180228061459-e0a39a4cb421/go.mod h1:6dJC0mAP4ikYIbvyc7fijjWJddQyLn8Ig3JB5CqoB9Q=
- github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742 h1:Esafd1046DLDQ0W1YjYsBW+p8U2u7vzgW2SQVmlNazg=
- github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742/go.mod h1:bx2lNnkwVCuqBIxFjflWJWanXIb3RllmbCylyMrvgv0=
-+github.com/modern-go/reflect2 v1.0.2 h1:xBagoLtFs94CBntxluKeaWgTMpvLxC4ur3nMaC9Gz0M=
-+github.com/modern-go/reflect2 v1.0.2/go.mod h1:yWuevngMOJpCy52FWWMvUC8ws7m/LJsjYzDa0/r8luk=
- github.com/mohae/deepcopy v0.0.0-20170929034955-c48cc78d4826 h1:RWengNIwukTxcDr9M+97sNutRR1RKhG96O6jWumTTnw=
- github.com/mohae/deepcopy v0.0.0-20170929034955-c48cc78d4826/go.mod h1:TaXosZuwdSHYgviHp1DAtfrULt5eUgsSMsZf+YrPgl8=
- github.com/muhammadmuzzammil1998/jsonc v0.0.0-20201229145248-615b0916ca38 h1:0FrBxrkJ0hVembTb/e4EU5Ml6vLcOusAqymmYISg5Uo=