OSDN Git Service

change release version
[karesansui/karesansui.git] / doc / redhat.spec
index e47adf8..a1e3ea8 100644 (file)
@@ -5,8 +5,8 @@
 
 %define __python $(which python)
 %define __app karesansui
-%define version 1.1.0
-%define release 2
+%define version 2.0.1
+%define release 1
 %define date %(echo `LANG=C date +%%Y%%m%%d%%H%%M%%S`)
 
 %if %{commerce}
@@ -65,6 +65,15 @@ On the Web for virtualization management software to manage.
     The guest OS and the management of resources and dynamic changes can be done easily.
     RESTful Web applications in architecture.
 
+%package lib
+Summary: libraries for Karesansui Core
+Group: Applications/System
+License: LGPL
+Requires: %{name} = %{version}
+
+%description lib
+libraries for Karesansui Core
+
 %package data
 Summary: UI data for Karesansui Core
 Group: Applications/System
@@ -129,6 +138,12 @@ install -d -m 0770 $RPM_BUILD_ROOT%{__sysconfdir}
 %{__cp} -f $RPM_BUILD_ROOT%{__sysconfdir}/log.conf{.example,}
 %{__cp} -fr doc/lighttpd/ $RPM_BUILD_ROOT%{__sysconfdir}/lighttpd.example/
 %{__cp} -f doc/whitelist.conf.example $RPM_BUILD_ROOT%{__sysconfdir}/
+%{__cp} -f doc/service.xml.example $RPM_BUILD_ROOT%{__sysconfdir}/service.xml
+%{__cp} -f doc/logview.xml.example $RPM_BUILD_ROOT%{__sysconfdir}/logview.xml
+%{__cp} -fr doc/template/ $RPM_BUILD_ROOT%{__sysconfdir}/template/
+
+install -d -m 0770 $RPM_BUILD_ROOT/etc/cron.d/
+%{__cp} -f doc/cron_cleantmp.example $RPM_BUILD_ROOT/etc/cron.d/karesansui_cleantmp
 
 install -d -m 0770 $RPM_BUILD_ROOT/{etc,var}/opt/karesansui
 install -d -m 0770 $RPM_BUILD_ROOT/var/log/karesansui
@@ -274,19 +289,20 @@ fi
 %dir %{python_sitelib}/
 %dir %{python_sitelib}/karesansui/
 %dir %{python_sitelib}/karesansui/db/
-%dir %{python_sitelib}/karesansui/lib/
 %dir %{python_sitelib}/karesansui/static/
 %{python_sitelib}/karesansui/*.py*
 %{python_sitelib}/karesansui/db/*.py*
 %{python_sitelib}/karesansui/db/access/*.py*
 %{python_sitelib}/karesansui/db/model/*.py*
-%{python_sitelib}/karesansui/lib/*
 %{python_sitelib}/karesansui/static/js/*
 %{python_sitelib}/karesansui/static/lib/*
 %{__sysconfdir}/*.example
 %defattr(0770,root,%{_group})
 %config(noreplace) %{__sysconfdir}/*.conf
+%config(noreplace) %{__sysconfdir}/*.xml
 %dir %{__sysconfdir}/
+%dir %{__sysconfdir}/template/
+%{__sysconfdir}/template/*
 %dir /var/opt/karesansui/
 %dir /var/log/karesansui/
 %dir %{__tmpdir}/
@@ -294,6 +310,12 @@ fi
 %dir /var/opt/karesansui/cache
 %defattr(0770,%{_group_member},%{_group})
 %dir /var/opt/karesansui/cache/yum
+/etc/cron.d/*
+
+%files lib
+%defattr(-,root,%{_group})
+%dir %{python_sitelib}/karesansui/lib/
+%{python_sitelib}/karesansui/lib/*
 
 %files data
 %defattr(-,root,%{_group})
@@ -330,6 +352,19 @@ fi
 %{python_sitelib}/karesansui/plus/*
 
 %changelog
+* Fri Jul 23 2010 Keisuke Fukawa <keisuke@karesansui-project.info> - 2.0.0-2
+- version 2.0.0 stable release.
+
+* Mon May 24 2010 Taizo ITO <taizo@karesansui-project.info> - 2.0.0-1
+- version 2.0.0 beta release.
+- 'karesansui-lib' sub package that includes python libraries is separated from core package.
+
+* Wed Jan 06 2010 Kei Funagayama <kei@karesansui-project.info> - 1.1.0-4
+- version 1.1.0 beta release.
+
+* Fri Dec 25 2009 Taizo ITO <taizo@karesansui-project.info> - 1.1.0-3
+- Fixed attach/detach device.
+
 * Mon Dec 14 2009 Kei Funagayama <kei@karesansui-project.info> - 1.1.0-2
 - Add "plus" package.
 - Add Software Update feature.