OSDN Git Service

change release version
[karesansui/karesansui.git] / doc / redhat.spec
index 54f480f..a1e3ea8 100644 (file)
@@ -5,8 +5,8 @@
 
 %define __python $(which python)
 %define __app karesansui
-%define version 1.0.3
-%define release 2
+%define version 2.0.1
+%define release 1
 %define date %(echo `LANG=C date +%%Y%%m%%d%%H%%M%%S`)
 
 %if %{commerce}
@@ -38,6 +38,7 @@
 %define _user_doc       Karesansui Project
 %define _uid_min        250
 %define _uid_max        300
+%define _group_member   wwwhde
 
 Summary: Virtualization management tool(Web Application) 
 Summary(ja): オープンソースの仮想ホスト管理アプリケーション
@@ -64,6 +65,15 @@ On the Web for virtualization management software to manage.
     The guest OS and the management of resources and dynamic changes can be done easily.
     RESTful Web applications in architecture.
 
+%package lib
+Summary: libraries for Karesansui Core
+Group: Applications/System
+License: LGPL
+Requires: %{name} = %{version}
+
+%description lib
+libraries for Karesansui Core
+
 %package data
 Summary: UI data for Karesansui Core
 Group: Applications/System
@@ -101,6 +111,17 @@ Requires: hde-python-paste
 %description test
 Unit test environment for Karesansui Core
 
+%package plus
+Summary: additional packages that extend functionality of existing packages
+Group: Applications/System
+License: See the source code
+Requires: %{name} = %{version}
+Requires: yum
+Requires: rpm-python
+
+%description plus
+additional packages that extend functionality of existing packages
+
 %prep
 %setup -n %{__app}-%{version}
 
@@ -117,6 +138,12 @@ install -d -m 0770 $RPM_BUILD_ROOT%{__sysconfdir}
 %{__cp} -f $RPM_BUILD_ROOT%{__sysconfdir}/log.conf{.example,}
 %{__cp} -fr doc/lighttpd/ $RPM_BUILD_ROOT%{__sysconfdir}/lighttpd.example/
 %{__cp} -f doc/whitelist.conf.example $RPM_BUILD_ROOT%{__sysconfdir}/
+%{__cp} -f doc/service.xml.example $RPM_BUILD_ROOT%{__sysconfdir}/service.xml
+%{__cp} -f doc/logview.xml.example $RPM_BUILD_ROOT%{__sysconfdir}/logview.xml
+%{__cp} -fr doc/template/ $RPM_BUILD_ROOT%{__sysconfdir}/template/
+
+install -d -m 0770 $RPM_BUILD_ROOT/etc/cron.d/
+%{__cp} -f doc/cron_cleantmp.example $RPM_BUILD_ROOT/etc/cron.d/karesansui_cleantmp
 
 install -d -m 0770 $RPM_BUILD_ROOT/{etc,var}/opt/karesansui
 install -d -m 0770 $RPM_BUILD_ROOT/var/log/karesansui
@@ -124,6 +151,9 @@ install -d -m 0770 $RPM_BUILD_ROOT%{__tmpdir}
 
 find $RPM_BUILD_ROOT%{python_sitelib}/karesansui -type d -exec chmod g+rwx \{\} \; 2>/dev/null
 
+install -d -m 0770 $RPM_BUILD_ROOT/{etc,var}/opt/karesansui/cache
+install -d -m 0770 $RPM_BUILD_ROOT/{etc,var}/opt/karesansui/cache/yum
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -160,11 +190,11 @@ if [ $? -ne 0 ]; then
   /usr/sbin/useradd -c "%{_user_doc}" -u ${_uid} -g %{_group} -s /bin/false -r %{_user} 2> /dev/null || :
 fi
 
-# Add wwwhde user to %{_group} group member
-%{__grep} ^wwwhde: /etc/passwd >/dev/null 2>&1
+# Add %{_group_member} user to %{_group} group member
+%{__grep} ^%{_group_member}: /etc/passwd >/dev/null 2>&1
 if [ $? -eq 0 ]; then
-  gpasswd -a wwwhde %{_group} >/dev/null 2>&1
-  gpasswd -a %{_group} wwwhde >/dev/null 2>&1
+  gpasswd -a %{_group_member} %{_group} >/dev/null 2>&1
+  gpasswd -a %{_group} %{_group_member} >/dev/null 2>&1
 fi
 
 %post
@@ -194,7 +224,8 @@ if [ -d %{__vendor_sysconfdir} ]; then
 fi
 libvirt_datadir=/var/opt/hde/libvirt
 if [ -d ${libvirt_datadir} ]; then
-  for subdir in boot images snapshot disk
+  #for subdir in boot images snapshot disk
+  for subdir in domains
   do
     %{__mkdir_p} ${libvirt_datadir}/${subdir}
     %{__chmod} g+rwx ${libvirt_datadir}/${subdir} >/dev/null 2>&1
@@ -258,22 +289,33 @@ fi
 %dir %{python_sitelib}/
 %dir %{python_sitelib}/karesansui/
 %dir %{python_sitelib}/karesansui/db/
-%dir %{python_sitelib}/karesansui/lib/
 %dir %{python_sitelib}/karesansui/static/
 %{python_sitelib}/karesansui/*.py*
 %{python_sitelib}/karesansui/db/*.py*
 %{python_sitelib}/karesansui/db/access/*.py*
 %{python_sitelib}/karesansui/db/model/*.py*
-%{python_sitelib}/karesansui/lib/*
 %{python_sitelib}/karesansui/static/js/*
 %{python_sitelib}/karesansui/static/lib/*
 %{__sysconfdir}/*.example
 %defattr(0770,root,%{_group})
 %config(noreplace) %{__sysconfdir}/*.conf
+%config(noreplace) %{__sysconfdir}/*.xml
 %dir %{__sysconfdir}/
+%dir %{__sysconfdir}/template/
+%{__sysconfdir}/template/*
 %dir /var/opt/karesansui/
 %dir /var/log/karesansui/
 %dir %{__tmpdir}/
+%defattr(0770,root,%{_group})
+%dir /var/opt/karesansui/cache
+%defattr(0770,%{_group_member},%{_group})
+%dir /var/opt/karesansui/cache/yum
+/etc/cron.d/*
+
+%files lib
+%defattr(-,root,%{_group})
+%dir %{python_sitelib}/karesansui/lib/
+%{python_sitelib}/karesansui/lib/*
 
 %files data
 %defattr(-,root,%{_group})
@@ -304,10 +346,37 @@ fi
 %dir %{python_sitelib}/karesansui/tests/
 %{python_sitelib}/karesansui/tests/*
 
+%files plus
+%defattr(-,root,%{_group})
+%dir %{python_sitelib}/karesansui/plus/
+%{python_sitelib}/karesansui/plus/*
+
 %changelog
+* Fri Jul 23 2010 Keisuke Fukawa <keisuke@karesansui-project.info> - 2.0.0-2
+- version 2.0.0 stable release.
+
+* Mon May 24 2010 Taizo ITO <taizo@karesansui-project.info> - 2.0.0-1
+- version 2.0.0 beta release.
+- 'karesansui-lib' sub package that includes python libraries is separated from core package.
+
+* Wed Jan 06 2010 Kei Funagayama <kei@karesansui-project.info> - 1.1.0-4
+- version 1.1.0 beta release.
+
+* Fri Dec 25 2009 Taizo ITO <taizo@karesansui-project.info> - 1.1.0-3
+- Fixed attach/detach device.
+
+* Mon Dec 14 2009 Kei Funagayama <kei@karesansui-project.info> - 1.1.0-2
+- Add "plus" package.
+- Add Software Update feature.
+
+* Thu Dec 10 2009 Taizo ITO <taizo@karesansui-project.info> - 1.1.0-1
+- kvm support.
+- Changed paths for domain's image data.
+
 * Thu Oct 29 2009 Kei Funagayama <kei@karesansui-project.info> - 1.0.3-2
 - CentOS(i386/x86_64) support.
 - RHEL(i386/x86_64) support.
+
 * Tue Sep 18 2009 Kei Funagayama <kei@karesansui-project.info> - 1.0.3-1
 - Added checker for keymap selection.
 - Fixed web server setting bugs.
@@ -315,6 +384,7 @@ fi
     ** glibc detected *** /usr/bin/python: free(): invalid pointer:
 - Changed the format of system uri path.
     fixed error "unexpected Xen URI path '/system', try xen:///" for libvirt-0.6.5.
+
 * Thu Jun 18 2009 Kei Funagayama <kei@karesansui-project.info> - 1.0.2-1
 - Sparce file support is now available at creating a guest environment.
 - Keyboard maps selection is now available at creating a guest environment.
@@ -323,6 +393,7 @@ fi
 - sqlite time to register with the system, had not added the time zone information.
 - Network database is now available as pysilhouette database.
 - Addresses an issue which karesansui does not work at multi-host environment.
+
 * Tue Jun 9 2009 Kei Funagayama <kei@karesansui-project.info> - 1.0.1-1
 - Karesansui now works on CentOS5.3 64bit(x86_64), RHEL5.3 64bit(x86_64) and RHEL5.3 32bit(x86).
 - Added support for AMD Athlon64 or Opteron environment.
@@ -341,5 +412,6 @@ fi
 - Prevent input data from being posted to other resources when enter key is pressed on input forms.
 - Improved a check logic about guest ID.
 - Improved error handling on nonexistent NIC.
+
 * Tue May 19 2009 Taizo ITO <taizo@karesansui-project.info> - 1.0.0-1
 - Initial build.