OSDN Git Service

Fix 'Explore To' in context menu in Commit Dialog
[tortoisegit/TortoiseGitJp.git] / src / Git / targetver.h
1 #pragma once\r
2 \r
3 // The following macros define the minimum required platform.  The minimum required platform\r
4 // is the earliest version of Windows, Internet Explorer etc. that has the necessary features to run \r
5 // your application.  The macros work by enabling all features available on platform versions up to and \r
6 // including the version specified.\r
7 \r
8 // Modify the following defines if you have to target a platform prior to the ones specified below.\r
9 // Refer to MSDN for the latest info on corresponding values for different platforms.\r
10 #ifndef WINVER                          // Specifies that the minimum required platform is Windows Vista.\r
11 #define WINVER 0x0500           // Change this to the appropriate value to target other versions of Windows.\r
12 #endif\r
13 \r
14 #ifndef _WIN32_WINNT            // Specifies that the minimum required platform is Windows Vista.\r
15 #define _WIN32_WINNT 0x0500     // Change this to the appropriate value to target other versions of Windows.\r
16 #endif\r
17 \r
18 #ifndef _WIN32_WINDOWS          // Specifies that the minimum required platform is Windows 98.\r
19 #define _WIN32_WINDOWS 0x0410 // Change this to the appropriate value to target Windows Me or later.\r
20 #endif\r
21 \r
22 #ifndef _WIN32_IE                       // Specifies that the minimum required platform is Internet Explorer 7.0.\r
23 #define _WIN32_IE 0x0700        // Change this to the appropriate value to target other versions of IE.\r
24 #endif\r