OSDN Git Service

Both Ruby 1.9.3 and 1.8.7 are supported.
[shogi-server/shogi-server.git] / changelog
index 430ca72..36fd038 100644 (file)
--- a/changelog
+++ b/changelog
@@ -1,3 +1,30 @@
+2012-01-07  Daigo Moriwaki <daigo at debian dot org>
+
+       * [shogi-server]
+         - Added shogi_server/compatible.rb, which implements compatible
+           methods and allows Ruby 1.8.7 to run the server.
+         - test/TC_floodgate.rb failed with Ruby 1.8.7. This issue has
+           been fixed.
+         - test/TC_uchifuzume.rb did not run with Ruby 1.8.7. This issue
+           has been fixed.
+         - test/TC_league.rb failed with Ruby 1.8.7. This issue has been
+           fixed.
+       * README:
+         - Both Ruby 1.9.3 and 1.8.7 are supported.
+
+2012-01-06  Daigo Moriwaki <daigo at debian dot org>
+
+       * [shogi-server]
+         - test/TC_logger.rb depeneded on a specific directory where it was
+           running on. This issues has been fixed.
+
+2012-01-01  Daigo Moriwaki <daigo at debian dot org>
+
+       * [shogi-server]
+         - shogi_server/floodgate.rb: Generating next time around the new
+           year day by reading configuration files did not work correctly.
+           This issue has been fixed.
+
 2011-12-18  Daigo Moriwaki <daigo at debian dot org>
 
        * [sohgi-server]