OSDN Git Service

Ruby 2.0.0 or later is recommended to use with shogi-server since Ruby 1.8 reached...
[shogi-server/shogi-server.git] / changelog
index 28f1f02..1432246 100644 (file)
--- a/changelog
+++ b/changelog
@@ -1,3 +1,18 @@
+2014-11-24  Daigo Moriwaki <daigo at debian dot org>
+
+       * Ruby 2.0:
+         - Ruby 2.0.0 or later is recommended to use with shogi-server
+           since Ruby 1.8 reached its End-of-Life on the end of July, 2014.
+
+2014-07-19  Daigo Moriwaki <daigo at debian dot org>
+
+       * [mk_rate]
+         - Added a new option, --abnormal-threshold n:
+           Games that end with the 'abnormal' status are counted in
+           win/lost games for the rating calculation if a game plays more
+           than n plies. Otherwise (or if n is zero), abnormal games are
+           counted out of rating games.
+
 2014-01-07  Daigo Moriwaki <daigo at debian dot org>
 
        * [shogi-server]