OSDN Git Service

Fixed a bug #23245.
[shogi-server/shogi-server.git] / README
1 $Id$
2
3 = Shogi-server project
4
5 2008-11-30 Daigo Moriwaki <daigo at debian dot org>
6
7 The Shogi-server project develops Shogi-server, a rating tool and so on.
8
9 == Shogi-server
10
11 Shogi-server is a server that implements the Server Protocol Ver 1.1 defined
12 by Computer Shogi Association (CSA[http://www.computer-shogi.org/index_e.html]) 
13 in order for computer shogi players to play games.   
14
15 === Pre-requires
16
17 Ruby 1.8.7:: Ruby 1.8.6 or earlier are not supported.
18
19 For Debian,
20  $ sudo aptitude install ruby1.8
21
22 === Install
23
24  $ svn checkout \ 
25      http://svn.sourceforge.jp/svnroot/shogi-server/shogi-server/trunk shogi-server
26
27 The following files are required to run Shogi-server:
28
29 - shogi-server
30 - shogi_server.rb
31 - shogi_server/**/*.rb
32
33 === Run
34
35  $ ruby ./shogi-server --pid-file shogi-server.pid \
36                        --daemon . \
37                        --player-log-dir player-log-dir \
38                        --floodgate-history floodgate_history.yaml \
39                        floodgatetest 4000
40
41 == Other tools
42
43 See documents at the head of each source file.
44
45 * mk_rate
46 * mk_html
47 * showgame