OSDN Git Service

test/TC_league.rb failed with Ruby 1.8.7. This issue has been fixed.
[shogi-server/shogi-server.git] / README
1 $Id$
2
3 = Shogi-server project
4
5 2008-11-30 Daigo Moriwaki <daigo at debian dot org>
6
7 The Shogi-server project develops Shogi-server, a rating tool and so on.
8
9 == Shogi-server
10
11 Shogi-server is a server that implements the Server Protocol Ver 1.1 defined
12 by Computer Shogi Association (CSA[http://www.computer-shogi.org/index_e.html]) 
13 in order for computer shogi players to play games.   
14
15 === Pre-requires
16
17 Ruby 1.9.3:: Ruby 1.9.2 or earlier are not supported.
18
19 The Ruby community claimed that Ruby 1.8 had no future.
20
21 As of December 2011, Shogi-server runs with Ruby 1.8.7. In future, however,
22 incompatible changes may be incorporated in Shogi-server. It is
23 recommended that you soon upgrade to Ruby 1.9.3.
24
25 For Debian,
26  $ sudo aptitude install ruby1.9.1
27
28 Note that in Debian the latest ruby1.9.1 package comes from Ruby 1.9.3.
29 "1.9.1" in the package name is Ruby internal API version, not release version.
30
31 === Install
32
33  $ git clone git://git.sourceforge.jp/gitroot/shogi-server/shogi-server.git
34
35 The following files are required to run Shogi-server:
36
37 - shogi-server
38 - shogi_server.rb
39 - shogi_server/**/*.rb
40
41 === Run
42
43  $ ruby1.9.1 ./shogi-server --pid-file shogi-server.pid \
44                             --daemon . \
45                             --player-log-dir player-log-dir \
46                             --floodgate-history floodgate_history.yaml \
47                             floodgatetest 4000
48
49 == Other tools
50
51 See documents at the head of each source file.
52
53 * mk_rate
54 * mk_html
55 * showgame