OSDN Git Service

* configure.ac: Update minimum MPC version to 0.8.
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>
Mon, 30 Nov 2009 06:12:16 +0000 (06:12 +0000)
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>
Mon, 30 Nov 2009 06:12:16 +0000 (06:12 +0000)
* configure: Regenerate.

gcc:
* doc/install.texi: Update minimum MPC version to 0.8.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@154750 138bc75d-0d04-0410-961f-82ee72b054a4

ChangeLog
configure
configure.ac
gcc/ChangeLog
gcc/doc/install.texi

index a9d99bb..1a4989f 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2009-11-30  Kaveh R. Ghazi  <ghazi@caip.rutgers.edu>
+
+       * configure.ac: Update minimum MPC version to 0.8.
+       * configure: Regenerate.
+
 2009-11-21  Sebastian Pop  <sebpop@gmail.com>
 
        * configure.ac: Check for version 0.15.5 or later revision of CLooG.
index d65bbe2..d7d7e12 100755 (executable)
--- a/configure
+++ b/configure
@@ -5530,7 +5530,7 @@ int
 main ()
 {
 
-    #if MPC_VERSION < MPC_VERSION_NUM (0,7,0)
+    #if MPC_VERSION < MPC_VERSION_NUM (0,8,0)
     choke me
     #endif
 
@@ -5615,6 +5615,7 @@ main ()
     mpc_neg (n, n, MPC_RNDNN);
     mpc_sqr (n, n, MPC_RNDNN);
     mpc_pow (n, n, n, MPC_RNDNN);
+    mpc_acosh (n, n, MPC_RNDNN);
     mpc_clear (n);
 
   ;
index 2915932..c9c5f0a 100644 (file)
@@ -1367,7 +1367,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
     CFLAGS="$CFLAGS $mpcinc"
     AC_MSG_CHECKING([for the correct version of mpc.h])
     AC_TRY_COMPILE([#include <mpc.h>],[
-    #if MPC_VERSION < MPC_VERSION_NUM (0,7,0)
+    #if MPC_VERSION < MPC_VERSION_NUM (0,8,0)
     choke me
     #endif
     ], [AC_MSG_RESULT([yes]); have_mpc=maybe],
@@ -1414,6 +1414,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
     mpc_neg (n, n, MPC_RNDNN);
     mpc_sqr (n, n, MPC_RNDNN);
     mpc_pow (n, n, n, MPC_RNDNN);
+    mpc_acosh (n, n, MPC_RNDNN);
     mpc_clear (n);
     ], [AC_MSG_RESULT([yes]); have_mpc=yes],
        [AC_MSG_RESULT([no]); have_mpc=no; mpclibs= ; mpcinc= ])
index 63a1924..351ddd6 100644 (file)
@@ -1,3 +1,7 @@
+2009-11-30  Kaveh R. Ghazi  <ghazi@caip.rutgers.edu>
+
+       * doc/install.texi: Update minimum MPC version to 0.8.
+
 2009-09-09  Segher Boessenkool  <segher@kernel.crashing.org>
 
        * config/rs6000/rs6000.md (fnmaddsf4_powerpc_1): Remove
index be7e69f..a98c45f 100644 (file)
@@ -344,7 +344,7 @@ not installed in your default library search path.
 
 Necessary to build libgcj, the GCJ runtime.
 
-@item MPC Library version 0.7.0 (or later)
+@item MPC Library version 0.8.0 (or later)
 
 Optional when building GCC@.  Having this library will enable
 additional optimizations on complex numbers.  It can be downloaded