OSDN Git Service

Guard against M4 versions with a buggy strstr.
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>
Sat, 5 Mar 2011 07:32:50 +0000 (07:32 +0000)
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>
Sat, 5 Mar 2011 07:32:50 +0000 (07:32 +0000)
config/:
* override.m4: Error out if a buggy M4 was detected, to
avoid spurious diffs in generated files.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@170697 138bc75d-0d04-0410-961f-82ee72b054a4

config/ChangeLog
config/override.m4

index ee4c699..2d8d573 100644 (file)
@@ -1,3 +1,9 @@
+2011-03-05  Ralf Wildenhues  <Ralf.Wildenhues@gmx.de>
+           Eric Blake  <eblake@redhat.com>
+
+       * override.m4: Error out if a buggy M4 was detected, to
+       avoid spurious diffs in generated files.
+
 2011-01-25  Jakub Jelinek  <jakub@redhat.com>
 
        * cloog.m4 (CLOOG_REQUESTED): Use $2 if --without-cloog.
index fc2d527..52bd1c3 100644 (file)
@@ -48,6 +48,12 @@ _GCC_AUTOCONF_VERSION_CHECK
 ])
 
 
+dnl Ensure we do not use a buggy M4.
+m4_if(m4_index([..wi.d.], [.d.]), [-1],
+  [m4_fatal(m4_do([m4 with buggy strstr detected.  Please install
+GNU M4 1.4.16 or newer and set the M4 environment variable]))])
+
+
 dnl Fix 2.64 cross compile detection for AVR and RTEMS
 dnl by not trying to compile fopen.
 m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.64],