OSDN Git Service

* config.gcc (obsolete): Add all ARM targets using the FPA.
authorrearnsha <rearnsha@138bc75d-0d04-0410-961f-82ee72b054a4>
Fri, 2 Mar 2012 09:37:30 +0000 (09:37 +0000)
committerrearnsha <rearnsha@138bc75d-0d04-0410-961f-82ee72b054a4>
Fri, 2 Mar 2012 09:37:30 +0000 (09:37 +0000)
(with_fpu): Obsolete selection of the FPA or Maverick on ARM.
* doc/install.texi: Avoid references to obsolete ARM ports.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@184775 138bc75d-0d04-0410-961f-82ee72b054a4

gcc/ChangeLog
gcc/config.gcc
gcc/doc/install.texi

index 751ca2b..9cbc9cc 100644 (file)
@@ -1,3 +1,9 @@
+2012-03-01  Richard Earnshaw  <rearnsha@arm.com>
+
+       * config.gcc (obsolete): Add all ARM targets using the FPA.
+       (with_fpu): Obsolete selection of the FPA or Maverick on ARM.
+       * doc/install.texi: Avoid references to obsolete ARM ports.
+
 2012-03-01  Joern Rennecke  <joern.rennecke@embecosm.com>
 
        * config/epiphany/epiphany.md (movmisalign<mode>): New patterns.
index 7d00a6c..99f0b47 100644 (file)
@@ -242,7 +242,18 @@ md_file=
 
 # Obsolete configurations.
 case ${target} in
+ # Avoid special cases that are not obsolete
+   arm*-*-*eabi*                       \
+ )
+     ;;
    alpha*-dec-osf5.1*                  \
+ | arm*-*-ecos-elf                     \
+ | arm*-*-elf                          \
+ | arm*-*-freebsd*                     \
+ | arm*-*-linux*                       \
+ | arm*-*-rtems*                       \
+ | arm*-*-uclinux*                     \
+ | arm*-wince-pe*                      \
  | mips-sgi-irix6.5                    \
  | mips*-*-openbsd*                    \
  | score-*                             \
@@ -3043,12 +3054,20 @@ case "${target}" in
 
                case "$with_fpu" in
                "" \
-               | fpa | fpe2 | fpe3 | maverick | vfp | vfp3 | vfpv3 \
+               | vfp | vfp3 | vfpv3 \
                | vfpv3-fp16 | vfpv3-d16 | vfpv3-d16-fp16 | vfpv3xd \
                | vfpv3xd-fp16 | neon | neon-fp16 | vfpv4 | vfpv4-d16 \
                | fpv4-sp-d16 | neon-vfpv4)
                        # OK
                        ;;
+               fpa | fpe2 | fpe3 | maverick)
+                       if test "x$enable_obsolete" != xyes; then
+                           echo "*** Configuration option --with-fpu=${with_fpu} is obsolete." >&2
+                           echo "*** Specify --enable-obsolete to build it anyway." >&2
+                           echo "*** Support will be REMOVED in the next major release of GCC." >&2
+                           exit 1
+                       fi
+                       ;;
                *)
                        echo "Unknown fpu used in --with-fpu=$with_fpu" 2>&1
                        exit 1
index 6c99d2b..53109ba 100644 (file)
@@ -3004,7 +3004,7 @@ information are.
 @item
 @uref{#amd64-x-solaris210,,amd64-*-solaris2.10}
 @item
-@uref{#arm-x-elf,,arm-*-elf}
+@uref{#arm-x-eabi,,arm-*-eabi}
 @item
 @uref{#avr,,avr}
 @item
@@ -3219,11 +3219,11 @@ This is a synonym for @samp{x86_64-*-solaris2.1[0-9]*}.
 @html
 <hr />
 @end html
-@heading @anchor{arm-x-elf}arm-*-elf
+@heading @anchor{arm-x-eabi}arm-*-eabi
 ARM-family processors.  Subtargets that use the ELF object format
 require GNU binutils 2.13 or newer.  Such subtargets include:
-@code{arm-*-freebsd}, @code{arm-*-netbsdelf}, @code{arm-*-*linux}
-and @code{arm-*-rtems}.
+@code{arm-*-netbsdelf}, @code{arm-*-*linux-gnueabi}
+and @code{arm-*-rtemseabi}.
 
 @html
 <hr />
@@ -4614,7 +4614,7 @@ Presently Windows for Itanium is not supported.
 
 @subheading Windows CE
 
-Windows CE is supported as a target only on ARM (arm-wince-pe), Hitachi
+Windows CE is supported as a target only on Hitachi
 SuperH (sh-wince-pe), and MIPS (mips-wince-pe).
 
 @subheading Other Windows Platforms