OSDN Git Service

Patch from Dara Hazeghi.
authorwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>
Fri, 11 Jul 2003 04:59:35 +0000 (04:59 +0000)
committerwilson <wilson@138bc75d-0d04-0410-961f-82ee72b054a4>
Fri, 11 Jul 2003 04:59:35 +0000 (04:59 +0000)
PR bootstrap/10758
* doc/install.texi: Document requirements for ia64-*-hpux* target.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@69214 138bc75d-0d04-0410-961f-82ee72b054a4

gcc/ChangeLog
gcc/doc/install.texi

index 339ccea..5c7cfc4 100644 (file)
@@ -1,3 +1,8 @@
+2003-07-10  Dara Hazeghi  <dhazeghi@yahoo.com>
+
+       PR bootstrap/10758
+       * doc/install.texi: Document requirements for ia64-*-hpux* target.
+
 2003-07-10  Roger Sayle  <roger@eyesopen.com>
 
        * config/ia64/hpux.h (TARGET_C99_FUNCTIONS): Define.
index a3378cc..32046c8 100644 (file)
@@ -1885,6 +1885,8 @@ GNU Compiler Collection on your machine.
 @item
 @uref{#ia64-*-linux,,ia64-*-linux}
 @item
+@uref{#ia64-*-hpux*,,ia64-*-hpux*}
+@item
 @uref{#*-ibm-aix*,,*-ibm-aix*}
 @item
 @uref{#ip2k-*-elf,,ip2k-*-elf}
@@ -2610,6 +2612,18 @@ more major ABI changes are expected.
 
 @html
 <hr />
+@end html
+@heading @anchor{ia64-*-hpux*}ia64-*-hpux*
+Building GCC on this target requires the GNU Assembler. The bundled HP
+assembler will not work. To prevent GCC from using the wrong assembler,
+the option @option{--with-gnu-as} may be necessary.
+
+The GCC libunwind library has not been ported to HPUX. This means that for
+GCC versions 3.2.3 and earlier, @option{--enable-libunwind-exceptions}
+is required to build GCC. For GCC 3.3 and later, this is the default.
+
+@html
+<hr />
 <!-- rs6000-ibm-aix*, powerpc-ibm-aix* -->
 @end html
 @heading @anchor{*-ibm-aix*}*-ibm-aix*