OSDN Git Service

* lib/target-supports.exp (check_weak_override_available): New.
authorjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>
Wed, 7 Jan 2009 23:53:03 +0000 (23:53 +0000)
committerjsm28 <jsm28@138bc75d-0d04-0410-961f-82ee72b054a4>
Wed, 7 Jan 2009 23:53:03 +0000 (23:53 +0000)
commitcabf5d2bd0a09c95eb24b9917f55495f4e216a85
treeded040516e1b86fef5c43a9bf45e66bc0e5ea049
parent9538c1d1e092d4f074924002c0ac917ab317314c
* lib/target-supports.exp (check_weak_override_available): New.
* lib/target-supports-dg.exp (dg-require-weak-override): New.
* gcc.dg/tree-ssa/pr27781.c, g++.dg/eh/weak1.C: Use
dg-require-weak-override.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@143172 138bc75d-0d04-0410-961f-82ee72b054a4
gcc/testsuite/ChangeLog
gcc/testsuite/g++.dg/eh/weak1.C
gcc/testsuite/gcc.dg/tree-ssa/pr27781.c
gcc/testsuite/lib/target-supports-dg.exp
gcc/testsuite/lib/target-supports.exp