OSDN Git Service

spu: Remove vec_extract_even/odd and vec_interleave expanders.
authorrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>
Tue, 25 Oct 2011 21:30:04 +0000 (21:30 +0000)
committerrth <rth@138bc75d-0d04-0410-961f-82ee72b054a4>
Tue, 25 Oct 2011 21:30:04 +0000 (21:30 +0000)
commit535780a57c64ac1cc7bf69eb6d15143fe87c32b0
tree83004855d56f4085e07f9c6a3b6bd0f39eac2a11
parent6620d7d7c5f2fe5df0df2b85e143746f76fdd4cf
spu: Remove vec_extract_even/odd and vec_interleave expanders.

        * config/spu/spu.md (vec_extract_evenv4si, vec_extract_evenv4sf,
        vec_extract_evenv8hi, vec_extract_evenv16qi, vec_extract_oddv4si,
        vec_extract_oddv4sf, vec_extract_oddv8hi, vec_extract_oddv16qi,
        vec_interleave_highv4sf, vec_interleave_lowv4sf,
        vec_interleave_highv4si, vec_interleave_lowv4si,
        vec_interleave_highv8hi, vec_interleave_lowv8hi,
        vec_interleave_highv16qi, vec_interleave_lowv16qi): Remove.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@180451 138bc75d-0d04-0410-961f-82ee72b054a4
gcc/ChangeLog
gcc/config/spu/spu.md