OSDN Git Service

Fix library dependencies for -Wl,--as-needed.
authorrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>
Sun, 27 Sep 2009 06:49:33 +0000 (06:49 +0000)
committerrwild <rwild@138bc75d-0d04-0410-961f-82ee72b054a4>
Sun, 27 Sep 2009 06:49:33 +0000 (06:49 +0000)
commit295fba81d7ad59f8f3a0e0ccb309b5d99046eadb
tree447040d312e28c4aba6b8805f1c6913013244950
parentbdb4507a2e8c50385dea1bdd5a24812ed3691f73
Fix library dependencies for -Wl,--as-needed.

gcc/:
PR bootstrap/40928
* configure.ac: Use $LIBS for '-ldl', not $LDFLAGS.
* configure: Regenerate.

libjava/:
PR libgcj/38298
* Makefile.am (libgcj_tools_la_LIBADD): Add '-lm'.
* Makefile.in: Regenerate.

git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@152215 138bc75d-0d04-0410-961f-82ee72b054a4
gcc/ChangeLog
gcc/configure
gcc/configure.ac
libjava/ChangeLog
libjava/Makefile.am
libjava/Makefile.in