OSDN Git Service

2012-08-02 Michael Hope <michael.hope@linaro.org>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / testsuite / Makefile.am
index 792c831..0cf8de5 100644 (file)
@@ -1,7 +1,7 @@
 ## Makefile for the testsuite subdirectory of the GNU C++ Standard library.
 ##
 ## Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
-## 2011 Free Software Foundation, Inc.
+## 2011, 2012 Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 ## Process this file with automake to produce Makefile.in.
@@ -59,6 +59,8 @@ site.exp: Makefile
        @echo 'set target_triplet $(target_triplet)' >>site.tmp
        @echo 'set libiconv "$(LIBICONV)"' >>site.tmp
        @echo 'set baseline_dir "$(baseline_dir)"' >> site.tmp
+       @echo 'set baseline_subdir_switch "$(baseline_subdir_switch)"' >> site.tmp
+       @echo 'set TEST_GCC_EXEC_PREFIX "$(libdir)/gcc/"' >> site.tmp
        @echo '## All variables above are generated by configure. Do Not Edit ##' >>site.tmp
        @test ! -f site.exp || \
          sed '1,/^## All variables above are.*##/ d' site.exp >> site.tmp
@@ -69,7 +71,7 @@ site.exp: Makefile
 
 extract_symvers = $(glibcxx_builddir)/scripts/extract_symvers
 
-baseline_subdir := $(shell $(CXX) --print-multi-dir)
+baseline_subdir := $(shell $(CXX) $(baseline_subdir_switch))
 
 baseline_symbols:
        -@(output=${baseline_dir}/${baseline_subdir}/baseline_symbols.txt; \
@@ -132,7 +134,7 @@ check-DEJAGNU $(check_DEJAGNU_normal_targets): check-DEJAGNU%: site.exp
          normal0) \
            if $(SHELL) -c "$$runtest --version" > /dev/null 2>&1; then \
              $$runtest $(AM_RUNTESTFLAGS) $(RUNTESTDEFAULTFLAGS) \
-                       $(RUNTESTFLAGS) abi.exp; \
+                       $(RUNTESTFLAGS) abi.exp prettyprinters.exp; \
            else echo "WARNING: could not find \`runtest'" 1>&2; :;\
            fi; \
            dirs="`cd $$srcdir; echo [013-9][0-9]_*/*`";; \
@@ -254,8 +256,8 @@ check-profile: site.exp
 # By adding these files here, automake will remove them for 'make clean'
 CLEANFILES = *.txt *.tst *.exe core* filebuf_* tmp* ostream_* *.log *.sum \
             testsuite_* site.exp abi_check baseline_symbols *TEST* *.dat \
-            *.ii *.s *.o *.cc *.x *.a *.so *.xml *.raw *.out
+            *.ii *.s *.o *.cc *.x *.a *.so *.xml *.raw *.out *.gdb
 
 # To remove directories.
 clean-local:
-       rm -rf de fr debug parallel profile binaries normal*
+       rm -rf de fr debug parallel profile binaries normal*