OSDN Git Service

2008-04-10 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / src / Makefile.am
index 33d1719..e6c0aad 100644 (file)
@@ -1,6 +1,6 @@
 ## Makefile for the src subdirectory of the GNU C++ Standard library.
 ##
-## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003
+## Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2005
 ## Free Software Foundation, Inc.
 ##
 ## This file is part of the libstdc++ version 3 distribution.
 
 ## You should have received a copy of the GNU General Public License along
 ## with this library; see the file COPYING.  If not, write to the Free
-## Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307,
+## Software Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
 ## USA.
 
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
-
-mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
+include $(top_srcdir)/fragment.am
 
 # Cross compiler support.
-CXX = @glibcxx_CXX@
-glibcxx_srcdir=@glibcxx_srcdir@
-glibcxx_builddir=@glibcxx_builddir@
-toolexecdir = @glibcxx_toolexecdir@
-toolexeclibdir = @glibcxx_toolexeclibdir@
 toolexeclib_LTLIBRARIES = libstdc++.la
 
 # Symbol versioning for shared libraries.
-if GLIBCXX_BUILD_VERSIONED_SHLIB
-port_specific_symbol_file = @port_specific_symbol_file@
-version_arg = -Wl,--version-script=libstdc++-symbol.ver
-libstdc++-symbol.ver:  ${glibcxx_srcdir}/@SYMVER_MAP@
-       cp ${glibcxx_srcdir}/@SYMVER_MAP@ ./libstdc++-symbol.ver
-       if test "x${port_specific_symbol_file}" != x; then \
-         sed -n '1,/DO NOT DELETE/p' $@ > tmp.top; \
-         sed -n '/DO NOT DELETE/,$$p' $@ > tmp.bottom; \
-         cat tmp.top $(port_specific_symbol_file) tmp.bottom > $@; \
-         rm tmp.top tmp.bottom; \
+if ENABLE_SYMVERS
+libstdc++-symbols.ver:  ${glibcxx_srcdir}/$(SYMVER_FILE) \
+               $(port_specific_symbol_files)
+       cp ${glibcxx_srcdir}/$(SYMVER_FILE) ./libstdc++-symbols.ver
+       chmod +w ./libstdc++-symbols.ver
+       if test "x$(port_specific_symbol_files)" != x; then \
+         if grep '^# Appended to version file.' \
+              $(port_specific_symbol_files) /dev/null > /dev/null 2>&1; then \
+           cat $(port_specific_symbol_files) >> $@; \
+         else \
+           sed -n '1,/DO NOT DELETE/p' $@ > tmp.top; \
+           sed -n '/DO NOT DELETE/,$$p' $@ > tmp.bottom; \
+           cat tmp.top $(port_specific_symbol_files) tmp.bottom > $@; \
+           rm tmp.top tmp.bottom; \
+         fi; \
        fi
+
+if ENABLE_SYMVERS_GNU
+version_arg = -Wl,--version-script=libstdc++-symbols.ver
+version_dep = libstdc++-symbols.ver
+endif
+if ENABLE_SYMVERS_GNU_NAMESPACE
+version_arg = -Wl,--version-script=libstdc++-symbols.ver
+version_dep = libstdc++-symbols.ver
+endif
+if ENABLE_SYMVERS_DARWIN
+version_arg = -Wl,-exported_symbols_list,libstdc++-symbols.explist
+version_dep = libstdc++-symbols.explist
+libstdc++-symbols.explist : libstdc++-symbols.ver \
+               ${glibcxx_srcdir}/scripts/make_exports.pl \
+               $(libstdc___la_OBJECTS) $(libstdc___la_LIBADD)
+       perl ${glibcxx_srcdir}/scripts/make_exports.pl \
+         libstdc++-symbols.ver \
+         $(libstdc___la_OBJECTS:%.lo=.libs/%.o) \
+        `echo $(libstdc___la_LIBADD) | \
+           sed 's,/\([^/.]*\)\.la,/.libs/\1.a,g'` \
+        > $@ || (rm -f $@ ; exit 1)
+endif
 else
 version_arg =
-libstdc++-symbol.ver:
+version_dep =
 endif
 
-# Compile flags that should be constant throughout the build, both for
-# SUBDIRS and for libstdc++-v3 in general.
-OPTIMIZE_CXXFLAGS = @OPTIMIZE_CXXFLAGS@
-
-# These bits are all figured out from configure. Look in acinclude.m4
-# or configure.in to see how they are set. See GLIBCXX_EXPORT_FLAGS
-CONFIG_CXXFLAGS = \
-       @SECTION_FLAGS@ @EXTRA_CXX_FLAGS@
-
-# Warning flags to use.
-WARN_CXXFLAGS = \
-       @WARN_FLAGS@ $(WERROR) -fdiagnostics-show-location=once
-
-# Use common includes from acinclude.m4/GLIBCXX_EXPORT_INCLUDES
-GLIBCXX_INCLUDES = @GLIBCXX_INCLUDES@
-LIBMATH_INCLUDES = @LIBMATH_INCLUDES@
-LIBSUPCXX_INCLUDES = @LIBSUPCXX_INCLUDES@
-TOPLEVEL_INCLUDES = @TOPLEVEL_INCLUDES@
-
-INCLUDES = \
-       -nostdinc++ \
-       $(GLIBCXX_INCLUDES) \
-       $(LIBSUPCXX_INCLUDES) $(LIBMATH_INCLUDES) \
-       $(TOPLEVEL_INCLUDES)
 
 # Source files linked in via configuration/make substitution for a
 # particular host.
 host_sources = \
+       atomicity.cc \
        codecvt_members.cc \
        collate_members.cc \
        ctype_members.cc \
        messages_members.cc \
        monetary_members.cc \
        numeric_members.cc \
-       time_members.cc
+       time_members.cc 
 
-codecvt_members.cc: ${glibcxx_srcdir}/@CCODECVT_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CCODECVT_CC@ . || true
+codecvt_members.cc: ${glibcxx_srcdir}/$(CCODECVT_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CCODECVT_CC) . || true
 
-collate_members.cc: ${glibcxx_srcdir}/@CCOLLATE_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CCOLLATE_CC@ . || true
+collate_members.cc: ${glibcxx_srcdir}/$(CCOLLATE_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CCOLLATE_CC) . || true
 
-ctype_members.cc: ${glibcxx_srcdir}/@CCTYPE_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CCTYPE_CC@ . || true
+ctype_members.cc: ${glibcxx_srcdir}/$(CCTYPE_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CCTYPE_CC) . || true
 
-messages_members.cc: ${glibcxx_srcdir}/@CMESSAGES_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CMESSAGES_CC@ . || true
+messages_members.cc: ${glibcxx_srcdir}/$(CMESSAGES_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CMESSAGES_CC) . || true
 
-monetary_members.cc: ${glibcxx_srcdir}/@CMONEY_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CMONEY_CC@ . || true
+monetary_members.cc: ${glibcxx_srcdir}/$(CMONEY_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CMONEY_CC) . || true
 
-numeric_members.cc: ${glibcxx_srcdir}/@CNUMERIC_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CNUMERIC_CC@ . || true
+numeric_members.cc: ${glibcxx_srcdir}/$(CNUMERIC_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CNUMERIC_CC) . || true
 
-time_members.cc: ${glibcxx_srcdir}/@CTIME_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CTIME_CC@ . || true
+time_members.cc: ${glibcxx_srcdir}/$(CTIME_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CTIME_CC) . || true
+
+atomicity_file = ${glibcxx_srcdir}/$(ATOMICITY_SRCDIR)/atomicity.h
+atomicity.cc: ${atomicity_file}
+       $(LN_S) ${atomicity_file} ./atomicity.cc || true
 
 # Source files linked in via configuration/make substitution for a
 # particular host, but with ad hoc naming rules.
 host_sources_extra = \
-       basic_file.cc \
-       c++locale.cc
+       basic_file.cc c++locale.cc ${ldbl_compat_sources} ${parallel_sources}
 
-c++locale.cc: ${glibcxx_srcdir}/@CLOCALE_CC@
-       @LN_S@ ${glibcxx_srcdir}/@CLOCALE_CC@ ./$@ || true
+c++locale.cc: ${glibcxx_srcdir}/$(CLOCALE_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(CLOCALE_CC) ./$@ || true
 
-basic_file.cc: ${glibcxx_srcdir}/@BASIC_FILE_CC@
-       @LN_S@ ${glibcxx_srcdir}/@BASIC_FILE_CC@ ./$@ || true
+basic_file.cc: ${glibcxx_srcdir}/$(BASIC_FILE_CC)
+       $(LN_S) ${glibcxx_srcdir}/$(BASIC_FILE_CC) ./$@ || true
+
+if ENABLE_PARALLEL
+parallel_sources = parallel_list.cc parallel_settings.cc
+else
+parallel_sources =
+endif
+
+if GLIBCXX_LDBL_COMPAT
+ldbl_compat_sources = compatibility-ldbl.cc
+else
+ldbl_compat_sources =
+endif
 
 # Sources present in the src directory.
 sources = \
-       allocator-inst.cc \
+       atomic.cc \
+       bitmap_allocator.cc \
+       pool_allocator.cc \
+       mt_allocator.cc \
        codecvt.cc \
+       compatibility.cc \
        complex_io.cc \
-       concept-inst.cc \
        ctype.cc \
-       demangle.cc \
-       ext-inst.cc \
-       fstream-inst.cc \
+       date_time.cc \
+       debug.cc \
        functexcept.cc \
-       globals.cc \
-       io-inst.cc \
+       hash.cc \
+       hash_c++0x.cc \
+       globals_io.cc \
+       hashtable.cc \
+       hashtable_c++0x.cc \
        ios.cc \
-       istream-inst.cc \
+       ios_failure.cc \
+       ios_init.cc \
+       ios_locale.cc \
        limits.cc \
+       list.cc \
+       debug_list.cc \
        locale.cc \
-       locale-inst.cc \
+       locale_init.cc \
+       locale_facets.cc \
        localename.cc \
+       stdexcept.cc \
+       strstream.cc \
+       system_error.cc \
+       tree.cc \
+       allocator-inst.cc \
+       concept-inst.cc \
+       fstream-inst.cc \
+       ext-inst.cc \
+       ios-inst.cc \
+       iostream-inst.cc \
+       istream-inst.cc \
+       istream.cc \
+       locale-inst.cc \
        misc-inst.cc \
        ostream-inst.cc \
        sstream-inst.cc \
-       stdexcept.cc \
-       stl_tree.cc \
        streambuf-inst.cc \
+       streambuf.cc \
        string-inst.cc \
-       strstream.cc \
        valarray-inst.cc \
+       wlocale-inst.cc \
        wstring-inst.cc \
        ${host_sources} \
-       ${host_sources_extra}
+       ${host_sources_extra} 
 
-VPATH = $(top_srcdir)/src:$(top_srcdir)
+vpath % $(top_srcdir)/src
+vpath % $(top_srcdir)
 
 libstdc___la_SOURCES = $(sources)
 
@@ -161,16 +195,14 @@ libstdc___la_LIBADD = \
        $(top_builddir)/libmath/libmath.la \
        $(top_builddir)/libsupc++/libsupc++convenience.la
 
-libstdc___la_DEPENDENCIES = libstdc++-symbol.ver $(libstdc___la_LIBADD)
+libstdc___la_DEPENDENCIES = ${version_dep} $(libstdc___la_LIBADD)
 
 libstdc___la_LDFLAGS = \
-       -version-info @libtool_VERSION@ ${version_arg} \
-       -lm @LIBUNWIND_FLAG@
-
+       -version-info $(libtool_VERSION) ${version_arg} -lm 
 
 # Use special rules for the deprecated source files so that they find
 # deprecated include files.
-GLIBCXX_INCLUDE_DIR=@glibcxx_builddir@/include
+GLIBCXX_INCLUDE_DIR=$(glibcxx_builddir)/include
 strstream.lo: strstream.cc
        $(LTCXXCOMPILE) -I$(GLIBCXX_INCLUDE_DIR)/backward -Wno-deprecated -c $<
 strstream.o: strstream.cc
@@ -184,13 +216,52 @@ concept-inst.lo: concept-inst.cc
 concept-inst.o: concept-inst.cc
        $(CXXCOMPILE) -D_GLIBCXX_CONCEPT_CHECKS -fimplicit-templates -c $<
 
-# Use special rules for the demangler, so that an additional implicit
-# instantiation file is not necessary.
-demangle.lo: demangle.cc
-       $(LTCXXCOMPILE) -fimplicit-templates -c $<
-demangle.o: demangle.cc
-       $(CXXCOMPILE) -fimplicit-templates -c $<
-
+# Use special rules for parallel mode compilation.
+PARALLEL_FLAGS = -fopenmp -D_GLIBCXX_PARALLEL -I$(glibcxx_builddir)/../libgomp
+parallel_list.lo: parallel_list.cc
+       $(LTCXXCOMPILE) $(PARALLEL_FLAGS) -c $<
+parallel_list.o: parallel_list.cc
+       $(CXXCOMPILE) $(PARALLEL_FLAGS) -c $<
+
+parallel_settings.lo: parallel_settings.cc
+       $(LTCXXCOMPILE) $(PARALLEL_FLAGS) -c $<
+parallel_settings.o: parallel_settings.cc
+       $(CXXCOMPILE) $(PARALLEL_FLAGS) -c $<
+
+# Use special rules for the C++0x sources so that the proper flags are passed.
+system_error.lo: system_error.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+system_error.o: system_error.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+hash_c++0x.lo: hash_c++0x.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+hash_c++0x.o: hash_c++0x.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+hashtable_c++0x.lo: hashtable_c++0x.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+hashtable_c++0x.o: hashtable_c++0x.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+date_time.lo: date_time.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+date_time.o: date_time.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+atomic.lo: atomic.cc
+       $(LTCXXCOMPILE) -x c++ -std=gnu++0x -c $<
+atomic.o: atomic.cc
+       $(CXXCOMPILE) -x c++ -std=gnu++0x -c $<
+
+if GLIBCXX_LDBL_COMPAT
+# Use special rules for compatibility-ldbl.cc compilation, as we need to
+# pass -mlong-double-64.
+compatibility-ldbl.lo: compatibility-ldbl.cc
+       $(LTCXXCOMPILE) -mlong-double-64 -c $<
+compatibility-ldbl.o: compatibility-ldbl.cc
+       $(CXXCOMPILE) -mlong-double-64 -c $<
+endif
 
 # AM_CXXFLAGS needs to be in each subdirectory so that it can be
 # modified in a per-library or per-sub-library way.  Need to manually
@@ -199,7 +270,6 @@ demangle.o: demangle.cc
 # as the occasion calls for it.
 AM_CXXFLAGS = \
        -fno-implicit-templates \
-       $(LIBSUPCXX_CXXFLAGS) \
        $(WARN_CXXFLAGS) \
        $(OPTIMIZE_CXXFLAGS) \
        $(CONFIG_CXXFLAGS)
@@ -224,7 +294,9 @@ AM_CXXFLAGS = \
 # CXXLINK, just after $(LIBTOOL), so that libtool doesn't have to
 # attempt to infer which configuration to use
 LTCXXCOMPILE = $(LIBTOOL) --tag CXX --mode=compile $(CXX) $(INCLUDES) \
-              $(AM_CPPFLAGS) $(CPPFLAGS) $(CXXFLAGS) $(AM_CXXFLAGS)
+              $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) 
+
+LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
 
 # 3) We'd have a problem when building the shared libstdc++ object if
 # the rules automake generates would be used.  We cannot allow g++ to
@@ -233,7 +305,7 @@ LTCXXCOMPILE = $(LIBTOOL) --tag CXX --mode=compile $(CXX) $(INCLUDES) \
 # directory to configure libstdc++-v3 to use gcc as the C++
 # compilation driver.
 CXXLINK = $(LIBTOOL) --tag CXX --mode=link $(CXX) \
-         @OPT_LDFLAGS@ @SECTION_LDFLAGS@ $(AM_CXXFLAGS) $(LDFLAGS) -o $@
+         $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
 
 
 # Added bits to build debug library.
@@ -247,7 +319,7 @@ endif
 
 debugdir = debug
 
-# Build parallel set of debug objects here.
+# Build a set of debug objects here.
 stamp-debug:
        if test ! -d ${debugdir}; then \
          mkdir -p ${debugdir}; \
@@ -262,9 +334,9 @@ stamp-debug:
        echo `date` > stamp-debug;
 
 build_debug: stamp-debug
-       (cd ${debugdir} && $(MAKE) CXXFLAGS='@DEBUG_FLAGS@' all)
+       (cd ${debugdir} && $(MAKE) CXXFLAGS='$(DEBUG_FLAGS)' all)
 
 # Install debug library here.
 install_debug:
        (cd ${debugdir} && $(MAKE) \
-       toolexeclibdir=@glibcxx_toolexeclibdir@/debug install)
+       toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)