OSDN Git Service

2009-06-21 Jonathan Wakely <jwakely.gcc@gmail.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / src / Makefile.am
index d218cea..4295d4d 100644 (file)
@@ -189,6 +189,7 @@ sources = \
        condition_variable.cc \
        chrono.cc \
        thread.cc \
+       future.cc \
        ${host_sources} \
        ${host_sources_extra} 
 
@@ -297,6 +298,11 @@ thread.lo: thread.cc
 thread.o: thread.cc
        $(CXXCOMPILE) -std=gnu++0x -c $<
 
+future.lo: future.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+future.o: future.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
 if GLIBCXX_LDBL_COMPAT
 # Use special rules for compatibility-ldbl.cc compilation, as we need to
 # pass -mlong-double-64.