OSDN Git Service

2011-03-14 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / libsupc++ / Makefile.am
index c67c294..701c2d9 100644 (file)
@@ -1,6 +1,8 @@
 ## Makefile for the GNU C++ Support library.
 ##
-## Copyright (C) 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+## Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,
+## 2009, 2010, 2011
+## Free Software Foundation, Inc.
 ##
 ## Process this file with automake to produce Makefile.in.
 ##
@@ -8,7 +10,7 @@
 ##
 ## GCC is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 ##
 ## GCC is distributed in the hope that it will be useful,
@@ -17,9 +19,8 @@
 ## GNU General Public License for more details.
 ##
 ## You should have received a copy of the GNU General Public License
-## along with GCC; see the file COPYING.  If not, write to
-## the Free Software Foundation, 59 Temple Place - Suite 330,
-## Boston, MA 02111-1307, USA.
+## along with GCC; see the file COPYING3.  If not see
+## <http://www.gnu.org/licenses/>.
 
 include $(top_srcdir)/fragment.am
 
@@ -30,9 +31,14 @@ toolexeclib_LTLIBRARIES = libsupc++.la
 # 2) integrated libsupc++convenience.la that is to be a part of libstdc++.a
 noinst_LTLIBRARIES = libsupc++convenience.la
 
+std_HEADERS = \
+       cxxabi.h exception initializer_list new typeinfo 
 
-headers = \
-       exception new typeinfo cxxabi.h exception_defines.h
+bits_HEADERS = \
+       cxxabi_forced.h hash_bytes.h \
+       exception_defines.h exception_ptr.h nested_exception.h 
+
+headers = $(std_HEADERS) $(bits_HEADERS)
 
 if GLIBCXX_HOSTED
   c_sources = \
@@ -40,10 +46,17 @@ if GLIBCXX_HOSTED
 endif
 
 sources = \
+       array_type_info.cc \
+       atexit_arm.cc \
+       bad_alloc.cc \
+       bad_cast.cc \
+       bad_typeid.cc \
+       class_type_info.cc \
        del_op.cc \
        del_opnt.cc \
        del_opv.cc \
        del_opvnt.cc \
+       dyncast.cc \
        eh_alloc.cc \
        eh_arm.cc \
        eh_aux_runtime.cc \
@@ -52,29 +65,38 @@ sources = \
        eh_exception.cc \
        eh_globals.cc \
        eh_personality.cc \
+       eh_ptr.cc \
        eh_term_handler.cc \
        eh_terminate.cc \
        eh_throw.cc \
        eh_type.cc \
        eh_unex_handler.cc \
+       enum_type_info.cc \
+       function_type_info.cc \
+       fundamental_type_info.cc \
        guard.cc \
+       guard_error.cc \
+       hash_bytes.cc \
+       nested_exception.cc \
        new_handler.cc \
        new_op.cc \
        new_opnt.cc \
        new_opv.cc \
        new_opvnt.cc \
+       pbase_type_info.cc \
+       pmem_type_info.cc \
+       pointer_type_info.cc \
        pure.cc \
+       si_class_type_info.cc \
        tinfo.cc \
        tinfo2.cc \
        vec.cc \
+       vmi_class_type_info.cc \
        vterminate.cc
 
-libsupc___la_SOURCES = $(sources) $(c_sources)
+libsupc___la_SOURCES = $(sources) $(c_sources) 
 libsupc__convenience_la_SOURCES = $(sources) $(c_sources)
 
-glibcxxinstalldir = $(gxx_include_dir)
-glibcxxinstall_HEADERS = $(headers)
-
 # AM_CXXFLAGS needs to be in each subdirectory so that it can be
 # modified in a per-library or per-sub-library way.  Need to manually
 # set this option because CONFIG_CXXFLAGS has to be after
@@ -100,8 +122,8 @@ C_COMPILE = \
        $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
 
 # LTCOMPILE is copied from LTCXXCOMPILE below.
-LTCOMPILE = $(LIBTOOL) --tag CC --tag disable-shared --mode=compile $(CC) \
-           $(DEFS) $(C_INCLUDES) $(LIBSUPCXX_PICFLAGS) \
+LTCOMPILE = $(LIBTOOL) --tag CC --tag disable-shared $(LIBTOOLFLAGS) --mode=compile \
+           $(CC) $(DEFS) $(C_INCLUDES) $(LIBSUPCXX_PICFLAGS) \
             $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
 
 cp-demangle.c:
@@ -113,7 +135,12 @@ cp-demangle.o: cp-demangle.c
        $(C_COMPILE) -DIN_GLIBCPP_V3 -Wno-error -c $<
 
 
-# libstdc++ libtool notes
+nested_exception.lo: nested_exception.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+nested_exception.o: nested_exception.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+# Libtool notes
 
 # 1) Need to explicitly set LTCXXCOMPILE so that AM_CXXFLAGS is
 # last. (That way, things like -O2 passed down from the toplevel can
@@ -134,9 +161,11 @@ cp-demangle.o: cp-demangle.c
 #
 # We have to put --tag disable-shared after --tag CXX lest things
 # CXX undo the affect of disable-shared.
-LTCXXCOMPILE = $(LIBTOOL) --tag CXX --tag disable-shared \
+LTCXXCOMPILE = $(LIBTOOL) --tag CXX --tag disable-shared $(LIBTOOLFLAGS) \
               --mode=compile $(CXX) $(TOPLEVEL_INCLUDES) \
-              $(AM_CPPFLAGS) $(CPPFLAGS) $(CXXFLAGS) $(AM_CXXFLAGS)
+              $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) 
+
+LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
 
 # 3) We'd have a problem when building the shared libstdc++ object if
 # the rules automake generates would be used.  We cannot allow g++ to
@@ -144,25 +173,47 @@ LTCXXCOMPILE = $(LIBTOOL) --tag CXX --tag disable-shared \
 # course is problematic at this point.  So, we get the top-level
 # directory to configure libstdc++-v3 to use gcc as the C++
 # compilation driver.
-CXXLINK = $(LIBTOOL) --tag CXX --tag disable-shared \
+CXXLINK = $(LIBTOOL) --tag CXX --tag disable-shared $(LIBTOOLFLAGS) \
          --mode=link $(CXX) \
-         $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
+         $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
 
+
+# Install notes
 # We have to have rules modified from the default to counteract SUN make
-# prepending each of $(glibcxxinstall_HEADERS) with VPATH below.
-install-glibcxxinstallHEADERS: $(glibcxxinstall_HEADERS)
+# prepending each of $(*_HEADERS) with VPATH below.
+stddir = $(gxx_include_dir)
+bitsdir = $(gxx_include_dir)/bits
+
+install-stdHEADERS: $(std_HEADERS)
        @$(NORMAL_INSTALL)
-       $(mkinstalldirs) $(DESTDIR)$(glibcxxinstalldir)
-       @list='$(glibcxxinstall_HEADERS)'; for p in $$list; do \
+       $(mkinstalldirs) $(DESTDIR)$(stddir)
+       @list='$(std_HEADERS)'; for p in $$list; do \
          q=`echo $$p | sed -e 's,.*/,,'`; \
          if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
-         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(glibcxxinstalldir)/$$q"; \
-         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(glibcxxinstalldir)/$$q; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q; \
+       done
+
+install-bitsHEADERS: $(bits_HEADERS)
+       @$(NORMAL_INSTALL)
+       $(mkinstalldirs) $(DESTDIR)$(bitsdir)
+       @list='$(bits_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q; \
+       done
+
+uninstall-stdHEADERS:
+       @$(NORMAL_UNINSTALL)
+       list='$(std_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         rm -f $(DESTDIR)$(stddir)/$$q; \
        done
 
-uninstall-glibcxxinstallHEADERS:
+uninstall-bitsHEADERS:
        @$(NORMAL_UNINSTALL)
-       list='$(glibcxxinstall_HEADERS)'; for p in $$list; do \
+       list='$(bits_HEADERS)'; for p in $$list; do \
          q=`echo $$p | sed -e 's,.*/,,'`; \
-         rm -f $(DESTDIR)$(glibcxxinstalldir)/$$q; \
+         rm -f $(DESTDIR)$(bitsdir)/$$q; \
        done