OSDN Git Service

2011-03-14 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / libsupc++ / Makefile.am
index b5948d4..701c2d9 100644 (file)
 ## Makefile for the GNU C++ Support library.
 ##
-## Copyright (C) 2000 Free Software Foundation, Inc.
+## Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,
+## 2009, 2010, 2011
+## Free Software Foundation, Inc.
 ##
 ## Process this file with automake to produce Makefile.in.
 ##
-## This file is part of GNU CC.
+## This file is part of GCC.
 ##
-## GNU CC is free software; you can redistribute it and/or modify
+## GCC is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 ##
-## GNU CC is distributed in the hope that it will be useful,
+## GCC is distributed in the hope that it will be useful,
 ## but WITHOUT ANY WARRANTY; without even the implied warranty of
 ## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 ## GNU General Public License for more details.
 ##
 ## You should have received a copy of the GNU General Public License
-## along with GNU CC; see the file COPYING.  If not, write to
-## the Free Software Foundation, 59 Temple Place - Suite 330,
-## Boston, MA 02111-1307, USA. 
-
-AUTOMAKE_OPTIONS = 1.3 cygnus
-MAINT_CHARSET = latin1
-
-# Cross compiler and multilib support.
-# Install a library built with a cross compiler in tooldir, not libdir.
-if USE_LIBDIR
-if VERSION_SPECIFIC_LIBS
-gcc_version = @gcc_version@
-toolexecdir = $(libdir)/gcc-lib/$(target_alias)
-toolexeclibdir = $(toolexecdir)/$(gcc_version)
-else
-toolexeclibdir = $(libdir)$(MULTISUBDIR)
-endif
-else
-toolexecdir = $(exec_prefix)/$(target_alias)
-toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
-endif
+## along with GCC; see the file COPYING3.  If not see
+## <http://www.gnu.org/licenses/>.
 
+include $(top_srcdir)/fragment.am
 
 # Need this library to both be part of libstdc++.a, and installed
 # separately too.
-# 1) separate libsupc++.la 
+# 1) separate libsupc++.la
 toolexeclib_LTLIBRARIES = libsupc++.la
 # 2) integrated libsupc++convenience.la that is to be a part of libstdc++.a
 noinst_LTLIBRARIES = libsupc++convenience.la
 
+std_HEADERS = \
+       cxxabi.h exception initializer_list new typeinfo 
 
-# Compile flags that should be constant throughout the build, both for
-# SUBDIRS and for libstdc++-v3 in general.
-OPTIMIZE_CXXFLAGS = @OPTIMIZE_CXXFLAGS@
-
-# These bits are all figured out from configure. Look in acinclude.m4
-# or configure.in to see how they are set. See GLIBCPP_EXPORT_FLAGS
-# NB: DEBUGFLAGS have to be at the end so that -O2 can be overridden.
-CONFIG_CXXFLAGS = \
-       @EXTRA_CXX_FLAGS@ @SECTION_FLAGS@ @CSHADOW_FLAGS@ @DEBUG_FLAGS@ 
+bits_HEADERS = \
+       cxxabi_forced.h hash_bytes.h \
+       exception_defines.h exception_ptr.h nested_exception.h 
 
-# Warning flags to use.
-WARN_CXXFLAGS = \
-       @WARN_FLAGS@ $(WERROR) @WFMT_FLAGS@
+headers = $(std_HEADERS) $(bits_HEADERS)
 
-# Use common includes from acinclude.m4/GLIBCPP_EXPORT_INCLUDES
-GLIBCPP_INCLUDE_DIR = @GLIBCPP_INCLUDE_DIR@
-C_INCLUDE_DIR = @C_INCLUDE_DIR@
-TOPLEVEL_INCLUDES = @TOPLEVEL_INCLUDES@
-LIBMATH_INCLUDES = @LIBMATH_INCLUDES@
-LIBSUPCXX_INCLUDES = @LIBSUPCXX_INCLUDES@
-LIBIO_INCLUDES = @LIBIO_INCLUDES@
-CSHADOW_INCLUDES = @CSHADOW_INCLUDES@
-
-INCLUDES = \
-       -I$(top_srcdir)/../gcc -I$(top_srcdir)/../include \
-       $(CSHADOW_INCLUDES)  $(LIBSUPCXX_INCLUDES) -I$(GLIBCPP_INCLUDE_DIR) \
-       $(CONFIG_INCLUDES) -I$(top_builddir)/include
-
-headers = \
-       cxxabi.h exception new new.h typeinfo
+if GLIBCXX_HOSTED
+  c_sources = \
+       cp-demangle.c 
+endif
 
 sources = \
+       array_type_info.cc \
+       atexit_arm.cc \
+       bad_alloc.cc \
+       bad_cast.cc \
+       bad_typeid.cc \
+       class_type_info.cc \
        del_op.cc \
        del_opnt.cc \
        del_opv.cc \
        del_opvnt.cc \
-       exception_support.cc \
+       dyncast.cc \
+       eh_alloc.cc \
+       eh_arm.cc \
+       eh_aux_runtime.cc \
+       eh_call.cc \
+       eh_catch.cc \
+       eh_exception.cc \
+       eh_globals.cc \
+       eh_personality.cc \
+       eh_ptr.cc \
+       eh_term_handler.cc \
+       eh_terminate.cc \
+       eh_throw.cc \
+       eh_type.cc \
+       eh_unex_handler.cc \
+       enum_type_info.cc \
+       function_type_info.cc \
+       fundamental_type_info.cc \
+       guard.cc \
+       guard_error.cc \
+       hash_bytes.cc \
+       nested_exception.cc \
        new_handler.cc \
        new_op.cc \
        new_opnt.cc \
        new_opv.cc \
        new_opvnt.cc \
+       pbase_type_info.cc \
+       pmem_type_info.cc \
+       pointer_type_info.cc \
        pure.cc \
+       si_class_type_info.cc \
        tinfo.cc \
        tinfo2.cc \
-       vec.cc
-
-libsupc___la_SOURCES = $(sources)
-libsupc__convenience_la_SOURCES = $(sources)
-
-# Check for various configure bits that change where the headers get installed.
-if GXX_INCLUDE_DIR
-glibcppinstalldir = @gxx_include_dir@
-else
-if VERSION_SPECIFIC_LIBS
-glibcppinstalldir = $(libdir)/gcc-lib/$(target_alias)/@gcc_version@/include/g++
-else
-glibcppinstalldir = $(prefix)/include/g++-@libstdcxx_interface@
-endif
-endif
-
-glibcppinstall_HEADERS = $(headers)
+       vec.cc \
+       vmi_class_type_info.cc \
+       vterminate.cc
 
-# Flags to force separate libtool library to be static only.
-LIBTOOL = @LIBTOOL@ --tag disable-shared
-LIBSUPCXX_CXXFLAGS = -prefer-pic
+libsupc___la_SOURCES = $(sources) $(c_sources) 
+libsupc__convenience_la_SOURCES = $(sources) $(c_sources)
 
 # AM_CXXFLAGS needs to be in each subdirectory so that it can be
 # modified in a per-library or per-sub-library way.  Need to manually
 # set this option because CONFIG_CXXFLAGS has to be after
 # OPTIMIZE_CXXFLAGS on the compile line so that -O2 can be overridden
-# as the occasion call for it. (ie, --enable-debug)
+# as the occasion call for it.
 AM_CXXFLAGS = \
        -fno-implicit-templates \
-       $(LIBSUPCXX_CXXFLAGS) \
+       $(LIBSUPCXX_PICFLAGS) \
        $(WARN_CXXFLAGS) \
        $(OPTIMIZE_CXXFLAGS) \
-       $(CONFIG_CXXFLAGS) 
+       $(CONFIG_CXXFLAGS)
+
+AM_MAKEFLAGS = \
+       "gxx_include_dir=$(gxx_include_dir)"
+
+
+# Use special rules for pulling things out of libiberty.  These
+# objects should be compiled with the "C" compiler, not the C++
+# compiler, and also should not use the C++ includes.
+C_INCLUDES = -I.. -I$(toplevel_srcdir)/libiberty -I$(toplevel_srcdir)/include
+C_COMPILE = \
+       $(CC) $(DEFS) $(C_INCLUDES) \
+       $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
 
-# libstdc++ libtool notes
+# LTCOMPILE is copied from LTCXXCOMPILE below.
+LTCOMPILE = $(LIBTOOL) --tag CC --tag disable-shared $(LIBTOOLFLAGS) --mode=compile \
+           $(CC) $(DEFS) $(C_INCLUDES) $(LIBSUPCXX_PICFLAGS) \
+            $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+
+cp-demangle.c:
+       rm -f $@
+       $(LN_S) $(toplevel_srcdir)/libiberty/cp-demangle.c $@
+cp-demangle.lo: cp-demangle.c
+       $(LTCOMPILE) -DIN_GLIBCPP_V3 -Wno-error -c $<
+cp-demangle.o: cp-demangle.c
+       $(C_COMPILE) -DIN_GLIBCPP_V3 -Wno-error -c $<
+
+
+nested_exception.lo: nested_exception.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+nested_exception.o: nested_exception.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+# Libtool notes
 
 # 1) Need to explicitly set LTCXXCOMPILE so that AM_CXXFLAGS is
 # last. (That way, things like -O2 passed down from the toplevel can
@@ -144,19 +157,63 @@ AM_CXXFLAGS = \
 # can't decide which configuration to use, and it gives up.  The
 # correct solution is to add `--tag CXX' to LTCXXCOMPILE and maybe
 # CXXLINK, just after $(LIBTOOL), so that libtool doesn't have to
-# attempt to infer which configuration to use
-LTCXXCOMPILE = $(LIBTOOL) --tag CXX --mode=compile $(CXX) $(INCLUDES) \
-              $(AM_CPPFLAGS) $(CPPFLAGS) $(CXXFLAGS) $(AM_CXXFLAGS) 
-
-# 3) We have a problem when building the shared libstdc++ object if
-# the rules automake generates would be used.  We cannot allow CXX to
-# be used in libtool since this would add -lstdc++ to the link line
-# which of course is problematic at this point.
-CXXLINK = $(LIBTOOL) --mode=link "$(CC)" \
-         @OPT_LDFLAGS@ @SECTION_LDFLAGS@ $(AM_CXXFLAGS) $(LDFLAGS) -o $@
-
-
-
-
-
-
+# attempt to infer which configuration to use.
+#
+# We have to put --tag disable-shared after --tag CXX lest things
+# CXX undo the affect of disable-shared.
+LTCXXCOMPILE = $(LIBTOOL) --tag CXX --tag disable-shared $(LIBTOOLFLAGS) \
+              --mode=compile $(CXX) $(TOPLEVEL_INCLUDES) \
+              $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) 
+
+LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+
+# 3) We'd have a problem when building the shared libstdc++ object if
+# the rules automake generates would be used.  We cannot allow g++ to
+# be used since this would add -lstdc++ to the link line which of
+# course is problematic at this point.  So, we get the top-level
+# directory to configure libstdc++-v3 to use gcc as the C++
+# compilation driver.
+CXXLINK = $(LIBTOOL) --tag CXX --tag disable-shared $(LIBTOOLFLAGS) \
+         --mode=link $(CXX) \
+         $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+
+# Install notes
+# We have to have rules modified from the default to counteract SUN make
+# prepending each of $(*_HEADERS) with VPATH below.
+stddir = $(gxx_include_dir)
+bitsdir = $(gxx_include_dir)/bits
+
+install-stdHEADERS: $(std_HEADERS)
+       @$(NORMAL_INSTALL)
+       $(mkinstalldirs) $(DESTDIR)$(stddir)
+       @list='$(std_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q; \
+       done
+
+install-bitsHEADERS: $(bits_HEADERS)
+       @$(NORMAL_INSTALL)
+       $(mkinstalldirs) $(DESTDIR)$(bitsdir)
+       @list='$(bits_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q; \
+       done
+
+uninstall-stdHEADERS:
+       @$(NORMAL_UNINSTALL)
+       list='$(std_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         rm -f $(DESTDIR)$(stddir)/$$q; \
+       done
+
+uninstall-bitsHEADERS:
+       @$(NORMAL_UNINSTALL)
+       list='$(bits_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         rm -f $(DESTDIR)$(bitsdir)/$$q; \
+       done