OSDN Git Service

2011-03-14 Benjamin Kosnik <bkoz@redhat.com>
[pf3gnuchains/gcc-fork.git] / libstdc++-v3 / libsupc++ / Makefile.am
index 0b2fd0b..701c2d9 100644 (file)
@@ -1,6 +1,7 @@
 ## Makefile for the GNU C++ Support library.
 ##
-## Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
+## Copyright (C) 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008,
+## 2009, 2010, 2011
 ## Free Software Foundation, Inc.
 ##
 ## Process this file with automake to produce Makefile.in.
@@ -30,10 +31,14 @@ toolexeclib_LTLIBRARIES = libsupc++.la
 # 2) integrated libsupc++convenience.la that is to be a part of libstdc++.a
 noinst_LTLIBRARIES = libsupc++convenience.la
 
+std_HEADERS = \
+       cxxabi.h exception initializer_list new typeinfo 
 
-headers = \
-       exception new typeinfo cxxabi.h cxxabi-forced.h exception_defines.h \
-       initializer_list exception_ptr.h nested_exception.h
+bits_HEADERS = \
+       cxxabi_forced.h hash_bytes.h \
+       exception_defines.h exception_ptr.h nested_exception.h 
+
+headers = $(std_HEADERS) $(bits_HEADERS)
 
 if GLIBCXX_HOSTED
   c_sources = \
@@ -43,6 +48,7 @@ endif
 sources = \
        array_type_info.cc \
        atexit_arm.cc \
+       bad_alloc.cc \
        bad_cast.cc \
        bad_typeid.cc \
        class_type_info.cc \
@@ -69,6 +75,9 @@ sources = \
        function_type_info.cc \
        fundamental_type_info.cc \
        guard.cc \
+       guard_error.cc \
+       hash_bytes.cc \
+       nested_exception.cc \
        new_handler.cc \
        new_op.cc \
        new_opnt.cc \
@@ -85,12 +94,9 @@ sources = \
        vmi_class_type_info.cc \
        vterminate.cc
 
-libsupc___la_SOURCES = $(sources) $(c_sources)
+libsupc___la_SOURCES = $(sources) $(c_sources) 
 libsupc__convenience_la_SOURCES = $(sources) $(c_sources)
 
-glibcxxinstalldir = $(gxx_include_dir)
-glibcxxinstall_HEADERS = $(headers)
-
 # AM_CXXFLAGS needs to be in each subdirectory so that it can be
 # modified in a per-library or per-sub-library way.  Need to manually
 # set this option because CONFIG_CXXFLAGS has to be after
@@ -129,7 +135,12 @@ cp-demangle.o: cp-demangle.c
        $(C_COMPILE) -DIN_GLIBCPP_V3 -Wno-error -c $<
 
 
-# libstdc++ libtool notes
+nested_exception.lo: nested_exception.cc
+       $(LTCXXCOMPILE) -std=gnu++0x -c $<
+nested_exception.o: nested_exception.cc
+       $(CXXCOMPILE) -std=gnu++0x -c $<
+
+# Libtool notes
 
 # 1) Need to explicitly set LTCXXCOMPILE so that AM_CXXFLAGS is
 # last. (That way, things like -O2 passed down from the toplevel can
@@ -166,21 +177,43 @@ CXXLINK = $(LIBTOOL) --tag CXX --tag disable-shared $(LIBTOOLFLAGS) \
          --mode=link $(CXX) \
          $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
 
+
+# Install notes
 # We have to have rules modified from the default to counteract SUN make
-# prepending each of $(glibcxxinstall_HEADERS) with VPATH below.
-install-glibcxxinstallHEADERS: $(glibcxxinstall_HEADERS)
+# prepending each of $(*_HEADERS) with VPATH below.
+stddir = $(gxx_include_dir)
+bitsdir = $(gxx_include_dir)/bits
+
+install-stdHEADERS: $(std_HEADERS)
+       @$(NORMAL_INSTALL)
+       $(mkinstalldirs) $(DESTDIR)$(stddir)
+       @list='$(std_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(stddir)/$$q; \
+       done
+
+install-bitsHEADERS: $(bits_HEADERS)
        @$(NORMAL_INSTALL)
-       $(mkinstalldirs) $(DESTDIR)$(glibcxxinstalldir)
-       @list='$(glibcxxinstall_HEADERS)'; for p in $$list; do \
+       $(mkinstalldirs) $(DESTDIR)$(bitsdir)
+       @list='$(bits_HEADERS)'; for p in $$list; do \
          q=`echo $$p | sed -e 's,.*/,,'`; \
          if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
-         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(glibcxxinstalldir)/$$q"; \
-         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(glibcxxinstalldir)/$$q; \
+         echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q"; \
+         $(INSTALL_DATA) $$d$$p $(DESTDIR)$(bitsdir)/$$q; \
+       done
+
+uninstall-stdHEADERS:
+       @$(NORMAL_UNINSTALL)
+       list='$(std_HEADERS)'; for p in $$list; do \
+         q=`echo $$p | sed -e 's,.*/,,'`; \
+         rm -f $(DESTDIR)$(stddir)/$$q; \
        done
 
-uninstall-glibcxxinstallHEADERS:
+uninstall-bitsHEADERS:
        @$(NORMAL_UNINSTALL)
-       list='$(glibcxxinstall_HEADERS)'; for p in $$list; do \
+       list='$(bits_HEADERS)'; for p in $$list; do \
          q=`echo $$p | sed -e 's,.*/,,'`; \
-         rm -f $(DESTDIR)$(glibcxxinstalldir)/$$q; \
+         rm -f $(DESTDIR)$(bitsdir)/$$q; \
        done